Sims 3 won't open: Alder Lake (Intel 12th-gen) CPU

by Fuchie

Original Post

Accepted Solution

Sims 3 won't open: Alder Lake (Intel 12th-gen) CPU

[ Edited ]
★ Apprentice



I recently built a new computer . All my games are working correctly, except the SIms 3... When I click on play in Origin or Steam, the launcher opens correctly, but then when I click on play to launch the game, nothing happens. I can't even see the Sims in the tasks manager.


I'm running on Windows 11 + the new Alder Lake processor. So the issue may comes from that... What I don't understand, is that the Sims 2 & Sims 4 are working correctly...


Could you help? 

Here is what I already tried, without any success:


- Installing Direct X9

- Removing the Sims 3 folder in my documents (the folder is being recreated automatically, but I only see the crash logs, the rest is empty)

- Activating the legacy mode in the Bios 

- Launching the game on Origin & on Steam.


I have no cc.


You will find attached my Dxdiag report. 


Thanks for your support!


edited title for visibility.  -puzzlezaddict

Message 1 of 1,324 (62,358 Views)

Accepted Solution

Re: Sims 3 won't open: Alder Lake (Intel 12th-gen) CPU

[ Edited ]

This post is being marked as the solution for visibility.  This is still considered an open issue by EA.


Edited to add links to PowerShell script and Task Manager method here.  Try these if the patch doesn't help you.


Lazy Duchess has created a patch that can be applied to the game .exe to fix the issue of Sims 3 not loading on computers with 12th-gen (Alder Lake) Intel processors.  Please understand that this is NOT an official fix.  EA had no part in the creation of this tool and does not vouch for its safety or efficacy.


If you would like to revert your game to its previous state, you can restore the backup of the .exe that the patch creates.  Or you can repair the game files:


  • EA App/1.69:  Open My Collection, hover over the Sims 3 icon, click the three dots, and select Repair.
  • Origin/1.69:  Open your Origin game library, right-click on the Sims 3 icon, and select Repair.
  • Steam/1.67:  Open your Steam library, right-click on the Sims 3 tile, and select Properties > Local files > Verify integrity of the game files.
  • disc/1.67:  Run EA's "Cumulative Base Game Super Patcher," which can be downloaded here.

The text below was quoted from this post by LazyDuchess:

@LazyDuchess wrote:

Hey there!


I hope it's okay for me to share this here.


I've been trying to find a good solution for this, and I came up with a little patcher that should work around the issue without you having to use a Powershell or third party apps to run the game (Click on "" to download):


It's completely open source.


I'm hoping this method actually solves the issue with the added benefit of not needing a custom launcher or third party app, but I'm not able to test it as I don't own affected hardware. All you have to do is extract the .zip, launch the patcher and locate your TS3.exe if you're on 1.69 or TS3W.exe if you're on 1.67, it should then patch the game and make a backup for you.


As puzzlezaddict mentioned earlier, you can find your game's executables on the program files folder:


Program Files\EA Games\The Sims 3\Game\Bin

Program Files (x86)\Origin Games\The Sims 3\Game\Bin

Program Files (x86)\Electronic Arts\The Sims 3\Game\Bin

Program Files (x86)\Steam\steamapps\common\The Sims 3\Game\Bin


Let me know if this actually works, the issue is complicated to get around due to how early in the game's execution it happens.

If you're not sure which patch level you have and therefore which .exe to patch, check the game version in the lower-left corner of the launcher.



An alternative is to use this PowerShell script, created by another player, to force Sims 3 to use one CPU core in the first few seconds it's loading.  This script is self-limiting; you don't need to do anything to restore the game's full access to the CPU.


If you get an error when trying this method, you may need to manually update PowerShell, as described here:



For anyone who can't get the above to work, try limiting the game to one CPU core in the Task Manager, as described in this post:


I don't work for EA. I'm just trying to help fellow players with their games.

View in thread

Message 268 of 1,324 (84,846 Views)

All Replies

Re: Sims 3 crashing after launcher

@Fuchie  Please try launching the game directly from TS3W.exe, rather than going through the launcher.  I'm curious whether the issue is with the handoff to the launcher or the game itself.  With Steam and Origin closed, just double-click on the .exe, which you'd find here:


C:\Jeux\Steam\steamapps\common\The Sims 3\Game\Bin


If that doesn't help, please let me know what antivirus you're using, if any.


I take it that the Legacy Mode setting in BIOS is for games that have DRMs known to flag Alder Lake processors?  I didn't think Sims 3's DRM is one of those affected, but since Origin and Steam use different DRMs, you could always uninstall the Steam version and install the game through Origin and see whether it makes a difference.  You'd need to clean the registry in between: Steam leaves two sets of registry entries behind that would need to be removed.  Let me know if you need help with that process.


Personally, I'd much rather play through Steam than Origin, but it's at least worth trying.


I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 1,324 (62,280 Views)

The Sims 3 Launcher not working

★★★★ Novice

HI ,


So yesterday my GF who really loved to play the Sims 3 wanted to jump back in after months. Since the last time I've built a new PC.


New PC System : i9-12900kF CPU,  with DDR5 1x16GB 4800 Mhz, RTX 2070 Super GPU. Gen 4 SSD.


When I'm trying to launch the Game trought origins the the Sims 3 Launcher open up then when I click on the Play Button it opens the Origins game library and nothing happens after that. 


Can someone help ? I think its probably a compatibility Issues since I have DDR5 and a Samsung Gen 4 SSD but I can be wrong.

Message 3 of 1,324 (62,319 Views)

Re: The Sims 3 Launcher not working

Hero (Retired)

@IsmaEasyy Did you go to control panel - programs and features - turn Windows features on of off and enable .net framwork 3.5? Thiis required for the launcher to work. In Windows 10 it is included but disabled.

Message 4 of 1,324 (62,289 Views)

Re: Sims 3 crashing after launcher

Hero (Retired)

@Fuchie Is this a fresh install of Win 11 or an upgrade from Win 10?

Message 5 of 1,324 (62,242 Views)

Re: Sims 3 crashing after launcher

★ Apprentice

Hi @puzzlezaddict


Thank you for your answers!


- I also tried by launching TS3W.exe only, but the issue is the same. The game immediately crashes and I can only see the crash report in my documents folder. 


- The legacy mode is indeed for the DRM issue, I tried in the hope that it could solve the problem but it didn't.


- I tried with Origin & with Steam and I have the same issue on both Frown . I would prefer to play with Origin as I have all the DLCs on my account... 


@roberta591 It's a fresh install of windows 11, no upgrade from Windows 10.



Message 6 of 1,324 (62,233 Views)

Re: The Sims 3 Launcher not working

★★★★ Novice
@roberta591 it is already enable. and for your information im on Windows 11 but I dont think it changes alot
Message 7 of 1,324 (62,265 Views)

Re: Sims 3 crashing after launcher

Hero (Retired)

@Fuchie Do you have .net framework 3.5 enabled in control panel - programs and features - turn Windows features on or off?

Message 8 of 1,324 (62,204 Views)

Re: The Sims 3 Launcher not working

Hero (Retired)

@IsmaEasyy make sure Win 11 has all the updates. Many people have reported the game works after a Windows 11 update.

Message 9 of 1,324 (62,249 Views)

Re: The Sims 3 Launcher not working

★★★★ Novice
@roberta591 Yes sir I did made sure that all my drivers and system is up to date. i`ll try to check if something apears in event reader
Message 10 of 1,324 (62,241 Views)