Help us improve Answers HQ! Take Survey No, Thanks

Re: Sims 3 won't launch with Windows 10

by Unbounded13
Reply

Original Post

Highlighted

Re: Sims 3 won't launch with Windows 10

@alexcassano   Sorry for the late reply but I have been very busy. First please post your dxdiag for your new computer. Have you tried to reinstall Island Paradise? Does the game run with IP disabled in the game launcher? Maybe try to uninstall IP in the comtoer;s control panel and reinstall from TS3 store. IP may have been corrupted during installation. After you uninstall IP, run a registry cleaner like ccleaner (there is a free copy) THEN reinstall the pack.

_______________________________________________________________

I do not work for EA or associated with EA other then helping other users in the forums.
Message 31 of 34 (240 Views)
Highlighted

Re: Sims 3 won't launch with Windows 10

★★★ Newbie

I have tried clearing the cache, uninstalling and reinstalling the whole game, and updating graphics drivers.  So far nothing has worked.

Message 32 of 34 (229 Views)
Highlighted

Re: Sims 3 won't launch with Windows 10

★ Apprentice
@Nathanos74 I am also having this issue, game was working just fine two days ago, they rolled out another patch for the Sims 4 and since then my sims 3 is broken again. Launcher opens fine, but the game opens a black screen them promptly closes. Task manager shows it as not responding. These games have been nothing but a headache lately. Did you ever find a fix?
Message 33 of 34 (74 Views)
Highlighted

Re: Sims 3 won't launch with Windows 10

★ Apprentice
@alexcassano My first work around that fixed my game was going to control panel>system and security>system>advance system settings and under "Performance" hit settings, go under Data Execution Prevention and "Turn on DEP" click add and add Sims 3, Sims 3 Starter Application, Sims 3Launcher Starter Application and TSLHelper, click apply and okay. Close everything, right click your Sims 3 shortcut> Properties "Run this program in compatibility mode for: Windows XP (SP3)" and under setting check "Run this program as an administrator" click apply and okay. restart you PC and it worked for me!
Message 34 of 34 (73 Views)
Twitter Stream