Sims 3 expansion pack not downloading from EA app

by the_ultimate_jed

Original Post

Re: Sims 3 expansion pack not downloading from EA app

[ Edited ]
★★★★★ Novice

After managing to install and run Origin, I have concluded that it's not just about the EA App itself. It's about The Sims 3, itself. When you view game properties, you can see how many hours you played, the last time you played, extra content, and such. But all of that is missing for The Sims 3 (32-bit version). Yes, every other game (I checked so far) is normal and okay, except only and only The Sims 3. It's like this game is going to 'you f* donkey' status. SHAME ON EA!


However, I believe there might be another temporary solution that I believe it would work, but I haven't tested it yet. This is kind of similar to @Beautifulfreak8's solution. But in this solution, you don't need to find an already installed/downloaded copy of the 1.69 version of the DLCs. Just download and/or install DLCs from anywhere (from Steam, disc, or elsewhere). If you ended up installing the base game too, uninstall it without removing the DLCs. You might need to move the DLC files elsewhere and uninstall the base game. Then, install LD's Launcher. Done!


In case the Origin method would work for someone:


Edit: The first paragraph reminded me of the case I had with The Sims Medieval. TSM wasn't being displayed in my Origin library for a really long time. When I switched to EA App, boom! It was there. I was able to download it but I wasn't able to launch it. So, it's been like that for a while until I had my problem aided and solved by a contact support member.


ANOTHER EDIT: Steam users can download DLCs they own without downloading the base game. Check this guide! It not only works for soundtracks for other games but also works for DLCs!

After downloading, move EPX/EPXX folders to The Sims 3 folder, where Game and GameData folders are also found. Rename EPX folders to EP0X (for instance, EP3 to EP03), this obviously excludes EP10 and EP11.

Message 301 of 313 (762 Views)

How I Fixed Sims 3 expansions packs not downloading from EA app

★★★ Novice

Just wanted to post this incase it helps someone else, in the past year or so I've had trouble getting all my sims 3 packs to install like everyone else in my case 4 expansions, University, Pets, Showtime and Paradiso. In the past I'd just install the Origin app and they'd install in the background but that stop working for me. I have Windows 10, so today, I uninstalled the EA app, tried to install origin but kept getting the whoops can't install error, like I have been for months now, so I right clicked, (on Origin set up installer) and selected troubleshoot compatibility, then when I went to install it again as admin, this time I checked the box all the way at the end that said run it as previous technical versions or something like that and I was able to install and run old version of origin, it downloaded my other 4 packs within seconds.  I still got the pop up to download the EA app but just ignored it as they installed in the background, I hope this helps someone as I know how frustrating this has been. I can close my BBB complaint with EA, for now....

Message 302 of 313 (729 Views)

Re: How I Fixed Sims 3 expansions packs not downloading from EA app

★★★ Novice
@PiercedSimmer Also I forgot to add, after I clicked run in compatibility settings which it defaulted to windows 8 version, I did hit test the program after that, then it opened up the option to install the app exc.
Message 303 of 313 (726 Views)

Re: Sims 3 expansion pack not downloading from EA app

★ Novice

I was told by someone else that I should reply to this forum with my ID Report number.


Here's the ID: 3ab451d2-d285-45c6-9572-d45b7b11356e

Message 304 of 313 (724 Views)

Re: The Sims 3 additional content kit DLC won't install on EA App

★★★ Newbie
@Somefail This worked for me. None of mine were installing until i bought EA play and cancelled the base game from reinstalling... after I did that for some reason it let me start installing all the DLCs
Message 305 of 313 (627 Views)

Re: The Sims 3 additional content kit DLC won't install on EA App

[ Edited ]
★★★ Newbie

@Miynees What kind of issue did you have? I just bought the World Adventures expansion, and it is only listed as "in-game content" and there is no way for me to download. I'm wondering if I should try this out, but I'm afraid it only works for the expansions that are "preparing" or malfunctioning. 

I even managed to download Origins, and the games started downloading in the background, except for World Adventures. It is like I don't even own it. 


Message 306 of 313 (528 Views)

Re: The Sims 3 additional content kit DLC won't install on EA App

★★★ Newbie

I also tried the renaming files workaround. However, the World Adventures-expansion-file doesn't show up anywhere. 
I have been in contact with EA, but they just tell me to wait. I hate myself for not doing better research. 

What happens if I buy the expansion again, via Steam or Instant Gaming? Would that maybe work?

Message 307 of 313 (525 Views)

Sims3 Into the Future won't download / install

★★★★★ Novice



I got a new computer and own all the dlc's for sims3, except the Katy Perry ones.  I can install all the dlc's except Into the Future won't download at all.  I tried a couple of times to clear the cache, but this hasn't been any luck.  On my old pc it worked very good, but that was in origin, so far the new ea play is giving me lots of issues, but those I all could manage to get working just this one I can't and I'm not able to download and install the origin client anymore, so I'm stuck.

I don't have any mods installed, nor have I installed any of the items from the sims store I purchased installed yet and I didn't install any other stuff like worlds etc, that may be considered mods also but they can be downloaded from within the game.

I do own the Sims4, with a bunch of dlc too, but that game still lives in the shadow of the Sims3 and after almost 10 years it still hasn't catched up to the sims 3.  In other words, I just can't have the same amount of fun in sims4 as I can in sims3, and I'm more than capable to run the game with all the dlc's, I could do that 10 years ago, and I certainly can do that now with an even bigger monster of a pc.

I sure hope this issue can be solved quickly as I have been trying to download Into the Future against better knowledge for 6 weeks now.  (well I tried on average 4 days a week and 2 or 3 times a day, it does take a long time for ea play to come up with an error and it tells me to wait a few mins, so that's atleast 1 hour of time each day I tried anyway.

Message 308 of 313 (361 Views)

Re: Sims3 Into the Future won't download / install

★★★★★ Novice

OK, I just thought I would do a reinstall too.  But I noticed something weird, the game installs fine, then Into the future wants to install seperately and then all the rest of the expansions I own want to install as part of the Island Paradise as extra content.

So maybe the problem will be solved in my instance if Into the future would be installed as extra content too.

I made a screenshot hoping to make this more clear, otherwise just allow us to install and run origin again so we can install it from there.

Also it would be nice if I close the program by clicking the X, it would actually close and won't run in the background.  Now I have 80 GB RAM, so the extra memory being used is not that much of an issue, I just don't want to run the program constantly, or give us a visible menu structure where we can exit the program easily without having to remember the menu is hidden under the 3 dashes.

Message 309 of 313 (246 Views)

Re: How I Fixed Sims 3 expansions packs not downloading from EA app

★★ Novice

I used a combination of your idea and another idea and got everything downloaded - first I bought a $1 sims 3 base game key. Redeemed it with EA. I already was able to install the base but it also unlocked all my expansion packs except 3. Then I downloaded origin. It started downloading stuff in the background that wasn’t even Sims 3 related - it was Sims 4. But then I used Origin to open EA app. I tried to download EA app again and it said it was installed. I “repaired” it, opened it and found everything installed! 

Message 310 of 313 (212 Views)