Re: Sims 3 Won't Launch Windows 11

by Invalid_Raven

Original Post

Sims 3 Won't Launch Windows 11

★★★★★ Newbie

Hi there, I know that this issue is extremely common and I've tried several threads. I'll try to link to everything I have tried as well.

Sims 4 works perfectly fine with legacy edition.


1. I have uninstalled and reinstalled both origin and sims 3, using Revo as suggested in this thread here 

2. Cleared out origin's cache.

3. Tried downloading Direct X as suggested in this thread (here)

4. Downloaded the Alder Lake Patch same thread as above 

5. I've tried running a script that was recommended on a previous thread


I'm running only on origin as my laptop doesn't have a disk drive. Prior to this, I had to merge my accounts, I remember it worked way back when but that was on windows 7.


This is my current processor:

Intel(R) Core(TM) i3-10110U CPU @ 2.10GHz 2.59 GHz


I have attached my DxDiag just in case. I paused the expansion pack downloads before I started the game but when it was installed with all the packs it still did not open.


I use windows defender as well if that assists.


Message 1 of 3 (231 Views)

Re: Sims 3 Won't Launch Windows 11

Community Manager

Hey there @Invalid_Raven,


It sounds like you may need to have The Sims 3 re-added to your account so you can access your game again. This isn't something we can do for you here on AHQ as we can't access your account details, but the live support team can help you with this.


Please reach out to live support via Twitter or Facebook, feel free to attach this conversation when you contact in so the team has something to reference. If you run into any issues with this, be sure to let me know! 


Message 2 of 3 (194 Views)

Re: Sims 3 Won't Launch Windows 11

★★★★★ Newbie

cheers, I will give them a message and see how it goes

Message 3 of 3 (183 Views)
Twitter Stream