Help us improve Answers HQ! Take Survey No, Thanks

Sims 3 Sunset Valley ocean glitch

by LachlanEllis99
Reply

Original Post

Highlighted
Accepted Solution

Sims 3 Sunset Valley ocean glitch

★★ Newbie

The Ocean in Sunset Valley Mirrors the entire town.

Message 1 of 3 (186 Views)

Accepted Solution
Highlighted

Re: Sims 3 Sunset Valley ocean glitch

@LachlanEllis99  First, try disabling the MSI Dragon Center while you play.  A couple of the errors in your dxdiag reference this software, and it's unlikely to help Sims 3 run any better.

 

You can also try changing the water quality in graphics settings.  "Mirrors only" will still look fine, so you can try that and the two higher settings.  Be sure to change the setting at the Main Menu, then quit to desktop and relaunch before testing it out.  If you change the setting while a save is loaded, or load from the Main Menu after changing a setting, you can get some very strange graphics glitches.

 

By the way, if you already did change some graphics settings and then load the game, move the entire Sims 3 game folder out of Documents\Electronic Arts and onto your desktop, then launch the game again.  Change the settings to what you want, but quit to desktop before reloading.

 

It should also be noted that GeForce Experience's offer to optimize settings usually does more harm than good.  If you have GFE and allowed it to optimize TS3, please undo that.

 

If none of this helps, the next step is to do a clean uninstall of the driver for your Nvidia 1050.  The errors in your dxdiag that specifically mention Sims 3 are most likely driver-related.  First, download Display Driver Uninstaller from here:

 

https://www.wagnardsoft.com/forums/viewtopic.php?f=5&t=2747

 

You can download the newest Nvidia driver here:

 

https://www.nvidia.com/Download/driverResults.aspx/158760/en-us

 

Next, take your computer completely offline—disable wifi and/or pull the ethernet cord—and double-click the DDU.exe.  Take note of where the file will land, and click Extract.  If it's easier, you can copy the path and then paste it into the address bar in a File Explorer window.  Open the folder and then Display Driver Uninstaller.exe, and you'll get a message that you're not in Safe Mode.  Click OK, then go to Options and enable Safe Mode dialog.  Here's a screenshot of what your options should look like; make sure the box in red is checked:

DDU 1.1.png

 

Close options, and the DDU, and then open the DDU.exe again.  For launch options, choose "Safe Mode (Recommended)," and then click Reboot to Safe Mode (you'll need your password, so find it before rebooting).  Once you login, you'll see this:

 

DDU 2.png

In the blue box, choose GPU, then Nvidia if it's not already showing.  Then click Clean and Restart red box).

 

Once your computer has rebooted, now back in normal mode, run the driver install .exe in custom mode. Select "perform a clean installation" and install ONLY the GPU driver and the PHYSX software.

 

Reboot again and see if the water looks normal in-game.  Let me know either way.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.

View in thread

Message 2 of 3 (179 Views)

All Replies
Highlighted

Re: Sims 3 Sunset Valley ocean glitch

@LachlanEllis99  First, try disabling the MSI Dragon Center while you play.  A couple of the errors in your dxdiag reference this software, and it's unlikely to help Sims 3 run any better.

 

You can also try changing the water quality in graphics settings.  "Mirrors only" will still look fine, so you can try that and the two higher settings.  Be sure to change the setting at the Main Menu, then quit to desktop and relaunch before testing it out.  If you change the setting while a save is loaded, or load from the Main Menu after changing a setting, you can get some very strange graphics glitches.

 

By the way, if you already did change some graphics settings and then load the game, move the entire Sims 3 game folder out of Documents\Electronic Arts and onto your desktop, then launch the game again.  Change the settings to what you want, but quit to desktop before reloading.

 

It should also be noted that GeForce Experience's offer to optimize settings usually does more harm than good.  If you have GFE and allowed it to optimize TS3, please undo that.

 

If none of this helps, the next step is to do a clean uninstall of the driver for your Nvidia 1050.  The errors in your dxdiag that specifically mention Sims 3 are most likely driver-related.  First, download Display Driver Uninstaller from here:

 

https://www.wagnardsoft.com/forums/viewtopic.php?f=5&t=2747

 

You can download the newest Nvidia driver here:

 

https://www.nvidia.com/Download/driverResults.aspx/158760/en-us

 

Next, take your computer completely offline—disable wifi and/or pull the ethernet cord—and double-click the DDU.exe.  Take note of where the file will land, and click Extract.  If it's easier, you can copy the path and then paste it into the address bar in a File Explorer window.  Open the folder and then Display Driver Uninstaller.exe, and you'll get a message that you're not in Safe Mode.  Click OK, then go to Options and enable Safe Mode dialog.  Here's a screenshot of what your options should look like; make sure the box in red is checked:

DDU 1.1.png

 

Close options, and the DDU, and then open the DDU.exe again.  For launch options, choose "Safe Mode (Recommended)," and then click Reboot to Safe Mode (you'll need your password, so find it before rebooting).  Once you login, you'll see this:

 

DDU 2.png

In the blue box, choose GPU, then Nvidia if it's not already showing.  Then click Clean and Restart red box).

 

Once your computer has rebooted, now back in normal mode, run the driver install .exe in custom mode. Select "perform a clean installation" and install ONLY the GPU driver and the PHYSX software.

 

Reboot again and see if the water looks normal in-game.  Let me know either way.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 3 (180 Views)
Highlighted

Re: Sims 3 Sunset Valley ocean glitch

★★ Newbie

Thank you! It worked when I Re-Installed my GPU Driver.

Message 3 of 3 (127 Views)
Twitter Stream