Help us improve Answers HQ! Take Survey No, Thanks

Script mods not working on TS4 last udpdate

by Ariadnelie
Reply

Original Post

Highlighted
Accepted Solution

Script mods not working on TS4 last udpdate

[ Edited ]
★★ Novice

Hi, I have issues with my script mods... Here are the details of my problem, but first, know this :

+ All my mods are up to date
+ My Sims 4 game is up to date (1.45.62.1020)
+ The problem is encountered with any script mod (MCC, 'the woohoo mod'...)

Description of the issue step by step  :

- On lauching the game, everything seems normal. I begin a new save with a new household, my wicked accessories appears etc so the script is recognized. (screenshot : http://prntscr.com/khn7s2)
- When I hit the check mark to proceed, I have to chose a season.
- When I chose a season, I have to chose a parcel to make my sim live. The family funds are 0$ so it can't move anywhere, and the picture on the down left is gone/greyed (a blue/grey square, see screenshot : http://prntscr.com/khn8au)
- On clicking on any parcel, I'm back to chose a season or to the CAS to make a new family... It loops (see screenshots : http://prntscr.com/khn8ho // http://prntscr.com/khn8m5 // http://prntscr.com/khn8tx // http://prntscr.com/khn90f // http://prntscr.com/khn94v)

I tried this :

- Mods desactivated : create a family and place it somewhere. Everyting ok this far.
- I save, activate the mods, restart the game
- Mods activated : I want to chose my family precedently created, but I'm back to chose a season/to make a sim in the CAS

The things I tried with the game, the mods and EA folder themselves :

- Restart the game
- Restart the computer
- Clear game cache in ProgramsData
- Repair game in Origin
- Check all mods are up to date
- Test mods 1 by 1, with and without the "Script Mods Activated" option
- Test the game without mods (everything works fine)
- Uninstall game, reinstall it
- Rename my Electronic Arts folder with "-old" so the game can create a fresh folder
- Test listed options above in this fresh folder

Also I has OneDrive installed at first, I uninstalled it and retried everything listed above.

I run on Windows 10 (see screenshot here : http://prntscr.com/khn7ag), my graphic card and all my drivers are up to date, for what it's worth...

If someone has ANY idea how to fix this, I'd be sooo grateful !!!

Thank you very much

Message 1 of 18 (9,712 Views)

Accepted Solution
Highlighted

Re: Script mod not working since new update

★★ Novice

Hi ! I post the solution I found here so it may be useful to someone : after putting my game in english (to make it short because resolving the problem took a lot of time) it finally worked !! I put it in english via Origin and via the register (changing fr_FR to en_US)

 

And yes crinrict I also posted my demand on another forum, better to  cross sources ! The people who helped me figure out the solution were on the mod's discord

View in thread

Message 4 of 18 (9,730 Views)

All Replies
Highlighted

Re: Script mods not working on TS4 last udpdate

Champion

As you already determined that it was caused by your Mods you just need to figure out which mods cause the problem. You say you tested one by one. When you did that did  every mod you tested with cause the issue?

Also you only mention Mods. If you have any CC they can also cause errors.

---------------------------------------------------------------------------------------
Please only PM me when asked to do so. Questions and answers belong here so everyone can benefit from them.

I do not work for EA or Origin. I am a player like you that enjoys helping others with their game.
Message 2 of 18 (9,684 Views)
Highlighted

Re: Script mod not working since new update

Hero

Hi @Ariadnelie

 

are you the same as this user: https://forums.thesims.com/en_US/discussion/comment/16671914/#Comment_16671914 ? If so, I believe you got it solved now ?

Happy Gaming
Crin


Trennlinie


I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.

Please only contact me via PM when asked to do so.


Important Threads


Message 3 of 18 (9,670 Views)
Highlighted

Re: Script mod not working since new update

★★ Novice

Hi ! I post the solution I found here so it may be useful to someone : after putting my game in english (to make it short because resolving the problem took a lot of time) it finally worked !! I put it in english via Origin and via the register (changing fr_FR to en_US)

 

And yes crinrict I also posted my demand on another forum, better to  cross sources ! The people who helped me figure out the solution were on the mod's discord

Message 4 of 18 (9,731 Views)
Highlighted

Re: Script mod not working since new update

★★ Newbie

I changed language in game to english, but it still doesn't work. 
Guys, please hepl me. I'm trying to solve this problem within a week and nothing happens.

Message 5 of 18 (9,599 Views)
Highlighted

Re: Script mod not working since new update

★★ Novice

Hey ! Did you try all the things I listed above? If no, try to check if one of your mods doesn't contain special characters (I had one with an "è_é" and that made my game glitch) 

Message 6 of 18 (9,588 Views)
Highlighted

Re: Script mod not working since new update

★★ Newbie

All script mods doen't work. Even when they're updated to the latest version of game.
And that's why it's kinda strange, because all cc items work perfectly.

Message 7 of 18 (9,585 Views)
Highlighted

Re: Script mod not working since new update

★★ Novice
Yeah but did you try all the things listed above?
Message 8 of 18 (9,583 Views)
Highlighted

Re: Script mod not working since new update

★★ Newbie

Yeap and that's why I lost all hope. 

Message 9 of 18 (9,581 Views)
Highlighted

Re: Script mod not working since new update

★★ Novice
Maybe the scripts aren't updated since there was an update on the game last week... Try to ask the modders in their discord
Message 10 of 18 (9,579 Views)
Twitter Stream