Help us improve Answers HQ! Take Survey No, Thanks

SIMS 3 closing, not crashing just closing.

by iisshhaa
Reply

Original Post

SIMS 3 closing, not crashing just closing.

★★★ Novice

Hello, I'm a sims 3 player and I just recently got a new pc. my sims worked fine for my laptop no crashing, no issues. and now on my new pc it just closes? not crashing closing. My houses are cc heavy, but like no issues on my laptop which has way less specs than my new pc. Any help or ideas? I've tried threads and updated, removed, but still is happening. thanks to anyone who can help!

Message 1 of 10 (446 Views)

Re: SIMS 3 closing, not crashing just closing.

@iisshhaa  Sims 3 is definitely crashing, over and over, with repeated access violations.  The question is why.  Since a couple of the crashes mention a component of the 2005 VC++ runtime, which Sims 3 uses, it's worth uninstalling and reinstalling the runtime.

 

Hit Windows key-i, select Apps, scroll down to the Microsoft Visual C++ Redistributables, click on the 2005 x86 version, and uninstall.  Then download a new one from Microsoft:

 

https://www.microsoft.com/en-us/download/details.aspx?id=26347

 

You only need the x86 version, not the others, unless some other app happens to have the x64 version installed as well.  But you don't need to uninstall the x64 version in the first place.  Restart your computer before trying to play.

 

One other critical step here is to make sure your in-game framerates aren't running wild.  Your graphics card is powerful enough to produce fps well into the hundreds, which can lead to crashes (among other things) in addition to not being good for the card overall.  To see your framerates, bring up the cheats console (crtl-shift-C) and enter "fps on" without quotes.  A number will appear in the upper right corner of hte screen, and it should never go above 60, the refresh rate of your monitor.

 

If you need help limiting fps, just ask, and let me know whether you ever play in windowed mode.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 10 (437 Views)

Re: SIMS 3 closing, not crashing just closing.

[ Edited ]
★★★ Novice

@puzzlezaddictoh wow thank you for the help, so installed the new 2005 thing, and I'm on world without the house loaded and my refresh rate is 250/260 :\ that's way above 60.. lol and i would love help getting it lower please. (:

 

Message 3 of 10 (429 Views)

Re: SIMS 3 closing, not crashing just closing.

★★★ Novice
@puzzlezaddict oh yeah and I play in windowed mode.
Message 4 of 10 (427 Views)

Re: SIMS 3 closing, not crashing just closing.

@iisshhaa  The easiest path is to set a max frame rate in the Nvidia Control Panel.  Right-click on the desktop and select the CP, then choose Manage 3D Settings > Global Settings, and you'll see this:

 

Nvidia CP global fps limiter.png

 

Turn on the Max Frame Rate setting, enter 60 in the box, click OK, then Apply.  Double-check to make sure the setting holds in-game.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 5 of 10 (411 Views)

Re: SIMS 3 closing, not crashing just closing.

★★★ Novice

so I tried this, it did read below 60, but unfortunately the closing is still happening.  

Message 6 of 10 (394 Views)

Re: SIMS 3 closing, not crashing just closing.

@iisshhaa  Please try playing in a clean user folder.  Move your entire Sims 3 folder out of Documents\Electronic Arts and onto your desktop, and when you launch the game, a clean folder will spawn with no content.  Don't add anything to it yet; just see whether the game crashes.

 

If it does, please look for related entries in the Reliability Monitor.  Hit Windows key-R and enter "perfmon /rel" without quotes.  You'll see a list of errors and updates, with a column for each day.  (Today is all the way on the right.)

 

For any errors that mention Origin or Sims 3 that happen while you're playing in the clean folder, click "View technical details," then copy the information and paste it into a reply here.  Sometimes the Reliability Monitor doesn't update right away, so if you don't see any related errors, be sure to check back an hour or two.  The timestamp on the initial chart can also be off by up to an hour, so that's not an entirely reliable metric, but the one within the technical details should be accurate.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 7 of 10 (376 Views)

Re: SIMS 3 closing, not crashing just closing.

★★★ Novice
@puzzlezaddict it worked okay with the clean folder, but it did say unrecognized graphics card when i started up. thanks again!
Message 8 of 10 (355 Views)

Re: SIMS 3 closing, not crashing just closing.

★★★ Novice
@puzzlezaddict update. I read how to get it to read the card as my last resort. and I did the first step, and I had no clue how to find the one for the other part, my game was reading 0-0 now it reads it found my card, I was in the game longer than I've ever been in the last two weeks since I moved over, but half the stuff was black, so I'm assuming it needs the other file to be updated and I have no idea how to do that one. I updated the graphics cards, and the rules I dunno how to update that one.
Message 9 of 10 (339 Views)

Re: SIMS 3 closing, not crashing just closing.

@iisshhaa  Getting your graphics card recognized isn't really necessary, and an unrecognized card usually has nothing to do with crashing.  You're only supposed to see the unrecognized card message once, but the fact that you've seen it is stored in options.ini, and a new user folder means a new copy of that file.

 

Anyway, if you want to get your card recognized, here are the instructions.  I'm posting both parts because the graphicsrules.sgr edit depends on what's in graphicscards.sgr, so if you approached the first edit differently, you may have to either redo that one or adjust the second edit accordingly.

 

These instructions only apply to and will only work for the original poster's graphics card.  If you'd like help getting your own card recognized, please post the same information from deviceconfig and ask for help.

 

Spoiler

Open graphicscards.sgr (Notepad works fine), and crtl-F to search for 10de.  That will take you to these lines:

 

vendor "NVIDIA" 0x10b4 0x12d2 0x10de
card 0x0fd1 "GeForce GT 650M"
card 0x0fd2 "GeForce GT 640M"

 

Create a new line under the "Nvidia" line, copy this text, and paste it in the new line:

 

    card 0x1e89 "GeForce RTX 2060"

So you should now see this:

 

vendor "NVIDIA" 0x10b4 0x12d2 0x10de

card 0x1c02 "GeForce RTX 2060"
card 0x0fd1 "GeForce GT 650M"
card 0x0fd2 "GeForce GT 640M"

 

(with indents from spaces that this site isn't displaying properly).  Save, quit, and open graphicsrules.sgr.  Crtl-F and search for 8800, which will take you here:

 

 elseif (match("${cardName}", "*8800*") or match("${cardName}", "*9500*") or match("${cardName}", "*9600 GSO*") or match("${cardName}", [etc.]

 

Change the bolded 8800 to 2060.  Don't change anything else, not even the asterisks.  This will classify your card as uber.

 

Finally, scroll back to the top of graphicsrules, and look for this, 8-10 lines down:

 

if ($textureMemory == 0)
seti textureMemory 32
setb textureMemorySizeOK false

 

change the 32 to 1024, and add a # and a space in front of setb.  Your card has more VRAM than that, but TS3 can only use 800 MB anyway.  The lines should look like this:

 

if ($textureMemory == 0)
seti textureMemory 1024
# setb textureMemorySizeOK false

 

Launch the game at least once to refresh the deviceconfig.log, and see whether the card is recognized.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 10 of 10 (329 Views)
Twitter Stream