Help us improve Answers HQ! Take Survey No, Thanks

Re: Sims Disappear When Traveling in World Adventures

by TallPeasant
Reply

Original Post

Re: Sims Disappear When Traveling in World Adventures

★★★★ Novice

Hey i'm having the same problem did u ever get it fixed?

 

Message 1 of 6 (171 Views)

Re: Sims Disappear When Traveling in World Adventures

@TallPeasant  This thread is pretty old, but then the issue it covers is even older.  There are a number of ways to try to get through a broken travel transition, although not all of them work all the time.  So it would help if you could provide more details: how many sims you have; where they are and where you want them to go; how old the save is and whether they've ever traveled before; what you've tried so far, if anything; etc.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 6 (160 Views)

Re: Sims Disappear When Traveling in World Adventures

★★★★ Novice

Hey! Thanks for offering your help, I’ve tried contacting EA but they don’t really help tbh. I have another issue too but this is the one I’m focusing on for now

(I play on Mac btw and have the most recent updates for the Sims):

 

Everything was fine until I recently installed “World Adventures”, “University”, and “Generations”.

 

Whenever I try to travel it loads me into the world (Univeristy & other Worlds) but my sims are invisible and don’t load no matter how longboard I wait. I can look around but it’s like my Sims don’t exist. I tried 3-5 sims at a time maybe that’s the issue?

 

i tried doing the “Edit World” trick to switch to a diff household then back but it just makes me choose a household and my actual Household I created is nowhere to be found. 

Then it wont let me switch back to my original household because “You can’t switch households while at a University or on vacation” and like I mentioned, they don’t exist in that world apparently.

 

I’ve already tried re-installing the Sims 3 and World Adventures but the problem is still there /: Any ideas?

Message 3 of 6 (149 Views)

Re: Sims Disappear When Traveling in World Adventures

@TallPeasant  I split your post into its own thread, since the previous one was quite old, and this issue is more about troubleshooting on an individual basis than any quick fix.

 

The issue isn't a faulty installation of the base game or any of your packs, it's the travel transition itself.  EA's version is broken to some extent, and when combined with the fact that the destination world has to load while information from the previous one is still being used, it's pretty common to arrive in the new world without the sims loading.  The fact that you're playing in macOS only compounds the issue, because unlike the Windows version, the Mac version can only use 2 GB RAM, leaving very little room for the game to properly manage the transition.

 

Under EA standard, the only thing you can do is try to manage RAM use and the overall stress on the game engine.  Here's how:

  • Empty out your sims' inventories as much as possible.  A few items are fine, a hundred are not.
  • In game options, turn off the in-game shopping experience and the hidden object interactive loading screens.
  • Turn off memories, not just for traveling but in general.  These are a huge resource hog.
  • Right before you want your sims to travel, use "save as" to rename the save (so you have a backup), and then quit without saving, as a separate step.
  • Before playing, take your computer completely offline: disable wifi and/or pull the ethernet cable.
  • Delete the five cache files in your game folder in Documents (CASPartCache, compositorCache, scriptCache, simCompositorCache, and socialCache).  Do this every time you quit.
  • Delete everything in FeaturedItems.  This is the Sims 3 Store trying to sell you stuff.
  • Don't open Origin—launch TS3 directly from its icon in Applications.
  • Go to the Main Menu and turn down all the graphics options to the minimum.  If your sims arrive safely, you can "save as" again, quit, and turn them back up.
  • Quit from the Main Menu and relaunch the game.
  • When the save is loaded, run the game clock for a few in-game minutes, use command-enter to switch to windowed mode, and then purge RAM:  https://bluebellflora.com/resetting-ram-during-gameplay/

It might take a few tries to get this right.  You can start by sending all the sims, and if that doesn't work the first couple of times, try it with only one or two sims.

 

The fact is though, this is always going to be difficult.  Between the RAM limit in macOS and the general brokenness of the travel transition, this might not be fixable without mods.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 4 of 6 (133 Views)

Re: Sims Disappear When Traveling in World Adventures

★★★★ Novice

Thank you for your reply,

 

so I did everything you mentioned except I can't download "Xcode" because it says it needs a certain mac version 10. something or later which is another issue I need to fix. I'll eventually figure this out. I'm just stuck there fr now. thank you so much for your help either way. By the way, do you know how to fix the bug where when you try downloading your additional content purchased from the Sims 3 store, it gets stuck on "Queued for Download"? it just gets stuck there in an endless screen and when I do click "install" from the downloads tab it closes the sims 3 window and then gives me an "Unknown Sims 3 error has occurred" and I tried contacting EA 3 times about this they even escalated my problem and I haven't gotten a call back from the "pros" and it's been 3 days. This game is so buggy it's so frustrating. thanks again for everything

Message 5 of 6 (93 Views)

Re: Sims Disappear When Traveling in World Adventures

@TallPeasant  Don't worry too much about purging RAM.  It's a bit helpful around the edges, but it's probably not going to make a huge difference.  If you also play while completely offline, purging RAM would probably free up around 20 MB of memory, which isn't nothing but also isn't going to be the difference between your being able to play and not.

 

I don't really know about the download bug because I always use Firefox.  Safari doesn't work well with the store.  I'm not even sure Firefox works on old versions of macOS, but you might look into a variant called Waterfox, which is said to be compatible with older operating systems.  Other things you can try:

  • Clear your browser cache
  • If you're stuck with Safari, go to Preferences > Privacy > Manage Website Data and delete everything (this will reset all your logins as well)
  • Make sure you don't have your browser set to block popups
  • Open the launcher before you try to download anything
  • When prompted to choose an app to open the download, choose the base game icon; if that doesn't work, use the icon of your newest pack, i.e. the one that launches the game
  • Only download 4-6 items at a time, and one at a time if you're handling worlds or other large files
——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 6 of 6 (85 Views)
sims-four-characters

Want more Sims?

Check out our Sims forums for tutorials and all things Sims.

View more

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help