Random lagging when moving camera

by ManeEvent4U2
Reply

Original Post

Random lagging when moving camera

[ Edited ]
★★★★ Novice

For the longest time, my Sims 3 game ran smoothly, even with all expansion packs, a lot of the store content as well as custom content. But recently, whenever I play a game - in a brand new world or an old one - whenever I move the camera and look at the environment around me, the FPS drops really low and it lags like horrible. If I go back to my sims home lot, or a public lot, and just look from an aerial angle, the lag disappears. Any ideas? 

Message 1 of 24 (848 Views)

Re: Random lagging when moving camera

@ManeEvent4U2  Some stutter, especially at high speeds and/or with the camera moving, is inevitable in TS3 due to the way it was made.  (Camera stutter is different than lag, where the game clock pauses for a few seconds and then catches up all at once.)  But if you want to know whether there might be a problem in your game, you can run a dxdiag on your computer and attach the results here (use the browse button).

 

https://help.ea.com/en-us/help/pc/how-to-gather-dxdiag-information/

 

It would also be helpful to see the first 40 or so lines of the deviceconfig file inside your TS3 game folder.  This will show how the game is evaluating your hardware.  You can attach that file too or just paste the first part into a response.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 24 (836 Views)

Re: Random lagging when moving camera

[ Edited ]
★★★★ Novice

I've finished running the DxDiag and have saved it. However, when following the instructions to submit my results to my case, it's telling me I currently have no cases with them, and I have attempted to submit a file through here, however, it has not worked. I've never heard of DxDiag before, so sorry for my noob-ness xD

Message 3 of 24 (828 Views)

Re: Random lagging when moving camera

@ManeEvent4U2  I meant that you could attach it here, using the "browse" button below the text field where you type your reply and above "preview" and "submit."  You wouldn't really want EA help looking over your dxdiag, anyway—it's not what they're trained to do.  If you post it here instead, I can read it, as can other responders who'd like to help.

 

I'd also like to see the first 40 or so lines of your deviceconfig, inside Documents\EA\TS3.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 4 of 24 (818 Views)

Re: Random lagging when moving camera

★★★★ Novice

On my screen, the only thing I see in that location is the "choose file" button, which I assume is the browse button. Unfortunately, it won't let me submit the file here.

 

And these are the first 40 lines of my deviceconfig file:

=== Application info ===
Name: Sims3
Version:
Build: Release
=== Rating info ===
GPU: 3 GPU Memory: 4 CPU: 4 RAM: 4 CPU Speed: 3192 Threading: 3
Adjusted CPU: 3856 RAM: 16270 Adjusted RAM: 15758 Cores: 4
=== Machine info ===
OS version: Windows 7 6.1.7601 Service Pack 1
OS prod type: 0
OS major ver: 6
OS minor ver: 1
OS SP major ver: 1
OS SP minor ver: 0
OS is 64Bit: 1
CPU: GenuineIntel
Brand: Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
Family: 6
Model: 10
Cores: 4
HT: 0
x64: 0
Memory: 16270MB
Free memory: 12217MB
User: ~~~~
Computer: ~~~~
=== Graphics device info ===
Number: 0
Name (driver): Intel(R) HD Graphics
Name (database): Desktop IvyBridge GT1 [Found: 1, Matched: 1]
Vendor: Intel
Chipset: Vendor: 8086, Device: 0152, Board: 05771028, Chipset: 0009
Driver: igdumdim32.dll, Version: 10.18.10.4425, GUID: D7B78E66-4212-11CF-D162-7D25B4C2C735
Driver version: 4425
Monitor: \\.\DISPLAY1
Texture memory: 1696MB
Vertex program: 3.0
Pixel program: 3.0
Hardware TnL: 1

Message 5 of 24 (810 Views)

Re: Random lagging when moving camera

@ManeEvent4U2  Given your deviceconfig, I really do want to see your dxdiag.  Maybe try a different browser?  I'm using Firefox, and the browse button lets me navigate to whatever file I want.  Here's what I see:

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 6 of 24 (802 Views)

Re: Random lagging when moving camera

★★★★ Novice

Oh! Thank you! And with your want to see it, is there something wrong with my original configuration?

Message 7 of 24 (795 Views)

Re: Random lagging when moving camera

@ManeEvent4U2  What I wanted to see was whether you had a dedicated graphics card that TS3 wasn't using, but your dxdiag only lists an integrated one, which matches the specs google has provided.  With only the integrated card, your computer's performance is always going to be a bit limited.  The camera stutter and other graphics issues are to be expected with the lower level cards—for best performance, the recommendation is usually an Nvidia 1050 or AMD equivalent.

 

I'm not sure whether you have the latest drivers, either, as your card may be legacy by now.  It looks like you could check by going to Dell's website for your computer and clicking on the heading "Drivers, Manuals & Support," although it won't show me anything on my mac.

 

https://www.dell.com/en-us/shop/cty/optiplex-7010/spd/optiplex-7010

 

Anyway, the bottom line is that the performance you're describing is probably as good as it's going to get on your system.  TS3 is a wonderful game, but this is one of the shortcomings we have to live with.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 8 of 24 (782 Views)

Re: Random lagging when moving camera

★★★★ Novice

The graphics card isn't the problem. I understand that I have a limited extent at which I can raise my graphics in the game, but it has never been a problem. It just, out of no where, starting lagging for no reason. My sister's game doesn't do what mine does, so it isn't connected to the graphics what-so-ever. Her settings aren't that much different from mine, and even though she doesn't use custom content or store content, I've taken it out many times and it hasn't made a difference.

 

I've uninstalled and reinstalled the game and it still does it. I'm honestly losing my mind over this and if I don't find a fix soon, I'm just gonna box the game up and move to the Sims 4.

Message 9 of 24 (740 Views)

Re: Random lagging when moving camera

@ManeEvent4U2  As I said before, hardware will wear out over time, and you've been stressing this graphics card by running TS3's most demanding packs.  Obviously, I can't be sure that this is what's happening; you could always take the computer to a specialist for an evaluation.  But cards like yours were never meant to handle the demands of even a moderate game like TS3.  Most players who have similar cards find that their performance drops off sooner or later.

 

Again, you might look into updating your drivers, if you can.  I linked the site where you could check in my previous post.  It's always worth trying.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 10 of 24 (729 Views)
Twitter Stream