Problem with 64-bit/32-bit Origin

by FutsuIsTrash
Reply

Original Post

Re: Problem with 64-bit/32-bit Origin

@jwduncan79  Are you running a 32-bit version of Windows 10?  If so, you won't be able to run the 64-bit version of Sims 4.

 

Otherwise, try repairing the game: open your Origin game library, right-click on the Sims 4 icon, and select Repair.  If that doesn't bring back the option to switch to 64-bit, try disabling your antivirus temporarily.  A few programs block or even delete TS4_x64.exe, and its absence will prevent Origin from showing you the option to play in 64-bit.  Once the .exe is back, you can set exceptions for it and Origin.exe in your antivirus.

 

If you're looking for TS4_x64.exe, it's within the game's program files.  Unless you changed the default install location in Origin, the full file path will be:

 

Program Files (x86)\Origin Games\The Sims 4\Game\Bin

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 41 of 46 (357 Views)

Re: Problem with 64-bit/32-bit Origin

★★ Novice

I am running 64 bit Windows 10, I have tried repairing the game (twice), I have uninstalled and reinstalled Origin launcher, and I still do not have that option under the Advanced Launch Options.  The only options I have are "Language" and "Command Line Arguments," neither of which are very helpful to me in solving this problem.

 

I don't know why, but for some reason it keeps shifting over to Legacy Edition at random times and when it does I always have major graphics bugs and scanning issues that give me mondo headaches.

Message 42 of 46 (349 Views)

Re: Problem with 64-bit/32-bit Origin

@jwduncan79  Please run a dxdiag and attach it to a post.

 

https://help.ea.com/en-us/help/pc/how-to-gather-dxdiag-information/

 

Please also let me know what antivirus program you use.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 43 of 46 (347 Views)

Re: Problem with 64-bit/32-bit Origin

★★ Novice

well, I would appreciate any help that anyone can offer, since the problem apparently doesn't want to settle on any one thing (sigh).  In answer to your question, my current antivirus is PCMatic (I was using AVG but it kept causing issues so I uninstalled it).

 

The problem has once again changed, *now* I have the "When launching this game..." option under the Advanced Launch Options, but the game still won't launch.  It still *claims* that today is the last time I played, but the game itself won't actually start.

Message 44 of 46 (319 Views)

Re: Problem with 64-bit/32-bit Origin

@jwduncan79  Try disabling PCMatic just to see whether it helps.  What you've described is exactly what happens when an antivirus blocks Sims 4 from starting, and if that's the problem, then other suggestions aren't going to make a difference.

 

The driver for your graphics chip is also somewhat old.  If the antivirus isn't the issue, it may help to update the driver.  You can find the newest version made by Intel for your graphics chip here:

 

https://downloadcenter.intel.com/download/30196/Intel-Graphics-Driver-for-Windows-15-40-

 

Run the driver installer as an admin: right-click on the download and select "Run as administrator."  Restart your computer after installing and before trying to play.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 45 of 46 (316 Views)

Re: Problem with 64-bit/32-bit Origin

★★ Novice

[grumble]... Well, it was the AV software.  Apparently BOTH AVG and PCMatic were blocking the TS4.exe file from starting... and not telling me they were doing it.  After changing the settings around so that I get prompted for things like that from now on, it works just fine...  Thanks for the assist.

Message 46 of 46 (308 Views)
Twitter Stream