Re: Jagged lines in Sims 4

by littlemissday
Reply

Original Post

Jagged lines in Sims 4

★★ Novice

Hi all,

 

Hopefully someone is able to help me with some issues regarding jagged lines in Sims 4.

 

PC Specs:

Nvidia GeForce RTX 3060 

Intel(R) Core(TM) i7-10700K CPU @ 3.80Ghz

15.92 GB RAM

2560 x 1440, 144Hz

 

As you can see in the picture, I have some issues with the jagged lines that appears in my game. Mostly recognizable on windows and some objects. I have tried to tweak my nvidia control panel settins most especially the anti aliasing settings but nothing seems to get rid of them. I use optimal settings on GeForce experience when running my game and all my settings in the Sims 4 are set to Ultra, so I'm not quite sure what the issues are?

 

Any help?

Message 1 of 12 (427 Views)

Re: Jagged lines in Sims 4

Hey @littlemissday,

I've moved your post to a more relevant board than EA General Questions.

-----  

do not work for EA


CCP Hero Banner - Blue.png


Message 2 of 12 (399 Views)

Re: Jagged lines in Sims 4

@littlemissday  Lines in Sims 4 are going to be a bit jagged if you look closely, but that doesn't mean you can't improve things.  Please test both in fullscreen mode at the native resolution of your monitor and in windowed mode, and let me know whether either one is better.

 

If that doesn't help, disable the GeForce Experience option to optimize game settings.  Then apply these exact settings in the Nvidia Control Panel, if you haven't already:

 

Antialiasing - FXAA: On
Antialiasing - Gamma correction: On
Antialiasing - Mode: Override any Application Setting
Antialiasing - Setting: 2x [or higher]

 

And test again in both fullscreen and windowed modes.

 

If that doesn't help either, please run a dxdiag and attach it to a post.  Your computer is likely fine; this just gives me the answers to a bunch of other questions I might ask.

 

https://help.ea.com/en/help/pc/how-to-gather-dxdiag-information/

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 3 of 12 (390 Views)

Re: Jagged lines in Sims 4

★★ Novice

Thank you for replying!

 

Before I run dxdiag, I will try these settings first. Do I apply these to global settings or the program?

Message 4 of 12 (339 Views)

Re: Jagged lines in Sims 4

★★ Novice

I tried the settings you told me, both windowed fullscreen and fullscreen, but it seems it still looks the same.

 

I applied these settings to Global Settings and not the Program Settings I also disabled Optimal Settings in GeForce Experience.

Message 5 of 12 (336 Views)

Re: Jagged lines in Sims 4

[ Edited ]

@littlemissday  I meant to say Program settings, since I don't know what other games you play and whether you'd want those affected too.  For the purposes of this thread, you could use either one, but if you're still using global settings, please make sure that you haven't changed any of these settings for TS4_x64.exe, since explicitly set program settings will override global ones.

 

I don't know whether it's directly related, but your dxdiag also lists quite a few BlueScreens that are related to the video scheduler.  So it's a good idea to clean uninstall and reinstall the Nvidia graphics driver.  First, to cover your bases (in case this is on the Windows side rather than the driver side), run a couple of basic checks of your Windows system files:

 

  • Hit Windows key-X
  • Choose either “PowerShell (Administrator)” or “Windows Terminal (Administrator),” whichever option is offered
  • Inside the window that appears, copy and paste “DISM.exe /Online /Cleanup-image /Restorehealth” without quotes into the window, and enter
  • The system will start validating soon. If it throws an error, please list it here
  • After it reaches 100%, hit Windows key-X again
  • Again, choose “PowerShell (Administrator)” or “Windows Terminal (Administrator)”
  • Inside the window, copy and paste “sfc /scannow” without quotes into the window, and enter
  • Post the message you receive here

Restart your computer, hit Windows key-i, select Update & Security, and click the box to check for updates.  If any install, restart again afterwards.

 

Here's how to clean uninstall and reinstall the driver:

 

https://crinrict.com/blog/2019/02/clean-re-install-of-graphics-drivers-with-display-driver-uninstall...

 

You can download a fresh copy of the Nvidia driver here:

 

https://www.nvidia.com/Download/driverResults.aspx/187304/en-us

 

You'll need to redo your Control Panel settings afterwards.

 

I do want to say that if you're hoping to make Sims 4 look perfect, you're never going to get there.  It always has some mild aliasing, that's just how the video engine works; it's a question of improving things as much as possible.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 6 of 12 (325 Views)

Re: Jagged lines in Sims 4

★★ Novice

Thanks for the suggestions!

 

I will try to clean uninstall and install Nvidia driver and hope for the best. If I run to any problems I'll try and post them here as welll.

 

Thank you again! Standard smile

Message 7 of 12 (312 Views)

Re: Jagged lines in Sims 4

★★ Novice

Hi, me again…

 

so..I’ve been noticing these shiny objects flickering on walls or other objects while I play sims 4? 
I don’t have FXAA on because it makes it worse and I’ve tried it on and didn’t quite help. I even had my Gamma Correction ON and nothing seems to work? 
I’ve tweaked my NVIDIA settings as much as I could and even fixed lose cables (if there were) but I still see it these flickering shiny objects…

Any advice? 

Message 8 of 12 (148 Views)

Re: Jagged lines in Sims 4

@littlemissday  What settings did you change, and did you make sure to choose the option to override the application setting wherever possible?  (You can post a screenshot or two if you don't want to write everything out.)  Does it still happen in both windowed and fullscreen modes?

 

It's also worth trying to run your monitor at 120 Hz, or 100, if that's your first option below 144.  Right-click on the desktop and select Display Settings > Advanced Display Settings, then choose the refresh rate and restart your computer.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 9 of 12 (132 Views)

Re: Jagged lines in Sims 4

★★ Novice

Thanks for replying 🙏🏼

The settings you told me before, I kept them all and yes I still have it override application. I have my antialiasing transparency on to 8x super sample coz it helped get rid of some of the jaggies  I was getting before. Only thing I added were DSR smoothness to 30%, low latency mode to ultra and DSR factors.

 

I only see these shiny flicker on the walls of my sims house whenever I try to move the screen, idk why? and changing the NVIDIA settings doesn’t really help much…I’m wondering if it’s got to do with the Mods I have? Because I have custom content installed as well but idk how I can see from the folders which ones are corrupt. I did DISM command and even the sfc /scannow and everything was okay…:/

Message 10 of 12 (111 Views)
Twitter Stream