Help us improve Answers HQ! Take Survey No, Thanks

How do I get The Sims 3 to play using Intel's Iris xe graphic card?

by mw1525
Reply

Original Post

Accepted Solution

How do I get The Sims 3 to play using Intel's Iris xe graphic card?

★ Apprentice

Hi.

 

My laptop has Intel's Iris xe (G7) card installed. How do I get the game to recognize the card? I would like to play with settings on high but the device info has the defaults all set to low with 32mbs of texture memory. How can I fix this? My system is an i5 with 12GBs of system memory and 6GBs of shared memory.

Message 1 of 17 (1,174 Views)

Accepted Solution

Re: How do I get The Sims 3 to play using Intel's Iris xe graphic card?

[ Edited ]

@mw1525  The GPU rating is 1 because graphicsrules.sgr has an entry that says other Intel cards not specified should be rated low.  Since you added your card to graphicscards but not graphicsules, that rating is still in effect.

 

Since you've done everything else, you just need to add a couple lines to graphicsrules.  Use crtl-F to search for Havendale, and you'll land here:

 

    if (match("${cardName}", "*Havendale*"))
	seti cardLevel $cardLevelMedium
	seti isCardMatched true
    elseif (match("${cardName}", "*4?00*"))

Under the word true, create a new line and copy and paste this:

 

    elseif (match("${cardName}", "*Xe Graphics*"))
	seti cardLevel $cardLevelHigh
	seti isCardMatched true

(In case it doesn't translate over, the first indent is four spaces, and the second and third are one tab, at least on my laptop.)

 

Save, quit, launch the game, quit, and check your GPU rating.  If it's still a 1, please post the line you added to graphicscards, so I can match the graphicsrules entry to it.

 

Unless you delete options.ini, your graphics settings will stay on the default low profile (minus whatever changes you've made).  You can change the settings manually or delete options.ini to let the game create a new one; there's no functional difference.

 

By the way, I would love to know how the game runs on your graphics chip, including which packs you have installed.  I haven't heard from anyone with this chip yet, but several people have asked how Sims 3 might perform, so it would be great to get some perspective from a longtime player.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.

View in thread

Message 7 of 17 (1,046 Views)

All Replies

Re: How do I get The Sims 3 to play using Intel's Iris xe graphic card?

Community Manager

Hey @mw1525 does your system have multiple GPUs? 

 

Darko

Darko.png
Message 2 of 17 (1,158 Views)

Re: How do I get The Sims 3 to play using Intel's Iris xe graphic card?

[ Edited ]

@mw1525  I've moved your thread to the Sims 3 PC tech section.

 

Please go into Documents\Electronic Arts\The Sims 3, open the deviceconfig, copy the lines between "Graphics device info" (about 25 lines down) and "Options" (about 40 lines down), and paste them here.  Once I see that info, I can post instructions for your specific graphics chip.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 3 of 17 (1,146 Views)

Re: How do I get The Sims 3 to play using Intel's Iris xe graphic card?

[ Edited ]
★★ Novice

@mw1525 You can download The Sims 3 GPU Add-on on the link: *ssnip*
Once you downloaded, open it then patch your game installed location. After patched it, launch game, your game will recognize the card. Good luck!

 

(CM: Edited to remove link to 3rd party downloads)

Message 4 of 17 (1,118 Views)

Re: How do I get The Sims 3 to play using Intel's Iris xe graphic card?

★ Apprentice
@EA_Darko - No. My PC does not have multiple GPUs.
Message 5 of 17 (1,067 Views)

Re: How do I get The Sims 3 to play using Intel's Iris xe graphic card?

★ Apprentice
@puzzleaddict - Originally the 'config' said (Found 0, Matched 1). I added my card's name to the Graphic Card (.sgr) file and left the section which said matched 1 alone. I have no ide what it is matched to. Also, I changed the texture memory from 32mbs to 1024MBs. However, my GPU rating is still level 1. Here's the info (Thanks for taking a look Standard smile.

=== Rating info ===
GPU: 1 GPU Memory: 4 CPU: 3 RAM: 4 CPU Speed: 2419 Threading: 3
Adjusted CPU: 2825 RAM: 12010 Adjusted RAM: 11498 Cores: 4
=== Machine info ===
OS version: Windows 8 6.2.9200
OS prod type: 0
OS major ver: 6
OS minor ver: 2
OS SP major ver: 0
OS SP minor ver: 0
OS is 64Bit: 1
CPU: GenuineIntel
Brand: 11th Gen Intel(R) Core(TM) i5-1135G7 @ 2.40GHz
Family: 6
Model: 12
Cores: 4
HT: 1
x64: 0
Memory: 12010MB
Free memory: 8077MB


=== Graphics device info ===
Number: 0
Name (driver): Intel(R) Iris(R) Xe Graphics
Name (database): Intel(R) Iris(R) Xe Graphics [Found: 1, Matched: 1]
Vendor: Intel
Chipset: Vendor: 8086, Device: 9a49, Board: 0a251028, Chipset: 0001
Driver: igdumdim32.dll, Version: 27.20.100.9365, GUID: D7B78E66-D909-11CF-0D57-412ABAC2D635
Driver version: 9365
Monitor: \\.\DISPLAY1
Texture memory: 1024MB <<OVERRIDE>>
Vertex program: 3.0
Pixel program: 3.0
Hardware TnL: 1


=== Options ===
AnimationSmoothing 1
LightingQuality 2
GeneralReflections 2
TextureQuality 3
VisualEffects 2
TerrainQuality 1
EdgeSmoothing 3
ObjectHiding 1
AspectRatio 0
ForceSquarePixels 1
SimQuality 4
TreeQuality 3
DrawDistance 3
MaxActiveLots 3
NumMaxActiveLotOptions 6
AdvancedRendering 1
AudioQuality 3
AudiOopsutputMode 1
VoiceLevel 255
SoundFXLevel 255
MusicLevel 255
AmbientLevel 255
FocusMute 1
VoiceMute 0
SoundFXMute 0
MusicMute 0
AmbientMute 0
EdgeScrolling 0
EdgeScrollingWarning 0
Message 6 of 17 (1,066 Views)

Re: How do I get The Sims 3 to play using Intel's Iris xe graphic card?

[ Edited ]

@mw1525  The GPU rating is 1 because graphicsrules.sgr has an entry that says other Intel cards not specified should be rated low.  Since you added your card to graphicscards but not graphicsules, that rating is still in effect.

 

Since you've done everything else, you just need to add a couple lines to graphicsrules.  Use crtl-F to search for Havendale, and you'll land here:

 

    if (match("${cardName}", "*Havendale*"))
	seti cardLevel $cardLevelMedium
	seti isCardMatched true
    elseif (match("${cardName}", "*4?00*"))

Under the word true, create a new line and copy and paste this:

 

    elseif (match("${cardName}", "*Xe Graphics*"))
	seti cardLevel $cardLevelHigh
	seti isCardMatched true

(In case it doesn't translate over, the first indent is four spaces, and the second and third are one tab, at least on my laptop.)

 

Save, quit, launch the game, quit, and check your GPU rating.  If it's still a 1, please post the line you added to graphicscards, so I can match the graphicsrules entry to it.

 

Unless you delete options.ini, your graphics settings will stay on the default low profile (minus whatever changes you've made).  You can change the settings manually or delete options.ini to let the game create a new one; there's no functional difference.

 

By the way, I would love to know how the game runs on your graphics chip, including which packs you have installed.  I haven't heard from anyone with this chip yet, but several people have asked how Sims 3 might perform, so it would be great to get some perspective from a longtime player.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 7 of 17 (1,047 Views)

Re: How do I get The Sims 3 to play using Intel's Iris xe graphic card?

★ Apprentice
@puzzleaddict - Firstly, I will be glad to share my experience with the 'xe' card. It has been very positive in terms of how it handles this game. Just tell me which areas would be of the most interest for players and I will post about them.

Okay. I made the changes to the Graphics Rules file and some seriously funny (and conflicting) settings appeared when I pressed 'Restore Defaults'. Here's the 'Updated' Rating Info and a comparison of the changes.

=== Rating info ===
GPU: 4 GPU Memory: 1 CPU: 3 RAM: 4 CPU Speed: 2419 Threading: 3
Adjusted CPU: 2825 RAM: 12010 Adjusted RAM: 11498 Cores: 4

Here's what my settings were BEFORE the change (as made by me):

My Screen Settings: GPU Rated 1

-Full Screen Mode 'Enabled' (800x600 4:3)
-Default Refresh Rate 60Hz

Detail Settings:
-Object Hiding 'Enabled'
-Animation Smoothing 'Enabled'
-Advanced Rendering 'Enabled'

-Reflections: 'Mirrors & Water'
-Edge Smoothing 'High'
-Visual Effects 'Medium'
-Lighting & Shadows 'Medium'
-Tree Detail 'High'
-Draw Distance 'High'
-High Detail Lots '3' (scared to push it with the GPU registering '1')
-Texture Detail 'High'
-Sim Detail 'Very High'


Here's the settings AFTERWARDS: GPU Rated 4

-Full Screen Mode 'Enabled' (1024 x 768 4:3)
-Default Refresh Rate 60Hz

Detail Settings:
-Object Hiding 'Not Enabled'
-Animation Smoothing 'Enabled'
-Advanced Rendering 'Enabled'

Reflections: Mirrors Only
Edge Smoothing 'Off'
Visual Effects 'High'
Lighting and Shadows 'Low'
'Tree Detail 'High'
'Draw Distance 'High'
High Detail Lots '1'
Texture Detail 'Low'
Sim Detail 'Low'

So, according to this, I'll have some really great looking Trees for as far as my eyes can see :D!
Message 8 of 17 (1,014 Views)

Re: How do I get The Sims 3 to play using Intel's Iris xe graphic card?

@mw1525  I think the low settings in the second default profile are due to the GPU memory now being rated 1.  I'm guessing you undid the texture memory change, or else started with a fresh graphicsrules that didn't have the change at all.  In case it's easier than looking it up, this is the edit you want to make, 8-10 lines from the top:

 

if ($textureMemory == 0)
  seti textureMemory       1024
  # setb textureMemorySizeOK false

But you can of course use whatever graphics settings you'd like, as long as you're happy with the overall performance.

 

What I most want to hear about are how the game runs during inclement weather (rain/snow/hail) and when there are long-haired pets or horses on-screen.  In-game framerates can be useful as a measure of how hard your GPU has to work to render each frame, both during high-stress scenarios and overall, and of course please let me know if you see any crashes.  If your card can handle the most demanding features of Pets and Seasons, then it should be able to handle everything else without any trouble.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 9 of 17 (1,002 Views)

Re: How do I get The Sims 3 to play using Intel's Iris xe graphic card?

★ Apprentice
@puzzlezaddict - Thanks! I'll have to go back and change that section.

=======

MY SET-UP:

I am running an all disk install (2009) Updated to patch 1.67.
I have an 11th Gen i5 CPU and the game is installed on NVMe SSD.

I have expansion packs World Adventures through Seasons (minus Generations - I don't own that one in disk form) currently installed.

I also have High End Loft Stuff through Diesel (minus, Outdoor Living Stuff) Stuff packs installed.

Plus, all store worlds, venues, nearly all premium content items and a large variety of sets (CAS and furniture).

In addition, I am running a host of NRaas mods including Story Progression with no turned down settings. I receive 'stories' for every Sim in the world. Pets, Supernatural and Seasons are running with all occult life states active, all animals active and weather patterns (28 days) turned fully on and active.

GAME-PLAY PERFORMANCE:

There have been no crashes, lag or slow-downs of any kind (even when a Sim gets stuck - as reported by NRaas' Error Trap). I have not encountered any color, sound or screen issues. Animations run smoothly, texture details are sharp and clear at High and (some) Very High settings.

When my Sim is running through the world, lots, trees, cars and anything else in the scene stays visibly clear with no blur.

Concerning weather, I have only experienced rain, hail storms and fog, Winter is a long way away in my game so I'll have to update this thread once it happens to give an accurate report. Hail is handled beautifully with identifiable little balls of ice touching the ground and bouncing before disappearing. Rain storms are rich as the drops fall and the water running off of the edges of nearby houses is very realistic in its flow.

All animals are displayed in clear detail. The manes and braided tails of the horses are visible without having to be very close up on the animal. Even small animals such as hedgehogs and snakes look and animate wonderfully.

FPS and CPU HEAT
-This card is very powerful! After installing the Sims 3 and before launching it, add the game (TS3W) to 'Intel's Graphic Command Center'. This has to be done manually because the Command Center will not automatically pick the game up when scanning for games to add. Once the game is added it runs at a steady 59/60 FPS no matter what is being displayed. Only in 'Map View' do the FPS drop between 30/40 FPS.

I made the mistake of running the game without adding it to 'Command Center', the FPS were 250 and upwards! The heat coming through my keyboard made it feel as if my PC would catch on fire! So, slow it down first!

Also, my system fan did not come on in times of heavy rendering. For example, during the thunder storm, while I was wandering through Sunset Valley watching the wild horses walk about, and the zombies with their colorful umbrellas plus, the vampires running with their speed blur; not once did my system fan start up.

Hope this helps Standard smile.
Message 10 of 17 (992 Views)
Twitter Stream