Graphics Card Unrecognized

by Hazyroo
Reply

Original Post

Accepted Solution

Graphics Card Unrecognized

★★★★★ Newbie

Hi! I need help in getting the game to recognize my GPU: GTX 1650 Super.

Here's the graphics device information:

Number: 0
Name (driver): NVIDIA GeForce GTX 1650 SUPER
Name (database): NVIDIA GeForce GTX 1650 SUPER [Found: 0, Matched: 0]
Vendor: NVIDIA
Chipset: Vendor: 10de, Device: 2187, Board: 8d951462, Chipset: 00a1
Driver: nvldumd.dll, Version: 30.0.14.7196, GUID: D7B71E3E-62C7-11CF-CE6B-9BAD0EC2D335

Message 1 of 5 (844 Views)

Accepted Solution

Re: Graphics Card Unrecognized

@Hazyroo  To get the GPU recognized, you'll need to edit a two files called graphicscards.sgr and graphicsrules.sgr, which are both located in the Sims 3 program files.  For an Origin install, the default file path is:

 

Program files (x86)\Origin Games\The Sims 3\Game\Bin

 

Note:  These instructions only apply to and will only work for the original poster's graphics card.  If you'd like help getting your own card recognized, please post the same information from deviceconfig and ask for help.

 

 

Spoiler

Open graphicscards.sgr (Notepad works fine), and crtl-F to search for 10de.  That will take you to these lines:

 

vendor "NVIDIA" 0x10b4 0x12d2 0x10de
card 0x0fd1 "GeForce GT 650M"
card 0x0fd2 "GeForce GT 640M"

 

Create a new line under the "Nvidia" line, copy this text, and paste it in the new line:

 

    card 0x2187 "GeForce GTX 1650 Super"

So you should now see this:

 

vendor "NVIDIA" 0x10b4 0x12d2 0x10de

card 0x2187 "GeForce GTX 1650 Super"
card 0x0fd1 "GeForce GT 650M"
card 0x0fd2 "GeForce GT 640M"

 

(with indents from spaces that this site isn't displaying properly).  Save, quit, and open graphicsrules.sgr.  Crtl-F and search for 8800, which will take you here:

 

 elseif (match("${cardName}", "*8800*") or match("${cardName}", "*9500*") or match("${cardName}", "*9600 GSO*") or match("${cardName}", [etc.]

 

Change the bolded 8800 to GTX 1650.  Don't change anything else, not even the asterisks.  This will classify your card as uber.

 

Finally, scroll back to the top of graphicsrules, and look for this, 8-10 lines down:

 

if ($textureMemory == 0)
seti textureMemory 32
setb textureMemorySizeOK false

 

change the 32 to 1024, and add a # and a space in front of setb.  Your card has more VRAM than that, but TS3 can only use 800 MB anyway.  The lines should look like this:

 

if ($textureMemory == 0)
seti textureMemory 1024
# setb textureMemorySizeOK false

 

Launch the game at least once to refresh the deviceconfig.log.  You'll know it worked if you see a [Found: 1, Matched: 1] next to the card name in deviceconfig, and texture memory listed as 1024 instead of the current 32 MB override.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.

View in thread

Message 3 of 5 (804 Views)

All Replies

Re: Graphics Card Unrecognized

★★★ Novice

I'm actually reinstalling my Sims 3 games right now and will have to go through this process, too. I used information from Carl's Sims 4 Guide forums in the past to get my GPU recognized (manually editing the sgr files), but there's a file they constantly update for newer GPU's so this time I'm going to attempt that method. Looks to be easier than manually doing it.

 

If you want to read about either method check out:

https://www.carls-sims-4-guide.com/forum/index.php?topic=26753.0

Message 2 of 5 (823 Views)

Re: Graphics Card Unrecognized

@Hazyroo  To get the GPU recognized, you'll need to edit a two files called graphicscards.sgr and graphicsrules.sgr, which are both located in the Sims 3 program files.  For an Origin install, the default file path is:

 

Program files (x86)\Origin Games\The Sims 3\Game\Bin

 

Note:  These instructions only apply to and will only work for the original poster's graphics card.  If you'd like help getting your own card recognized, please post the same information from deviceconfig and ask for help.

 

 

Spoiler

Open graphicscards.sgr (Notepad works fine), and crtl-F to search for 10de.  That will take you to these lines:

 

vendor "NVIDIA" 0x10b4 0x12d2 0x10de
card 0x0fd1 "GeForce GT 650M"
card 0x0fd2 "GeForce GT 640M"

 

Create a new line under the "Nvidia" line, copy this text, and paste it in the new line:

 

    card 0x2187 "GeForce GTX 1650 Super"

So you should now see this:

 

vendor "NVIDIA" 0x10b4 0x12d2 0x10de

card 0x2187 "GeForce GTX 1650 Super"
card 0x0fd1 "GeForce GT 650M"
card 0x0fd2 "GeForce GT 640M"

 

(with indents from spaces that this site isn't displaying properly).  Save, quit, and open graphicsrules.sgr.  Crtl-F and search for 8800, which will take you here:

 

 elseif (match("${cardName}", "*8800*") or match("${cardName}", "*9500*") or match("${cardName}", "*9600 GSO*") or match("${cardName}", [etc.]

 

Change the bolded 8800 to GTX 1650.  Don't change anything else, not even the asterisks.  This will classify your card as uber.

 

Finally, scroll back to the top of graphicsrules, and look for this, 8-10 lines down:

 

if ($textureMemory == 0)
seti textureMemory 32
setb textureMemorySizeOK false

 

change the 32 to 1024, and add a # and a space in front of setb.  Your card has more VRAM than that, but TS3 can only use 800 MB anyway.  The lines should look like this:

 

if ($textureMemory == 0)
seti textureMemory 1024
# setb textureMemorySizeOK false

 

Launch the game at least once to refresh the deviceconfig.log.  You'll know it worked if you see a [Found: 1, Matched: 1] next to the card name in deviceconfig, and texture memory listed as 1024 instead of the current 32 MB override.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 3 of 5 (805 Views)

Re: Graphics Card Unrecognized

★★★★★ Newbie
@puzzlezaddict Thank you so much! It worked! My game runs on 200 fps now. So much smoother.
Message 4 of 5 (770 Views)

Re: Graphics Card Unrecognized

@Hazyroo  I would definitely recommend manually limiting fps for the overall health of your card.  The basic process is to open the Nvidia Control Panel (right-click on the desktop to see the option), select Manage 3D Settings > Program Settings, choose ts3.exe for an Origin install or ts3w.exe (with the W) for a disc or Steam install, set vertical sync to On, and click Apply.  Enabling triple buffering can also help with the smoothness.

 

If you play in windowed mode, vertical sync won't apply.  There's a Max Frame Rate setting in the same place where you can explicitly cap fps to the refresh rate of your monitor.

 

If you need more help with this process, let me know.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 5 of 5 (746 Views)