Help us improve Answers HQ! Take Survey No, Thanks

Game won’t start after pressing play

by goat-is-fabulous
Reply

Original Post

Game won’t start after pressing play

★★ Newbie

I’ve been playing the sims 3 no problem for almost 6 years, and after installing late night and ambitions, my game won’t start after pressing play. It’s shows a blue loading circle and then nothing happens. Origin shows that the game is running but it isn’t. I’m not the most efficient when it comes to computers, but others have had the same issue and they couldn’t fix it either. I have already tried everything that EA has suggested to other people and it still won’t work. My laptop handled the game just fine. I’ve also already taken out all my CC thinking that maybe I have bad CC, but the problem still persists. I really need help to get my game running, so anything else that I could try would be help

Message 1 of 4 (164 Views)

Re: Game won’t start after pressing play

@goat-is-fabulous  An easy test is to pull your entire Sims 3 game folder out of Documents\Electronic Arts and onto your desktop.  All of your cc, as well as your other user-generated files, will be in the old folder, and the game will create a clean one.  If the game launches fine with this new one in place, then yes, there's something corrupt in your existing folder.

 

You can move your files back in batches, testing each one to make sure the game still works.  Start by testing your mods if you have them, then your cc, and leave your saves for last.  Here's a list of everything in your game folder, including explanations of what you might want to keep:

 

https://sims3.crinrict.com/en/2011/01/faq-user-files.html

 

If you can't launch TS3 even after removing the game folder, please run a dxdiag and attach the results to a post here.

 

https://help.ea.com/en-us/help/pc/how-to-gather-dxdiag-information/

 

Or let me know if you're on a Mac.  Either way, please post any error messages you get.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 4 (144 Views)

Re: Game won’t start after pressing play

★★ Newbie

it still didn't launch, but here is the report you asked for.

Message 3 of 4 (126 Views)

Re: Game won’t start after pressing play

@goat-is-fabulous  After you removed your TS3 game folder, was a new one created in Documents\EA?

 

Try temporarily disabling your antivirus/firewall, just long enough to test whether TS3 will launch.  If it works, set exceptions for Origin.exe and TS3.exe.

 

If this doesn't help, I need a bit more information.  Windows 7 doesn't list error reports in the dxdiag, so it would be helpful to see any TS3-related entries in the Reliability Monitor.  Someone else wrote out how to find them here:

 

https://answers.ea.com/t5/Technical-Issues/Anthem-help/m-p/7684157#M22660

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 4 of 4 (120 Views)
Twitter Stream