Help us improve Answers HQ! Take Survey No, Thanks

Framerate isssue in 'Live mode'

by SWEYLYN1
Reply

Original Post

Highlighted

Framerate isssue in 'Live mode'

[ Edited ]
★★★★ Novice

Hi,

my problem is that the game is basically unplayable due to the single digit framerate in 'Live mode' (Town map, Build/Buy, & CAS works fine). Two days ago, the game crashed without any warning. Since then I have this issue.

Things I tried: starting the game without CC - it worked fine, so I moved the Packages folder to the desktop and pulled back a copy of it from a thumb drive I dedicated to game backups. I tested the game like a month ago with those mods and it was working fine back then. Launched the game - same issue.

Next I verified the game files - Origin verified the game files, they aren't corrupt

The external SSD was next - chkdsk reported no defects

I saved my household and their home to the bin and started a new game - everything was working fine. It was late in the night, so I saved and quit the game. Today I loaded it up the game now runs with 3-9 FPS in Live mode but in Build/Buy mode it runs with 22-59 FPS.

What can I do to make the game playable again?

Message 1 of 5 (203 Views)

Re: Framerate isssue in 'Live mode'

@SWEYLYN1  The first, simplest thing to try is deleting the five cache files in your TS3 game folder in Documents.  They should be deleted regularly anyway, since they tend to clog up with stale data.  You should definitely delete them any time you're troubleshooting as well.  For reference, they are:

  • CASPartCache.package
  • compositorCache.package
  • scriptCache.package
  • simCompositorCache.package
  • socialCache.package

If this alone doesn't help, pull your entire game folder out of Documents\Electronic Arts and onto your desktop.  Launch the game to create a new game folder; no need to go further than the Main Menu.  Quit, go into Saves inside your old game folder, and copy the folder with your most recent save in it.  Paste it into Saves in the new game folder.  Load this save and test your fps.  Since your cc won't be present in the new folder, you'll get a missing object warning, but this is fine, since the point is to test, not to save your progress.  (And you have a backup copy of the save in the old game folder.)

 

One note:  If you've been playing in a Store or custom world, you'll need to have that world file in your new game folder.  The easiest thing to do would be to just reinstall it before testing.

 

If the game runs fine in the new game folder, you can start copying over your mods and cc in batches, testing after each batch.  (Be sure to delete the cache files every time you quit.)  If any batch causes the game to not run well, you'll need to split it and test until you find the problem file(s).

 

If you still get low fps in the new game folder even without your mods and cc, then this is likely either an issue with your save or with your system.  What world are you playing in?  When you saved your sim family to the bin, did you quit to desktop before starting a new save?  Which mods do you use?  (It's fine to name them unless they're adult-themed, in which case just make some kind of oblique reference that I'll understand.  I think I've heard of all of them.)

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 5 (182 Views)

Re: Framerate isssue in 'Live mode'

[ Edited ]
★★★★ Novice

I regularly deleting the cache files so that can't be an issue.

There are lots of mods but most of them are just clothes/decorations. There are couple makeups/skintones for custom sims. The script mods are the following:

  • taxi charge
  • NRaas Story Progression
  • NRaas Overwatch
  • NRaas Decensor
  • no intro
  • no build sparks

I don't know the game's actual requirements, but I think an Intel core i7-7700HQ CPU, 8 GB RAM and an AMD Radeon RX 560 GPU should be enough to run this game.

Message 3 of 5 (176 Views)

Re: Framerate isssue in 'Live mode'

@SWEYLYN1  StoryProgression can cause a lot of lag, not because it's poorly made but because when running at high speeds, it makes a lot of demands on the game engine.  Try turning the speed down to Slow or Snail and see if it helps.

 

Other than that, I'd still like to know how the save runs in a clean game folder.  There are other potential issues with your existing folder besides the cache files, and a clean folder is the quickest way to find out.  I'd also like to know what world you're playing in, since some of them are poorly made enough that the game engine will grind to a halt trying to maintain them.

 

And yes, your specs are more than fine for TS3.  There could be other system issues though.  But it's easier to rule out issues with your save first.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 4 of 5 (162 Views)

Re: Framerate isssue in 'Live mode'

[ Edited ]
★★★★ Novice

I moved the Mods folder to the desktop and the game worked fine. Once I've put it back, there was the same issue. Now I reduced the number of mods to 60. What I left are the following:

00|altea127's lingerie for little girl
01|Angel of Fire
02|Beauty of the Orient
03|Chaotic Elements - Water_ziggy28TSR
04|Chaotic Elements Fire_ziggy28TSR
05|Dragon Attack
06|ESkin-nATURAL+Default-F
07|ESkin-Natural+Light
08|F-P_1985_Toyota_Sprinter_Trueno-AE86_TS3
09|F-P_2018-Honda-Civic-Type-R_TS3
10|Fairies_byRirann@TSR
11|Fairy painting 3
12|Fairy Wings_ziggy28TSR
13|Fantasy Dream Eyeshadow
14|fantasy II
15|Fantasy Picture 1
16|Fantasy Picture 2
17|Fantasy Style Anime Eyes
18|Fantasy.disabled
19|Flower Fairy_marcorse
20|Frozen Blossoms_ziggy28TSR
21|Futuristic Painting #1 by DP
22|Futuristic Painting #2 by DP
23|Futuristic Painting #3 by DP
24|Futuristic Painting #4 by DP
25|gemini_ziggy28
26|GirlsSwimwear
27|Juliana_AdidasSportPants_Child
28|Juliana_AdidasSportShorts_Child
29|Juliana_AdidasSportTop_Child
30|Magic Garden_marcorse
31|Moonlight Unicorn
32|Nightcrawler_AF_Hair_Moonlight
33|NoBuildSparkles
34|nointromaxis
35|PaintingGirlFantacy
36|Painting_Fantasygodess
37|PSpsnaturalA
38|PSpsnaturalND
39|Red Dragon By Dragoncat
40|S3 Child Onesie Mh75
41|sebrof77 - Chio v05-17-1750
42|sebrof77 - Song of Clouds v05-24-1402
43|sebrof77 - The Keeper v05-17-1750
44|sebrof77 - Too Cold to Snow v02-04-1035
45|sebrof77 - Whisper v05-17-1750
46|Sims3_Lemonleaf_skin A2.5 Non Default
47|Sims3_Lemonleaf_skin B2.5 Non Default
48|Snowfall_marcorse
49|Sonata77 child girl 13
50|StargirlHair_001
51|Swimwear for girls
52|The Colour of Dreams_marcorse
53|The Red Tour - Love Story Dress
54|There Be Dragons_marcorse
55|TS_Modern Art II
56|Winter Roadway_marcorse
57|Winter Wonderland By Dragoncat
58|ziggy28_libra
59|[PS] Dragon Blood Eyeshadow

 

2 cars, couple of clothes, skins & makeups. The rest are paintings.

I tested the game with a new Documents\Electronic Arts\The Sims 3 folder and the results were the same; it worked without the mods but lagged with the mods. There's also lag if the mods are in place but the 'Run without CC' option is checked in the launcher. I also tested the game with only the nobuildsparkles and the NoIntroMaxis mods left and it also works fine. Now I'll test it with only the above listed mods and update this comment to include the results.

Edit: the game runs fine with only these mods. Now, I'll put back everything else (except for Story Progression) and see what happens.

Message 5 of 5 (121 Views)
sims-four-characters

Want more Sims?

Check out our Sims forums for tutorials and all things Sims.

View more

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help