Re: [ISSUE] Loading family just loads Map again - PLEASE READ FIRST POST

by crinrict
Reply

Original Post

Accepted Solution

[FIXED] Loading family just loads Map again

[ Edited ]
Hero

Update: If you are facing this issue after patch 1.24.102 (Oct 27th), please take a look to this thread.

 


 

 

This is currently not an issue

 

If you still have it, it's most probably mod related. Remove your mods.

 


  

Cause

 

This problem isn't as much as a bug but a symptom of a problem that occurs in your game. The game tries to load the household and then hits a problem/corruption and can't load the lot because of that. It then bounces back to the world screen.

 

EA/Maxis has fixed a lot of causes for this since it first started happening but there's still issues around and causes need to be found. It could be something on the lot or a faulty Sim or object. You can either try troubleshooting yourself or upload your save game so EA/Maxis can take a look at it. They might find a cause and fix it in the next update.

 

Outdated mods are a major player in this so if you can't pinpoint your error to a specific save game, it's probably a mod.

 

An other issue with this is that once you have it in one household, it spreads to all others and also other save games if you don't close down the game completely. Going to the main menu will affect other save games.

 

Also there's no guarantee that it's not coming back after playing a while so make sure to make backups.

 

So for troubleshooting, always close down your game and restart before trying something different.

 

 

Before posting please try the solutions below:

 

For all the solutions, it's essential, that you close down your game after each time you encounter the map reloading. If you don't, the bug just carries over from save game to save game.

 

It's also good if you rename you user folder and JUST put back the broken save game. Nothing else. Be aware that this will remove all custom content from your Sims so don't save your game in that state. Once you have it back in working condition. remember what you did to make it work, then add back your hair, clothing, skins and objects (NO MODS). Then try again.

 

If it still works and you have all your custom content back, you may save the game under a different name. You can then start adding stuff back but don't bother with any cache files. You only need to put back what's listed in the article. The slot_00000001.save and the scratch folder are also not important.

 

Issue with unfinished paintings/broken easel

 

Spoiler
  1. Close down your game
  2. Start your game and load the faulty save game
  3. Go to the family you have last played with and go straight to build mode
  4. Delete any easel/drawing tables including unfinished paintings
  5. Go back to map view
  6. Load your family

Issue with relationships 

 

Spoiler

For this method which does take a lot of time, it's very important, that you close down your game each time you have the bug or if you have deleted Sims that don't need deleting. If you don't care about the households, you can leave them deleted of course.

 

  1. Close down your game
  2. Start your game and load the faulty save game
  3. Delete ALL households from your game via Manage world (yes, that may take a while)
  4. Go to the library and  download use a Maxis single household to place in any home.
  5. Check if that household now loads. If this is the case, it's most probably a faulty relationship
  6. Close down your game again and then restart and reload the save game
  7. Go to manage world to narrow down the household. Start with the played Sims and delete them neighborhood by neighborhood. Try loading a family after deleting all families from one neighborhood. Close down the game and restart after each.
  8. Once you found the neighborhood the faulty family is in, you need to narrow down the family. Use the 50/50 method.
  9. Once you have found the family, narrow down the faulty Sim in it. Take them to CAS via Manage Household and determine the faulty one by deleting, again using the 50/50 method.
  10. Once you have narrowed down the faulty Sim, split him from your household and upload to your library. 
  11. Delete the faulty one
  12. Load your remaining household and re-place him from the gallery. You can't reset the relationships but that might be possible with a cheat, didn't try.

There is a chance that the issue does not lie with the Sim but with an easel in that house. Use the method above in the house that faulty Sim lives to find out if deleting the easel also resolves the issue (without having to delete the Sim)

 Issue with pictures of content you don't own

 

Spoiler

Taken from this post: /t5/The-Sims-4/ISSUE-Loading-family-just-loads-Map-again-Need-your-bugged-save/m-p/4614110#M46921


@veroUKfr wrote:

  

Temporary solution :

 

  1. Delete all cache (cache, cachestr and localthumbcache.package)
  2. From the map view place another lot on top of the one containing the outdoor retreat paintings

 

Then everything comes back to normal.

And you can place the lot with the paintings again, delete them, and then use the lot normally.

 


 

If none of the above help, try troubleshooting as below

 

 

If you need help narrowing down the issue, zip this folder: documents\electronicarts\thesims4\saves and upload to mediafire or dropbox. Then post the the link. I can't promise to look at all of the but EA is still reading this thread and borked savegames help to reproduce the error. 

 

If you are uploading your saves folder, please state which game you have issues with and which family doesn't load or what you're doing. Also post which Addons you have.

 

 

Instructions how to salvage your house and Sims if the game no longer works

 

Spoiler

You should still be able to upload to family/house to the gallery (or just save to your library) and put them in a new game (This might not work for the newest problem occurring)

 

Here's how:

 

Household

 

  1. Click Manage Household
  2. Click on the families you want to save, choose Edit, add, remove Sims from thhe houshold in CAS
  3. Click on the Icon in the uppper right corner to save the family
  4. Click on save to library.
  5. Go back to the main menu
  6. Start a new game
  7. Load the Family from your library
  8. Place in a lot

House

 

  1. Put Origin in offline Mode (this is important)
  2. Start the game
  3. Load your save game
  4. Enter your house in build mode (this probably only works if your in offline mode)
  5. Save the lot to your library and place in a new game

 

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.



Important Threads


Message 3 of 171 (63,202 Views)

Accepted Solution

Re: [FIXED] Loading family just loads Map again

[ Edited ]
Hero

Glad it's solved.

 

I'm going to lock this thread now because it has run it's course and the original issue was fixed a while ago

 

If anyone still has this issue, please make a new thread.

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.



Important Threads


View in thread

Message 171 of 171 (37,779 Views)

All Replies

Re: [ISSUE] Loading family just loads Map again - PLEASE READ FIRST POST

[ Edited ]
Hero

<reserved>

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.



Important Threads


Message 1 of 171 (62,381 Views)
0

Sims 4 won't let me play

★★★ Newbie

I open the game and it looks like it works but when I go to click on a family/household it goes to the opening screen. It takes the same amount of time to load as it normally does but it wont open my family. It goes right back to the start where you choose a world. I also tried going through creating a new family. It let me create a new family but wouldn't let me play it once I chose the house.
If it helps, its just done an automatic update and I've clicked the repair game.
Please help

Message 2 of 171 (62,416 Views)

Re: [ISSUE] Loading family just loads Map again - PLEASE READ FIRST POST

Hero

<reserved>

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.



Important Threads


Message 4 of 171 (63,108 Views)

Re: [ISSUE] Loading family just loads Map again - PLEASE READ FIRST POST

★★★ Novice
Hi again @crinrict Standard smile here is the link to my save file again.
Thank you

https://www.mediafire.com/?77icsnj6l2jrh84
Message 5 of 171 (63,095 Views)
0

Re: [ISSUE] Loading family just loads Map again - PLEASE READ FIRST POST

★★ Novice

Had to completely restart my Sims 4 game and delete all my households in the end. I tried to replace the Arwood family but it did nothing. At least my other family's in my library! I can play now.

Message 6 of 171 (63,087 Views)
0

Re: [ISSUE] Loading family just loads Map again - PLEASE READ FIRST POST

Hero

@hexvia wrote:
@Hi again @crinrict Standard smile here is the link to my save file again.
Thank you

https://www.mediafire.com/?77icsnj6l2jrh84

Just tested yours, check my post in the old thread

 

@Satharen Did you close down the game completely, then restart it, then load your save game, then go to manage world, split the faulty sim, upload to the library, delete it, and then replace into the family from the library ?

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.



Important Threads


Message 7 of 171 (63,088 Views)

Re: [ISSUE] Loading family just loads Map again - PLEASE READ FIRST POST

★★★ Novice
Hi @crinrict ! I did do all steps in the original thread and unfortunately had no luck. Thanks for checking!
Message 8 of 171 (63,077 Views)
0

Re: [ISSUE] Loading family just loads Map again - PLEASE READ FIRST POST

[ Edited ]
Hero

Try this then

 

  1. Close the game
  2. Backup your user folder
  3. Rename the user folder documents\electronicarts\thesims4\ to documents\electronicarts\thesims4_Backup\
  4. Start the game to let it create a new user folder
  5. Close the game
  6. Find Slot_00000004.save in this folder documents\electronicarts\thesims4_Backup\saves and copy it to documents\electronicarts\thesims4\saves
  7. Start the game
  8. Start your save game
  9. Go to build mode
  10. Do the up/down thing again
  11. Go back to map view and try again.

@hexvia

 

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.



Important Threads


Message 9 of 171 (63,065 Views)
0

Re: [ISSUE] Loading family just loads Map again - PLEASE READ FIRST POST

★★★ Novice
Still no luck unfortunately Frown
Message 10 of 171 (63,062 Views)
0
Twitter Stream