Help us improve Answers HQ! Take Survey No, Thanks

Error message when trying to read

by AlexandraGold
Reply

Original Post

Error message when trying to read

★★★★ Newbie

Every time my sim tries to sit down and read a book (anybook as far as I have tested) I get an MCCC last exception message when I check the text file it says this ;

 

<report><version>2</version><sessionid>83d1542bee6743745cc1d746</sessionid><type>desync</type><sku>ea.maxis.sims4_64.15.pc</sku><createtime>2019-04-25 17:27:37</createtime><buildsignature>Local.Unknown.Unknown.1.51.77.1020-1.200.000.389.Release</buildsignature><categoryid>balloon_variant.py:51</categoryid><desyncid>83d1542bee6743745cc1d746</desyncid><systemconfig/><screenshot/><desyncdata>Exception in Sim Timeline: Exception running Element (TypeError: __init__() missing 1 required positional argument: 'definition')&#13;&#10;Traceback (most recent call last):&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\scheduling.py", line 212, in simulate&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\animation\animation_element.py", line 1150, in _run&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\balloon\tunable_balloon.py", line 167, in get_balloon_requests&#13;&#10; File "T:\InGame\Gameplay\Scripts\Core\sims4\tuning\tunable.py", line 523, in __call__&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\balloon\tunable_balloon.py", line 75, in factory&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\balloon\tunable_balloon.py", line 187, in select_balloon_icon&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\balloon\tunable_balloon.py", line 178, in _get_balloon_icons&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\balloon\balloon_variant.py", line 51, in get_balloon_icons&#13;&#10;TypeError: __init__() missing 1 required positional argument: 'definition'&#13;&#10;rtim=0</desyncdata></report>
</root>

 

 

I tried to go to the files indicated but I am not particularly good with this sort of thing. I found an old thread and it suggested deleting caches which I did, it didn't resolve the issue. I've also tried repairing the game and taking out my mods etc with no luck. I'm willing to try anything! Thank you in advance

Message 1 of 3 (200 Views)

Re: Error message when trying to read

Hero

HI @AlexandraGold 

 

I tried my game and I'm not getting any exceptions.

 

Could you test if it happens in an different household and a new save as well ? Just for testing.

Happy Gaming
Crin


Trennlinie


I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.

Please only contact me via PM when asked to do so.


Important Threads


Message 2 of 3 (189 Views)

Re: Error message when trying to read

★★★★ Novice

Hi @AlexandraGold,

I have had the same Last Exception Error message in the last few days. I went through my Mods/CC Folder(s) today and figured out that for me, the "culprit" were the "Pufferhead_Books" from the new Pufferhead Stuff Pack (fan made). I deleted the files and downloaded the updated version (v1.6.1) and my sims can read normally again. I hope this helps!

Message 3 of 3 (166 Views)
sims-four-characters

The Sims 4 Patch Notes

Check out the latest updates and bug fixes

View more on EA Help
white-sims-bg

Restore a previous saved game

Choose from an automatically stored save point in The Sims 4 if your data's corrupted or you want to revert anyway.

View more on EA Help

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help