EA App: Sims 3 Create a World Edit in-game doesn't work

by Matthew22254563
Reply

Original Post

Re: EA App: Sims 3 Create a World Edit in-game doesn't work

★★ Novice

After reading EA_Cade's comments here , I started wondering if the best (and potentially easiest) solution for EA would be to release a build-mode-only version of TS3 for world developers.  I mean, we don't need the full functionality of the game for EIG work.  And build and play modes operate from different (albeit connected) code cores, don't they?  Maybe it could be possible to snip them apart and put out a build-only shell engine to work with CAW.

 

Of course, I have limited programming experience and maybe this wouldn't be an easy thing to do.  I just feel like this shouldn't be as complicated as EA seems to be trying to make it.

 

 

Message 41 of 89 (2,125 Views)

Re: EA App: Sims 3 Create a World Edit in-game doesn't work

[ Edited ]
★★ Guide

@natashajones615 I think you figured out something, but my feeling is that they won't do what you've just asked.

 

I'm going to throw out a theory as to what I think happened with EIG and the EA App. I believe that this was all by design--not for malicious purpose; instead, out of misguidedness.

 

I say that because I've seen that over the past several years, there's been an industry-wide trend in the tech sector to force users into these highly restrictive ecosystems for some reason or other (safety issues, licensing, etc.). These ecosystems have become so heavy-handed that they're now crippling programs and in some cases hardware on people's systems.

 

For example, longtime simmers remember the frustration of Microsoft putting out an update that crippled Sims 1 in Windows 7, then completely killed the game in Windows 10. I have had software (not gaming but vide editing) suddenly get crippled when the manufacturer dropped support for codecs. Microsoft also released Windows 11 demanding something known as TPM, now cutting off millions of users who are still on older machines.

My theory is that the whole point of EA App is to force users to migrate to this restrictive ecosystem for security and anti-piracy measures, and that for whatever reason, they just don't want EIG baked into the App.

Message 42 of 89 (2,094 Views)

Re: EA App: Sims 3 Create a World Edit in-game doesn't work

★★★ Novice
@Matthew22254563 Same problem here, and now there's no avoiding the EA app - you'll be forcibly logged out mid-game as it undoes your Origin installation to replace itself.
Message 43 of 89 (1,916 Views)

Re: EA App: Sims 3 Create a World Edit in-game doesn't work

★★★ Newbie
Message 44 of 89 (1,730 Views)

Re: EA App: Sims 3 Create a World Edit in-game doesn't work

★★★ Novice

I just got this very same problem yesterday when I tried to load up the existing CAW file in Edit-In-Game, and it launched as the normal TS3 play not as the CAW town I tried to load. I have switch from Origin to EA App since December 2022, and every worked just fine, except recently.

Message 45 of 89 (1,616 Views)

Re: EA App: Sims 3 Create a World Edit in-game doesn't work

★★★★★ Novice

This really needs a fix. I have a town I spent hours working on, scultping, landscaping, painting, building lots, placing trees, even making custom objects and buildings to place in the town that now will never be finished. I had started to make sims that would be townies for it as well, but now... it was all a waste..

 

So "thanks" a lot EA....  I could say more, but I don't want this post to get deleted for use of profanity...

Message 46 of 89 (1,503 Views)

Sims 3 Create-A-World tool cannot run ingame

★★ Newbie

I'm not sure if this really falls into the category of The Sims 3, as it is an external program. However it is official by EA, so they would be responsible for this problem. Over the course of the last few months, I've been building a world in the Sims 3 create-a-world tool. However, due to the EA app and fully patching off Origin, it is now impossible for me to edit my town ingame. This means I won't be able to edit any lots. Is there a way to get it to work again? I've been very passionate about the project, and I don't want it to be put to a stop just because of disgusting promotion of a new app.

Message 47 of 89 (1,477 Views)

Re: Sims 3 Create-A-World tool cannot run ingame

Hero
@Rockhopper2020 Unfortunately, there is no way to use EIG with EA App unless EA releases an official fix.

If you own disk versions of the game (with a 2009/2010 version of the base game; you can check the year on the disk), or if you get the game on Steam (packs are currently on sale), CAW for those versions should be able to run in EIG mode. I understand that switching versions is not something you might have wanted, but right now that is the only way to use EIG.

CCP Hero Banner - Blue.png


Message 48 of 89 (1,454 Views)

Sims3 Create A World not working with EA App

★ Novice

Ever since Origin was replaced by the EA App the Sims3 Create A World tool fails to properly launch Sims3 when you try to edit in game. I'm guessing that it is trying to send some parameters to the Sim3 app to tell it to open a specific file in edit mode. The Origin app obviously passed these parameters along to the game while the EA App must not. The solution would be to have the EA app pass along any parameters to any game that has to be run via the EA App. That would most likely solve the problem with CAW and if there are other games run via the EA App that have utility programs that trigger the game to run in a special mode would fix any similar problems with them.

Message 49 of 89 (1,217 Views)

Re: EA App: Sims 3 Create a World Edit in-game doesn't work

★★★ Newbie

I have the same problem. Last year, around September 2022 EiG-function worked great for me. Now it doesn't anymore, as I discovered yesterday. I can create a new world, edit with all the functions in CAW, but if I try EiG EA desktop pops up and tells me the game failed to launch. Very frustrating. I've tried reaching out to EA, but they are not really likely to give any helpful answers about this.

 

Something very strange is also happening, when I try editing a new (created yesterday) world what I described above happens, but if I do the same with a world I was working on last year (between May and September) the EiG kind off works. It launches at least, and allows me to edit like normal until i try to save and exit back to CAW when the save fails. The graphic settings are also completely off, they revert back to the standard settings, and since the save fails I can't restart the game as it needs when making changes in the graphics... aaand for some reason launching EiG messes with the settings I have in the full game too. Very, very confusing. Has anyone experienced this as well?

 

I saw a reddit post ( https://www.reddit.com/r/Sims3/comments/15l619u/fir_island_not_yet_finished/ ) about CAW where two people claimed EiG works again, but as of today it still doesn't work for me. Have anyone gotten it to work again? 

Message 50 of 89 (1,039 Views)