Re: EA App: Sims 3 Create a World Edit in-game doesn't work

by raestacey

Original Post

Re: EA App: Sims 3 Create a World Edit in-game doesn't work

★★ Novice

Hey! So i managed to solve the error on my computer, the thing i did is:


- I saw what directory my The Sims 3 was installed on.

- I moved my CAW world files to the same directory it was installed.

- It worked!

Message 51 of 59 (659 Views)

Create a World Tool not editing-in-game

★ Novice

I have been using Create a World since its release back in December 2009 and have created many worlds albeit not for over a year.


The problem is today I started a new world, added a layer and created a few lots then saved the new world. Secondly I chose to Edit-in-Game - the world closed and looked like the launcher was starting - however it is opening the launcher for the Sims 3 game and not the CAW program with this new world that I have started. The launcher sits there waiting for me to press and play (which I did DO!) only to find it is only my saved games.

I have tried restarting my computer, doing some computer maintenance (disk clean-up etc) but to no avail.

I have tried editing other worlds I have created and still have the CAW files and it still does the same thing - i.e. launches my Sims 3 game.

Is this unique to the EA app - I think it was the origin app I was using before.


Thank you in advance for anyone who can help.Standard smile


Message 52 of 59 (560 Views)

Re: EA App: Sims 3 Create a World Edit in-game doesn't work

[ Edited ]
★★★ Novice


Message 53 of 59 (452 Views)

Re: EA App: Sims 3 Create a World Edit in-game doesn't work

★★ Novice

Hi, please explain how i would do this. Thank you in advance. 

Message 54 of 59 (347 Views)

CAW - does it work with EA?

★ Novice

Hi folks...


So i left sims for a few months came back to the EA crap going on. 


decided one day that i am going to make a sims3 world again.


got through the drama of changing from the "not broken origin" to the mess of EA... and now CAW (create a world) won't work



Has anyone got any tips on how to make CAW work with EA? 


I googled and it said to load through origin (but this what when they were existing side by side) now there is no origin?


any advice...


I really want my eco australian futuristic beach town with legacy houses built! 


thanks team Sim


please save me!

Message 55 of 59 (157 Views)

Re: EA App: Sims 3 Create a World Edit in-game doesn't work

★★★ Novice
@raestacey With EA app your Sims 3 has a new directory.
1. You should "search your pc" for a Sims 3 pack, I used my newest one, ITF. ( The directory I found under programx86 is where I found CAW, but it was not the current directory for the Sims 3 with EA app.)
2.Right click to open file location. This file should have all of your Sims 3 EPs and SPs. ( My new directory is : This PC > Local Disk > Program Data > Origin > Local Content )
3. Copy and paste entire CAW file into the new directory.
4. Load Edit in Game.
IT WILL WORK! It's amazing, Dona_Neve in this thread, a few comments above this one, figured it out!

***Note: If you are 12th GEN and need the powershell script work around to play the Sims 3, you will need to launch the powershell before edit in game, but no changes need to be made to the script. If you don't know what I'm talking about, ignore this note :D
Message 56 of 59 (127 Views)

Re: EA App: Sims 3 Create a World Edit in-game doesn't work

★ Novice

Ooooooh ok


so there is actually hope then!!!! OMG


Well i don't have time to try now as its kid dinner time. but i wanted to say thank you right now for helping in case i forget later.


thank you kindly. OMG i hope it works for me! my sims files are such a mess due to a new computer and cut and paste and changing hard drives.. lol... see how we go...


fingers crossed!!!!



Message 57 of 59 (120 Views)

Re: EA App: Sims 3 Create a World Edit in-game doesn't work

★ Novice

Ok, so unhappily this didn't quite work... please let me run my steps.



knowing i had 20 years of bits and pieces on my computer from several new computer saves and reloads. i uninstalled every jolly bit. All of it. All files, all CAW and SIMS. removed the lot. every save game, every town... the lot... all downloads all everything. ( yowzer) still have 5 year back ups on a external drive somewhere safe)



redownloaded the base game and it went into program files.


the CAW as you said went into program 86 files.


On the initial start up. i hit the CAW button... "crickets" not a thing happened... it flashed up and went away. no loading no nothing. Zip.


So..... i went into the progam files 86 and i cut and paste the entire CAW folder into the Electronic arts folder that holds the new sims 3 game.


Magically CAW LOADED... and i could use it... 


THEN unhappily as people have suggested, when i hit "EIG" it opened the launcher to savegames/new games. and obviously didn't work.


can i confirm if this should have worked or if EA have broken it again.


the files appear like this 


C drive program files

                  >Electronic arts folder

                               >The sims 3

                                >Create a world tool


I did not move anything over from documents folder i left that there.


any further advice appreciated.


I also restarted machine and repaired the sims 3 game.



many thanks. Wish EA would sort this out. 




thanks team helpers you guys rock





Message 58 of 59 (100 Views)

Re: EA App: Sims 3 Create a World Edit in-game doesn't work

★★★ Novice

I'm not entirely sure I followed all your steps correctly, but the only way I could find my new directory was to search my pc for a Sims 3 pack that I own. I can't even follow my own directory path as it reads. I had to search my pc to find it again for this post! This new directory also has my Sims Medieval and my 3 Dragon Age games in it. 


1. Search " The Sims 3 " or " Into the Future " or any pack you have in file explorer. Make sure " This PC " is selected when you search. 

2. Wait for them to load, my pc always takes a bit. 

3. You might have 2 or more places, for me Into the Future doesn't show up in my old directory so I use that one. Right click on the pack in file explorer after the search is done, then select open file location. 

4. Make sure this is not the Programx86 location, but rather one that says 'Local Content'. It does not say 'Electronic Arts' but rather 'Origin' in the file directory (for me at least). 

5. Move CAW folder into this directory. 'The Sims 3 Create a World' should sit between 'The Sims 3 Ambitions' and 'The Sims 3 Diesel Stuff' if you have them.

6. Test Edit in Game.


If this is exactly what you did and it didn't work, I'm so sorry I can't help more!!

Message 59 of 59 (75 Views)