Help us improve Answers HQ! Take Survey No, Thanks

Re: Can’t load game please help!

by sydl1001

Original Post

Can’t load game please help!

★★★★ Novice

I try to load the game in Origin and error comes up at the end of loading that says “VC++ runtime redistributable package was not installed successfully. setup cannot continue. (-1073741521)”   Checked and I have all the recommended system requirements 


please help I really want to play this game! 

Message 1 of 3 (106 Views)

Re: Can’t load game please help!

[ Edited ]
★ Pro

I understand that you have a 64-bit system and installed a game. You can't only launch this game.
Go to Program Filles / Origin Games / The Sims4 / installer, open the folder vc / vc2010sp / redistr. You will find two files in the redistr folder that you can install.
Then again open the folder vc / this time go to the folder vc2013 / then again to the folder redistr there will be files from 2015 - install them also.
I don't work for EA

Message 2 of 3 (88 Views)

Re: Can’t load game please help!

[ Edited ]
★★★★ Novice

looks like theres an issue in the vc2013 folder with those files. it said its not designed to run on windows or contains an error. I tried to re install them from microsoft site but still has the same error and wont let me download. argggg Frown It says "C:\Windows\system32\Cabinet.dll" not designed to run or has an error. I guess i'll contact microsoft 

Message 3 of 3 (50 Views)

The Sims 4 Patch Notes

Check out the latest updates and bug fixes

View more on EA Help

Restore a previous saved game

Choose from an automatically stored save point in The Sims 4 if your data's corrupted or you want to revert anyway.

View more on EA Help


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help