Help us improve Answers HQ! Take Survey No, Thanks

Re: [CURRENT ISSUE] Incredibly Low FPS when connected to Internet

by VividMelody
Reply

Original Post

Re: [CURRENT ISSUE] Incredibly Low FPS when connected to Internet

EA Sims Team

@christian_39 

 

Interesting.  I'll pass this info along.  Thank you!

Message 151 of 196 (1,537 Views)

Re: [CURRENT ISSUE] Incredibly Low FPS when connected to Internet

★★★★ Novice

Hey everyone!

 

I've been plagued with this issue as well, only getting 5 FPS while connected to the internet and 144 FPS when disconnected. Fortunately, I found another solution that worked perfectly for me, should updating your network adapter drivers not work.

 

For clarity, I'm on Windows 10 running the latest 2004 update / Build19041 and utilizing the Steam platform.

 

The Fix:

  • Win + S
  • Search for "Internet Options" and open it
  • Under "General > Browsing history" click "Settings"
  • Under the "Temporary Internet Files" tab, ensure you have some disk space allocated. I somehow had 0MB allocated which was the root cause for my low framerate (more on that under "Discovery".) Following the recommended amount to allocate is fine.
  • As another precaution, click the "Caches and databases" tab and delete any cache files, if applicable.
    Here's what my internet option settings look like afterwards:
Spoiler
Here's what my internet option settings look like:

 

Discovery:
After days of annoying troubleshooting, I came to this solution after noticing extremely abnormal high disk usage when running TS4 and thinking that might have to do with our low framerate issue. In Task Manager I saw that "Host Process for Windows Tasks" was using nearly 100% of my C: drive (where I have everything installed) whenever the game was running. "But Vivid, the game has so many assets to load, especially if you have CC and expansions!!" Well yes, Jimmy, but your disk usage shouldn't be permanently stuck at 100% usage when playing the game. So, I decided to explore further with Process Explorer and noticed that there was an excessive amount of writing being done to a WebCacheV01 data file in Windows' temp folder only when the game was running. 

Spoiler

I'm talking like non-stop refreshing with activity in the modules list which was not exactly normal behavior, especially with no major web services running asides from Steam and Origin. With that newfound knowledge, I looked around a bit and saw that some Windows users in general had high disk usage due to that WebCacheV01.dat file and that such issues can be mitigated through tinkering with your internet options in the control panel. I noticed mine was set to 0MB somehow, as mentioned above; you can't enter a value less than 8MB so I'm at a loss there, but after allocating a few hundred megabytes I saw my frames in-game instantly jump from 5 fps to my native 144 fps. I'm assuming that there may be some serious communication going on between the game executable and the servers for analytics or anti-piracy, or whatever it may be, and having insufficient cache allocated for internet files just kills your performance with all the attempted writing being done. I'm not too versed on how most of that works, but all I know is the issue at hand is fixed.

 

 

Hopefully this helps out the rest of you affected by this issue!

Message 152 of 196 (1,275 Views)

Re: [CURRENT ISSUE] Incredibly Low FPS when connected to Internet

★★ Novice

Any of these unforunately didn't fix my FPS issue STILL ongoing from 2016 to this day for me and i've changed 3 computers and 2 houses with different ISPs and the issue is till persistent. Now that i know for sure it's not me, it's the game because i've gone from GTX 970 to 1050 to 1060(current) with many different high end CPU's. My current system is :

 

GTX 1060

i7 6700K

8GB ram

 

When i should see the 90s-100s i'm stuck between 45-50 most of the time on High settings. Now i'm at a point of begging to get this to the higher ups at Sims Studios because i'm honestly at the last resort of quitting the game. I shouldn't be getting console-level fps with this system that i play high-end AAA games with ease. 

 

 

Alo this thread is labeled (FIXED) can we please remove that, maybe some SimGurus don't take a look at this threat because it's labeled as that.

Message 153 of 196 (1,170 Views)

Re: [CURRENT ISSUE] Incredibly Low FPS when connected to Internet

★★★★★ Novice

The game in it's current state is unplayable. These massive fps drops happen for no apparent reason. Switching to build mode, opening sim inventory, opening the notification bar on the top right, gaining some points (influence, vampire or magic points, fame, etc.). These are some triggers I personally observed. Sometimes opening the game menu is a quick fix to recover the normal framerate. Sometimes even that doesn't help anymore and the game needs a complete restart. I tried all the fixes mentioned in this thread and nothing helps.

 

It makes me sad to see this thread alone has over 15 pages. This should show that something is clearly wrong. Thats not a small issue. The devs should get their priorities straight. They are pumping out new addons like there is no tomorrow without fixing issues that make the game unplayable ("We don't need new parts and paintjobs for the broken car you sold us! Fix the car!").

Message 154 of 196 (1,215 Views)

The game runs at 4 fps after installing the Windows 10 May 2020 update

★ Novice

Product: The Sims 4
Platform:PC
Which language are you playing the game in? Italiano
How often does the bug occur? Every time (100%)
What is your current game version number? 1.65.70.1020
What expansions, game packs, and stuff packs do you have installed? just the free ones
Steps: How can we find the bug ourselves? Load the game in a machine with Windows 10 version 2004
What happens when the bug occurs? The game runs at 4 or less fps in the menu and in game
What do you expect to see? The game running smoothly
Have you installed any customization with the game, e.g. Custom Content or Mods? Not now. I've removed them.
Did this issue appear after a specific patch or change you made to your system? Yes
Please describe the patch or change you made. I installed the new Windows 10 2004 May update

The game runs very poorly (4 or less fps) constantly after updating Windows 10 to the 2004 version.

I already tried reinstalling the game, clearing the game's temp files, running a CCleaner scan and reinstalling my gpu drivers. Nothing worked.

 

 

Here are my pc specs:

CPU: Ryzen 5 2600

GPU: Nvidia GTX 1060 3GB

RAM: DDR4  16GB at 3000MHz

 

Message 155 of 196 (1,158 Views)

Re: The game runs at 4 fps after installing the Windows 10 May 2020 update

Hero
@OmniSaS Could you test if it runs better if you disconnect from the internet entirely. (turn it off)

There's a known issue with that so just need you to test if that's the cause for you.

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.



Important Threads


Message 156 of 196 (1,144 Views)

Re: The game runs at 4 fps after installing the Windows 10 May 2020 update

★ Novice
@crinrict i unplugged my ethernet cable and that fixed it, is there any way to not allow the game to use internet without me unplugging the cable every time?
Message 157 of 196 (1,130 Views)

Re: The game runs at 4 fps after installing the Windows 10 May 2020 update

Hero
@OmniSaS I merged your post with the current thread on this then

QA is investigating this, could you provide the info asked in the solution post of this thread.

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.



Important Threads


Message 158 of 196 (1,093 Views)

Re: The game runs at 4 fps after installing the Windows 10 May 2020 update

[ Edited ]
★★★★★ Apprentice

Alternatively you can disable the network adapter, like this:

1) Settings -> Internet and Network -> Status

2) Change adapter settings
https://i.imgur.com/SqfoVr8.png

3) Select the network adapter to disable -> right click and click "disable"
https://i.imgur.com/yAPaPZw.png

When you need to enable it again, do the same but click "enable" on step 3

Message 159 of 196 (952 Views)

Cant play with internet

★★ Novice

Like the title says, with internet i have 10fps max, without i get 144.

I did a google search and its been a year since this bug is in the game and still no fix?

Any news on this topic?

 

Pc:

1060 6GB

i5 8600k

16gb ram

and Sims 4 is installed on a 500gb ssd

Message 160 of 196 (854 Views)
Twitter Stream