Help us improve Answers HQ! Take Survey No, Thanks

Re: CAW won't start on Win10

by Vgrace573
Reply

Original Post

CAW won't start on Win10

★★★★ Novice

Couldn't CAW to save my butt, but kept trying until windows 10 when it would briefly show the start screen then shut down with no message.  New computer, (PC) figured why not?  So installed CAW.  Wonder of wonders it worked!  Managed to do what I wanted to with an unpopulated Riverview file (used s3pe to change id) uploaded it but it wouldn't install.  Then CAW started once again to flash start-up screen then shut down.  Then the sims3 itself did the same thing.  Ended up having to uninstall and re-install everything.  Tried CAW again but the same brief flash and end consistently.

  

Some site said that with 1.69 caw must be launched through Origin but I cannot figure out how to do that.  Also remember that I had to do some finagling on my old pc to get win10 to play ANY game whether Steam, Origin, disks, even windows games.  Can't figure out how I managed those permissions either.  

 

So is this a caw issue, a windows issue or just a user who's kinda a dolt issue?

Message 1 of 8 (279 Views)

Re: CAW won't start on Win10

@Vgrace573  I have no idea why you had to fiddle with your old computer in order to play games, TS3 or other; Windows 10 usually runs TS3 just fine.  But the first question is whether you can run TS3 itself, not CAW.  If not, the issue may be your antivirus/firewall (try disabling it temporarily to test), or it may be a missing or corrupt file that the game needs to work.

 

So please let me know whether you can now play TS3, and if not, whether you get any errors, and which ones, and where in the process it crashes.

 

If the game itself does run, but CAW doesn't, please make sure you're using the correct version of CAW.  There are separate downloads for 1.67 (disc/Steam) and 1.69 (Origin) installs.  I haven't heard anything about launching CAW through Origin, but you can always try signing into Origin first and then opening CAW.

 

Please make sure to disable OneDrive while you're testing.  I don't know that it causes issues with CAW specifically, but it can be a real problem with TS3 itself, as OneDrive tries to sync with or upload your local Documents folder.  If you use it for other purposes, you can fiddle with the settings to prevent it from doing anything automatically, but while you're testing, just go into Settings and turn it off entirely.

 

Finally, whether this is a CAW issue or still extends to TS3, please run a dxdiag and attach the results to a post here.  This will cover a number of potential issues, and at the end, it will list the last 10 errors, usually including the faulting file.

 

https://help.ea.com/en-us/help/pc/how-to-gather-dxdiag-information/

 

I know this is a lot, but there are so many ways TS3 can go wrong, and CAW is often an additional headache.  So it's difficult to troubleshoot without more information.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 8 (270 Views)

Re: CAW won't start on Win10

★★★★ Novice

Sims 3 works just fine (mostly).  Graphics are set for smoother game-play rather than quality and it loads quickly with very rare crashes.  (I'm frantically knocking on wood and tossing salt over my shoulder after typing that.)

 

Caw is 1.69 just like my games.  Just tried your suggestion about disabling One Drive--no joy.  Screen pops up for 2 seconds then just goes away.  No error messages, nothing.  Hope I attached that diagnostic okay and thanks a lot.  Really appreciate all you folks here who know what you're doing and are willing to help us poor schmucks whilst we flounder.

 

BTW back when win10 first invited itself into my life problems arose from the "game bar" and the video system also had to be adjusted for permissions or something though all had been hunky-dorey before that.  Was hoping the problem would be something that simple.

Message 3 of 8 (257 Views)

Re: CAW won't start on Win10

[ Edited ]

@Vgrace573  Darn, I was hoping that TS3 didn't work either; there are some simple interventions for the game, and I was hoping those would take care of CAW too.  I remember reading about the Creator's Update issues, although I wasn't running the game in Windows 10 until a year later, when most of the problems were sorted out.  Still, you could try the usual steps to turn off the effects of the update.  This is the guide I used, although some of the ways to access the settings may have changed:

 

https://forums.thesims.com/en_US/discussion/comment/15902876#Comment_15902876

 

I doubt any of that would crash CAW and not the game, but the settings are easy enough to switch off, and switch back on if CAW still crashes.

 

Your dxdiag mostly looks fine, although there's plenty I don't know about reading one.  I did notice that you have several errors caused by an .exe associated with Catalyst Control Center, which is a tool designed for AMD graphics cards.  Is there a reason you have it installed?  Nvidia cards can use the built-in Control Panel or download Nvidia Inspector for free.  I know some people prefer other tools, like RivaTuner Statistics Server; I use RTSS myself, but then I have an AMD card.  At any rate, try disabling CCC for now and see whether it makes a difference.

 

If this isn't the problem, it would help to get a crash dump.  Here's how:

  • Hit the Windows key, type "command prompt" in the box, right-click on Command Prompt in the search results, and select Run as Administrator
  • In the window, paste the following: "reg add "HKLM\Software\Microsoft\Windows\Windows Error Reporting\LocalDumps\devenv.exe" /v DumpType /d 2 /t REG_DWORD" without the outside quotes into the box, and enter
  • Launch CAW and wait for it to crash
  • After it crashes, wait for any crash dialogs to finish
  • Then hit Windows key-R and paste "%LOCALAPPDATA%\CrashDumps" without quotes into the box, and enter
  • Upload the last .dmp file here, or if it won't let you attach it to a post, upload it to a filesharing site (the free version of pastebin.com works fine) and link it
  • When you want to undo the auto crash log dumps, open Command Prompt as before, paste "reg delete "HKLM\Software\Microsoft\Windows\Windows Error Reporting\LocalDumps" /f" without the outside quotes, and enter

By the way, your dxdiag also has a whole bunch of errors from a browser extension called HoneyServicesCorporation.  (I think it's a coupon service?)  I don't know whether you need to update it, or whether the tool itself isn't working well with Edge right now, but either way, you probably want to find a way to clean up the errors.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 4 of 8 (244 Views)

Re: CAW won't start on Win10

★★★★ Novice

C:\Users\vgrac>%LOCALAPPDATA%\CrashDumps
'C:\Users\vgrac\AppData\Local\CrashDumps' is not recognized as an internal or external command,
operable program or batch file.

 

Creating the dump worked but no dialogs came up after attempting to start caw.  I waited awhile,tried launching again and waited some more.  Nothing.  See above for second command.  Guessing it didn't work because no batch file was created?  

 

Don't know why CCC is on this machine.  It was a refurbished model so maybe the video card was swapped out at some point.  The adjustments I made to keep the game running smoothly were done with nvidia.  Anyway, got rid of amd.  Game still works fine, caw still doesn't.   What's weird to me is that it worked for a few days some weeks back when I first downloaded it to this machine, then stopped working and as I mentioned before, ts3 broke at the same time.  Reinstall fixed the game but caw is still being a p.i.t.a.

 

Thanks puzzleaddict for your thoughtful help.  I ordered Seasons for no reason other than all the good lots and worlds use it.  Figured I'd set up the world I wanted in caw to play it but heck if I've gotten along without for all this time I'll get along period.  

 

BTW the Honey thing.  Saw those too.  Am guessing that anytime it tries to apply a no-longer-valid coupon at checkout it might cause an error?  Will look into it as I adore that app.

 

Thanks again.

Message 5 of 8 (233 Views)

Re: CAW won't start on Win10

@Vgrace573 The resolution of 1050 is an odd resolution. Usually you should follow TV resolutions of 720 and 1080 with 4K now being popular. With that said you should be using a DVI cable to connect to the monitor rather then the vga HD15 cable. The bigger issue is the 320W power supply that comes with the small form factor computer you have. This is probably an unusual power supply that replacement with a higher wattage may (probably) is not available. The 730 video card requires minimum 300W so you are very near maxing the power supply. My first guess would be to take the case off and make sure there is plenty of air flow - check the cooling fan(s). Next make sure there are no bloated capacitors. You have to make sure the health of your computer is up to run at near capacity as my guess would be an aging computer. I have a Dell Inspiron 660s (sff) I use for streaming (no games). I sudden change in a computer's performance merits a close inspection followed by a stress test.

_______________________________________________________________

I do not work for EA or associated with EA other then helping other users in the forums.
Message 6 of 8 (224 Views)

Re: CAW won't start on Win10

@Vgrace573  The way you describe the crash (or closing out, no crash, as the case may be), it sounds like what would happen if your antivirus/firewall was blocking CAW.  It would be weird for it to flag CAW but not TS3 itself, unless you've set an exception for the game.  I don't actually know what the .exe is for the 1.69 version of CAW; I have a Steam/1.67 install.  You could find out easily enough though, and try setting an exception.  Or just turn off your your av temporarily while you test.

 

If that doesn't help, you might ask on the official Sims forums.  Some players there still use CAW, and while 1.69 isn't particularly popular, plenty of players do have Origin installs.  Maybe someone else will have ideas.

 

https://forums.thesims.com/en_US/categories/create-a-world

 

I'm sorry I don't have any better ideas.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 7 of 8 (204 Views)
Highlighted

Re: CAW won't start on Win10

★★★★ Novice

roberta591 and puzzlezaddict thank you both.  I looked things over but my (admittedly ignorant) eyes didn't see a problem.  Turned off everything on Defender that could be and Malwarebytes doesn't run in real time.  Whole thing reminds me of my old original x-box.  Wouldn't start a game at all for months then suddenly worked perfectly, then decided not to work again.

 

Be that as it may, my system works great for everything else including gameplay not just ts3 but some other truly finicky games that I won't mention here.  (One has its own Netflix series coming up that I'm kinda jazzed about!)  I may butt into a thread on the forums as I can't find the spot where they'll let me create a new one. 

 

Thanks again for your time and attention.  Have a good one!

Message 8 of 8 (188 Views)
sims-four-characters

Want more Sims?

Check out our Sims forums for tutorials and all things Sims.

View more

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help