Help us improve Answers HQ! Take Survey No, Thanks

black screen when opening game

by laketommo
Reply

Original Post

Highlighted

black screen when opening game

★ Novice

Hey!

 

It's been a while since I last played The Sims 4, maybe around a year. I quit because of lack of space on my MacBook Air, but I have now cleared up about 50GB and therefore decided to play again. Today I installed Origin again and downloaded The Sims 4 (and the few extension packs I have). I started playing a little, with no problem, but I realized I was missing a lot of stuff and therefore decided to download some CC. I ended up spending a lot of time on this and probably downloaded about 2000 or so. As I was going to start my game the logo showed, but then it just turned into a black screen. It stayed like that for about 30 seconds before the game "closed" and the loading mouse appeared. It would stay like that until I force quit the game. I tried a few more times but it didn't work, so I ended up deleting both the game and Origin from my Mac. I re-installed both and tried playing the game - and it went just fine. I then copied the CC that I had downloaded earlier into the mod file, and the game would just show me a black screen when I tried opening it, again. I tried deleting the mods, but the black screen was still there. I then tried deleting and re-installing the game, but now the black screen would show again, and the loading mouse until I force quit the game. I'm very unsure what to do now and hope that someone can help. 

 

Btw, I have already tried the "repair" on Origin. I would also like to add that I earlier had problems because the Electronic Arts and Sims 4 were separated (one were in my disk and the other one on my iCloud, but I have now fixed this so that they're both on my disk). I'm not sure if this matters but I have a MacBook Air (13-inch, early 2015) where I have macOS Mojave, version 10.14.4. I also made sure that the game is up to date!

 

Any help would be appreciated, thank you!

Message 1 of 2 (148 Views)
Highlighted

Re: black screen when opening game

[ Edited ]
★ Expert

@laketommo

Probably some outdated CC or mod caused this. It can even be downloaded by mistake CC to TS3. It happens quite often but because it is Mac I will call for Mac specialist @Bluebellflora

For now, you can move mods folder to the desktop, delete localthumbcache.package file from the game folder and once more fix the game in Origin.
If the game will work without mods than copy and paste your mods and CC from old mods folder to the new one.
First copy the scripts mods, then your CC every time checking if this error isn't showing up again. But because you have a lot of CC divide them into smaller subfolders - for example, 50 in one.

I don't work for EA


Message 2 of 2 (131 Views)
Twitter Stream