Help us improve Answers HQ! Take Survey No, Thanks

The Sims 3 64-bit & metal NOT WORKING

by luckypalmer
Reply

Original Post

Accepted Solution

The Sims 3 64-bit & metal NOT WORKING

★★ Novice

Hi, I have recently purchased the Sims 3 64-bit and metal update and it took around 7hrs to install for it to then be incomplete and need to be reinstalled. I am not sure if this is due to a bug or the update is not even meant to be playable yet? Before the update, I had purchased The Sims 3 starter pack which includes base game + late night and high end loft stuff (obviously was unplayable because the game is incompatible with Mac). I was able to install the 64-bit and metal update as well as late night and high end loft stuff but all packs keep needing to be reinstalled even after installing. I thought maybe I needed to install the original base game after these issues and it installed fine but the other packs still aren't working. Is there a fix for this?

 

Thank you. 

Message 1 of 26 (4,091 Views)

Accepted Solution

Re: The Sims 3 64-bit & metal NOT WORKING

@luckypalmer  Try disabling Origin in-game: hover over your username, select Application Settings, then the Origin in-game header, and disable the option at the top.

 

If that doesn't help, try playing while your computer is offline.  Sign into Origin and put it in offline mode, then disable wifi and/or unplug the ethernet cable before opening the launcher.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.

View in thread

Message 10 of 26 (3,946 Views)

All Replies

Re: The Sims 3 64-bit & metal NOT WORKING

@luckypalmer  Just out of curiosity, please open Macintosh HD (or whatever you've named your hard disk) > Library > Application Support > Origin > DownloadCache, and if there are any files present, let me know what they are and how large they are.  (Or you could take a screenshot.)  This is where Origin stores downloaded games before installing, and I'm wondering whether the game files are there and in what form, and also whether you could manually launch the installer instead.  Probably not, but like I said, I'm curious.

 

If you don't see Macintosh HD listed in the left panel of a Finder window, click Finder in the upper left corner of your screen, select Preferences > Sidebar, and check the box next to hard disks.

 

If you can't install Sims 3 that way, please run the Origin reset tool, restart your computer, and try to download only the base game.  You can deal with the packs later, but they won't install if the base game isn't present.

 

https://help.ea.com/en-us/help/origin/origin/how-to-reset-origin-on-mac/

 

Just to clarify by the way, the 64-bit version of Sims 3 does have a minimum requirement of High Sierra (OS X 10.13) or newer.  Since you're saying the 32-bit version is incompatible with your Mac, it sounds like you're running Catalina (10.15), but just in case, please double-check what OS you're running.  Click the Apple icon in the upper left corner of your screen and select About This Mac, and you'll see your OS listed along with the other specs of your Mac.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 26 (4,066 Views)

Re: The Sims 3 64-bit & metal NOT WORKING

★★ Novice

My mac is running on Sierra 10.12.6 Frown I think this is the problem. 

Message 3 of 26 (4,048 Views)

Re: The Sims 3 64-bit & metal NOT WORKING

[ Edited ]

@luckypalmer  That is exactly the problem.  I'm not sure why you thought the 32-bit version of Sims 3 was incompatible with your Mac, because it still runs fine in Sierra, at least most of the time.  At any rate, you can definitely update to High Sierra, and if your Mac also supports Metal, you'll be able to install the 64-bit version.

 

Be sure to uninstall the 32-bit version first though.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 4 of 26 (4,036 Views)

Re: The Sims 3 64-bit & metal NOT WORKING

★★ Novice

Thank you for all your help. Sorry, I'm not very tech-savvy, The Sims 3 does not load onto my laptop though, there's always an error. Ok, so I've just checked if my mac supports metal and it does. So you're saying I should uninstall the 32-bit version and upgrade to high Sierra?

 

Thank you again for all your time!! Standard smile 

Message 5 of 26 (4,021 Views)

Re: The Sims 3 64-bit & metal NOT WORKING

@luckypalmer  Yes, if your Mac does in fact support Metal, go ahead and do a clean uninstall of the old version of Sims 3, upgrade to at least High Sierra, and you'll be able to install the 64-bit version of Sims 3.  Here's how to do a clean uninstall:

 

https://bluebellflora.com/how-to-do-a-clean-uninstall-and-reinstall-on-a-mac/

 

Here are the links for High Sierra and Mojave:

 

https://support.apple.com/en-us/HT208969

https://support.apple.com/en-us/HT210190

 

You don't need to install Catalina; either of the above would be fine.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 6 of 26 (4,012 Views)

Re: The Sims 3 64-bit & metal NOT WORKING

★★ Novice

I've updated to High Sierra and was then able to install the 64-bit and metal game as well as expansion packs, however, the launcher will not respond and I keep needing to force quit it.

Message 7 of 26 (3,992 Views)

Re: The Sims 3 64-bit & metal NOT WORKING

@luckypalmer  Please post the full specs of your Mac, as described here:

 

https://answers.ea.com/t5/Technical-Issues-Mac/32-bit-Sims-3-Mac-Help-Guides-and-Troubleshooting/m-p...

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 8 of 26 (3,959 Views)

Re: The Sims 3 64-bit & metal NOT WORKING

★★ Novice

Here you go.

Message 9 of 26 (3,949 Views)

Re: The Sims 3 64-bit & metal NOT WORKING

@luckypalmer  Try disabling Origin in-game: hover over your username, select Application Settings, then the Origin in-game header, and disable the option at the top.

 

If that doesn't help, try playing while your computer is offline.  Sign into Origin and put it in offline mode, then disable wifi and/or unplug the ethernet cable before opening the launcher.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 10 of 26 (3,947 Views)
Twitter Stream