Help us improve Answers HQ! Take Survey No, Thanks

Re: Problems installing Sims3Packs (TS3 64-bit)

by puzzlezaddict
Reply

Original Post

Re: Problems installing Sims3Packs (TS3 64-bit)

★★★ Apprentice

@puzzlezaddict when I click install when trying to install a world, no second plumbob shows up. It just starts to grey out all the buttons on the launcher and then I have to restart it. I chatted with EA rep a couple days ago and they said store worlds are still being worked on so I don't think anyone has 64-bit store worlds yet? Someone correct me if I'm wrong.

Message 151 of 263 (276 Views)

Re: Problems installing Sims3Packs (TS3 64-bit)

@aodoherty  What happens when you click the Install button?  If the answer is "nothing," try closing the launcher and opening it again.

 

@sunshineeannaa  Same as above.  And my store worlds have installed just fine, although I've only tried a few of them so far.  The key is to have the base game icon lit up in the launcher.  If it's not, follow these steps to fix that:

 

https://answers.ea.com/t5/Technical-Issues-Mac/Problems-installing-Sims3Packs-TS3-64-bit/td-p/966525...

 

@BrittWentz  I'm not surprised that technique worked for you.  That's a longtime way to convert Sims3Packs into .package-based content, although I believe it doesn't work for store stuff.  The critical error is usually fixed by the approach listed in the link above.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 152 of 263 (258 Views)

Re: Problems installing Sims3Packs (TS3 64-bit)

★★★ Novice

i've followed the steps for the critical system failure error, and my launcher still gives me the error. i downloaded my custom content from the sims resource, and here's the screenshot of the error i'm having:

Message 153 of 263 (252 Views)

Re: Problems installing Sims3Packs (TS3 64-bit)

@hanluesgf  I can't see the screenshot you tried to post.  Is this the same critical system failure as before?  If so, please check the Installer Data folder you made and see whether there's now a plist file inside.  If not, try repairing the game again.

 

If that's not the issue, please try downloading one item into a clean folder.  Move your entire Sims 3 folder out of Documents > Electronic Arts and onto your desktop, open the launcher to spawn a clean folder, download a fresh copy of one item, and move it to Documents > Electronic Arts > The Sims 3 > Downloads.  Then use the launcher to install it.  (If the Install button doesn't work, close the launcher and open it again.)  Let me know whether you get the same error again.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 154 of 263 (246 Views)

Re: Problems installing Sims3Packs (TS3 64-bit)

[ Edited ]
★ Pro

@puzzlezaddictThanks. I'm still wondering why it works 1 day later? I tried to reopen. the launcher but didn't work yesterday morning but it worked this morning..? LOL Now I got a new issue that I already noticed on AHQ page. I will add my issue there.

Message 155 of 263 (226 Views)

Re: Problems installing Sims3Packs (TS3 64-bit)

★★ Novice
@puzzlezaddic I am in need of downloading store content. I am not able to download anything. I am also not able to log into my EA account via the launcher.
Message 156 of 263 (217 Views)

Re: Problems installing Sims3Packs (TS3 64-bit)

@aodoherty  The launcher has always been fussy, and the game is too.  Sometimes I can't figure out why something starts working again, and I just accept it and move on.  Better that than the opposite.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 157 of 263 (181 Views)

Re: Problems installing Sims3Packs (TS3 64-bit)

[ Edited ]

Marked as a solution for visibility


 

For anyone still having issues installing store or custom content, the update today (November 9) has fixed the underlying problem that is the most common cause of an "Error downloading content" or "critical system failure."

 

If you have this issue, please repair the game in Origin: open your game library, right-click on the Sims 3 icon, and select Repair.  Then open the launcher and see whether the base game icon in the lower left corner is grayed out.  If it's now green, the underlying issue should be solved, and you should be able to install content again.

 

Although the underlying cause of expansion and stuff pack icons being grayed out is the same, that is not addressed in this fix.  However, the grayed out pack icons should not affect your ability to install or use store or custom content.

 

If you still get the same errors when downloading or installing content, and your base game icon is NOT grayed out in the launcher, please move the entire Sims 3 folder out of Documents/Electronic Arts and onto your desktop, open the launcher to spawn a clean folder, and download a fresh copy of one item to test.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 158 of 263 (6,198 Views)

Re: Problems installing Sims3Packs (TS3 64-bit)

[ Edited ]
★★★ Novice

this was the screenshot, let me know if you still can't see it!

Screen Shot 2020-11-08 at 7.52.24 PM.png

 

there's two plist files in my installer data folder. and as for downloading a new item, i've tried it and the install button doesn't work for me. i tried closing the launcher and opening it again, and i got the same result. also, none of my expansion packs show up in the launcher.

 

UPDATE: so now, there's multiple plist files in the installer data for my expansion packs and stuff packs, the only issue is that the installer button isn't working

Message 159 of 263 (153 Views)

Re: Problems installing Sims3Packs (TS3 64-bit)

★★★★★ Novice

Whenever I launch my game with custom content running it goes into the smaller screen where my game would normally fully launch but instead stays there with the rainbow loading cursor. I’ve given it time and it does not launch. I’ve tried reinstalling it, resetting my origin, repairing it, deleting the cache files, etc. and nothing seems to be working.

Message 160 of 263 (140 Views)
Twitter Stream