Help us improve Answers HQ! Take Survey No, Thanks

Poor graphics/low-resolution/graphics glitches (TS3 64-bit)

by puzzlezaddict
Reply

Original Post

Re: Poor graphics/low-resolution/graphics glitches (TS3 64-bit)

★★ Apprentice

Screen Shot 2020-11-01 at 11.44.26 am.png

I'm encountered a number of graphical issues with 64 bit release of Sims 3, I played around with a variation of setting, resolutions and in windowed and fullscreen mode. I have no mods, custom content or store content installed. 

 

  • Pixelated shadows, as mentioned previously in this in thread. Occurs on all settings shadows are enabled, I tried changing the resolution of shadows to 4096 and then 8192 by editing the GraphicsRules.sgr but I can see no change.

Screen Shot 2020-10-31 at 11.05.15 am.png

 

Screen Shot 2020-10-31 at 11.06.30 am.png

 

  • There is an issue with the texture of all tree trunks in the game, both base game and all expansions. It occurs on all different graphics setting combinations that I've tested and all resolutions. I have yet to notice a similar texture/mapping issue on any other build/buy or CAS item.

Screen Shot 2020-10-31 at 11.50.41 am.pngScreen Shot 2020-10-31 at 11.04.31 am.png

 

  • As I mentioned in a previous thread about the flashing red screen Disabling 'Enable Advanced Rendering' causes the some terrain paint in Island Paradiso and to an extent in Sunset Valley, to not appear or replaced by another texture. There are also patches of red in various places around the worlds. Distant lots also appear with a red texture/overlay. 

Screen Shot 2020-10-31 at 11.16.41 am.pngScreen Shot 2020-10-31 at 11.35.44 am.pngScreen Shot 2020-11-01 at 12.51.12 pm.pngScreen Shot 2020-10-31 at 11.35.18 am.png

 

  • Also, despite reflection quality set to 'Mirrors & Super Water' the water is not reflecting at it should be.
Attachment
Download this attachment
Message 31 of 46 (654 Views)

Re: Sims look low-resolution

★ Pro
@bbmuchsims This is the graphics card issue. I've been having this on windows as well. I experienced this with Radeon HD cards too. I'm currently using Radeon pro 560 and have the same issue both on windows and Mac. If it's possible, change it to Geforce Nvidia, it will be gone. I'm pretty sure. I didn't have this issue on Geforce GTX680MX.
Message 32 of 46 (617 Views)

Re: Sims look low-resolution

@aodoherty  You can't upgrade or swap the graphics card in a Mac, other than in the extremely high-end Mac Pros.  And newer Nvidia cards aren't supported by macOS.  I'm not sure the Apple-provided drivers would even work.  So even an external GPU setup might not be usable at all if it contained an Nvidia card.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 33 of 46 (591 Views)

Re: Sims look low-resolution

★ Guide

I did have some trouble with my graphics when I first started my game, still do somewhat (any lot that isn't mine is just a big block), even though it should run on ultra. However, I have found that some settings can help with the lots next to mine, and that faking-out the game for full screen will help with resolution (even though the text is somewhat blurry). When you hit command+return together and it takes you to the window mode, click "no" and it'll get rid of the black sides on either of the game playing (so it'll be total full-screen). Still playing around with some options but all-in-all it looks very good and I'm v thankful for this 64-bit addition :-)

Message 34 of 46 (564 Views)

Re: Sims look low-resolution

★ Pro
@puzzlezaddict The only way to fix this is just going back to the model, i7 3770 3.6 GHz up to 4.2, 27 inch i mac has Nvidia GTX680MX. Yea I know it's not possible to add or change SSD and Graphics card on I mac. Frown
Message 35 of 46 (544 Views)

Re: Sims look low-resolution

★★★★ Novice

Lately I've been having this weird reflection glitch on water even though I have reflection set to mirrors only. I have advanced rendering turned on cause I like the water texture. I had no problems with these settings on my computer with the old game.

Message 36 of 46 (463 Views)

Re: Poor graphics/low-resolution/graphics glitches (TS3 64-bit)

★★★ Novice

Windowed mode won't work for me at all; as command and enter does nothing. It's like my Sims 3 doesn't recognize as that being a command. I can get the cheat console to come up.

 

When I try changing changing the screen size to match my computer's resolution ( 5120 x 2880) only the options menu itself changes sizes. This is if I try any screen resolution from the drop down list. I've occasionally seen the red flash when trying to change resolutions as well. The only way I can leave fullscreen mode is to use my mouse to swipe left. And my computer's resolution stays at 4:3 (even outside of the game) until I completely quit The Sims 3.

 

The frame rate goes fluctuates between 55-75. Moving across the map in Sunset Valley, the way the map loads/renders reminds me if you were trying to film an old tv with a cell phone, it loads (depending on the direction I'm moving across the screen) in horizontal or vertical waves.

 

I don't see where you put a spoiler tag, so my device config file is attached as a text file.

Message 37 of 46 (458 Views)

Re: Sims look low-resolution

@middykitty4  Please attach your deviceconfig.log, in Documents > Electronic Arts > The Sims 3.  You'll neeed to manually open the folders; the file won't show up in a search.  You can delete your user and computer names, about 25 lines down, but there's nothing else in that file that can identify you.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 38 of 46 (443 Views)

Re: Poor graphics/low-resolution/graphics glitches (TS3 64-bit)

@Rhazya  Thanks for all the info.  It's interesting that you can't use cmd-enter to switch to windowed mode; someone else with an iMac said the same.  What you can do is edit options.ini, in Documents > Electronic Arts > The Sims 3, to set fullscreen to 0.  (Use cmd-f to search for the line.)  When the game launches in windowed mode, try switching the resolution a couple times and see whether it works.

 

I wouldn't be surprised if the full resolution of your screen didn't work as an option though: it seems like in windowed mode, the game window takes up more space than it should given the chosen resolution.  I'm not sure why.  But try 2560x1440 and see how it looks.  If you still can't switch it, you can try editing options.ini again: there's also a "resolution" line in the file.

 

For the way the map is rendered, I see that too, and I'm not sure how to fix it, except maybe to play on a different resolution.  You might need to experiment a bit.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 39 of 46 (442 Views)

Re: Poor graphics/low-resolution/graphics glitches (TS3 64-bit)

★★★ Novice
@puzzlezaddict I forgot to mention in my original post, that the cmd-enter worked in the 32bit version just fine.

I changed the fullscreen to 0 and that resolution works fine (ish) for the moment.

I did notice two side effects in windowed mode however.
1. Edge scrolling now won't work (it is checked), to move around I have to use the arrow keys.

2. Now my fans are running when they weren't before when the game was true fullscreen. The frame rate now is either 24/25. Interestingly enough, when I check The Sims 3 CPU usage in Activity Monitor is only like 23.6, which normally to get the fan(s) running it has to be like 90+

Not directly related, but I'm pleased to see in the 64 bit version I didn't have to edit the GraphicCards.sgr and GraphicsRules.sgr to get the game to recognize my graphics card.
Message 40 of 46 (434 Views)
Twitter Stream