Help us improve Answers HQ! Take Survey No, Thanks

Re: Patch Causes Error - No Troubleshooting Working!

by Bluebellflora

Original Post

Patch Causes Error - No Troubleshooting Working!

★★★★ Novice

I've uninstalled and reinstalled The Sims 3 (sans expansion packs) about 25 times now. This is exhausting! 


I have a Macbook air with the most recent update: High Sierra 10.13.5


So, here's the deal: I have a new computer. I did not put any old Sims data on the computer, I was starting from scratch. I installed my base game and all of my expansion packs and then didn't play for a while. 


Before playing my game for the first time, I installed some custom content. I go to play the game and the launcher loads, the game starts to load, and then I get the "no disc" error for the Island Paradise expansion pack. It's happened before on a different computer--not a big deal. I can usually fix this. So, I troubleshoot this but nothing is really working. My initial thought was that there was confusion from the mixture of Origin downloads and the CD. I think that initially everything was installed via CD and I tried to play with the CD. Then I tried to play by opening Origins. I did some investigating about the relationship there. Some related troubleshooting. I did not do any uninstalling yet. 


Next issue: I get to a troubleshoot solution that suggests putting all my Sims files on my desktop. Something went wrong with this. Now, my launcher doesn't open, but I also don't get an error message. I get some invisible launcher window. The computer say it's open but it's not. I now try troubleshooting for this new issue without uninstalling. 


Okay, now I'm tired of these little troubleshooting tactics. I uninstall everything, but I keep the custom content. Now the game has a new issue. The launcher won't open, and I get an unknown error. I try restarting. I try the super patcher (with checking my region). I uninstalling and trying an Origin download. I try uninstalling that and trying a disc installation. I go back and forth with those. I try updating/uninstalling/reinstalling Origin. I try bypassing the launcher. I try making a new admin account for just the sims. I try hiding my custom content outside of documents. I'm not listing everything. I maybe should've written down what I tried, but I didn't think the process would be this cumbersome. Just believe that I've scoured the web and tried all the basic troubleshooting techniques. 


Then I'm like, fine, no custom content. I get it, okay, I'll just delete EVERYTHING and uninstall EVERYTHING (always with a program that totally cleans files out--or at least to the degree it can find related files). I tried to clean out any misc, hidden Sims files. Truth be told, I was having a hard time finding them. It seems like files are hiding in my finder--visible under some circumstances and not visible under others (or with the "search" feature). But anyway. To the best of my ability, everything=gone. 


So, now I've gone a totally blank slate. I do all the things again. I try every troubleshooting tactic again with a blank slate and with reinstallation and computer restarts in between. Still, the unknown error message comes up instead of the launcher. So, a few more restarts/reinstallations. After temporarily switching to attempts at installation with Origin, I go back to disc installation. The launcher starts opening! There's a mandated update, so I comply. Everything is working until the very end of patching. And, it appears that the patching finishes. Then: nothing. I open the Sims and the error comes up in replace of the launches. Okay, reinstall and repeat. This time, I restart my computer before updating. No luck. Reinstall and repeat. This time, I manually install the super patch rather than updating with the launcher and no luck. It's not that the update didn't finish (I think), and I didn't get an update-related error after my attempts. It seems like the update itself is the issue, not the process. 


My most recent troubleshooting tactic (based on this update experience)  was to try to find an older version of the patch and install that. I DID find one, but only for EXE. And, who knows if that would've worked anyway. So, I just tried a couple different super patch links. 


What is going on?! I'm no expert at this, but I've had Sims for a long time. I know how to troubleshoot. I've never run into something like this before. I've read so many forums and potential solutions. Nothing is working. I have nothing that could be corrupting the game, as far as I can tell. I've even tried using a junk cleaner to get rid of excess files. What am I missing? 

Message 1 of 6 (210 Views)

Re: Patch Causes Error - No Troubleshooting Working!

@fluffyvmpr  The first thing to note is that macbook airs are not proper gaming computers, and most of them except perhaps the newest models are not well-suited to run a game like TS3.  Their processors and graphics cards may not meet the game's recommended requirements, and they don't have the cooling power to withstand the demands on their hardware.  Even if you can play the base game, the heaviest hitting EPs in particular (Pets, Seasons, then IP and ITF) may be to much for your mac.  But if you want to try go get the game running on this computer, here's how to proceed.


There are a couple of (sort of) recent issues with installing TS3 that have been causing you problems.  The first is that High Sierra and other new versions of mac OS will not authenticate discs and therefore won't let you play properly with a disc install.  The solution to this is to install entirely through Origin.  (You could also install most of your packs through discs, except for the most recent one by release date, which would need to be installed through Origin to avoid the disc authentication failure.  But Origin doesn't always handle a mix of disc and digital installs as well as it should, so it's probably better to just download everything through Origin if you can.)  You can read more about the disc issue in this thread:


By the way, since you've uninstalled and reinstalled a number of times, you may want to clean out all the TS3-related files and start over.  Remnants of a previous install could get in the way later when you try to play.  Here's a guide on which files to delete and where to find them:


Once you've uninstalled everything, try installing the base game only.  It was a good idea to patch your game after installing, but doing so through the launcher doesn't work well.  It's better to run the Super Patch (digital download version):


Even after patching the game, you may still get an unknown error message.  I don't know which model macbook air you have, but many of them have processor/graphic card combinations that are incompatible with TS3.  If you can't even run the base game, you'll need to edit its .sgr files to force recognition of your graphics card.  Here's a guide on how to do it; if your particular model is not on the list of affected computers, you can post back here for more guidance.


The unknown error is to be expected if you've installed at least one of Ambitions, Late Night, Fast Lane, and Outdoor Living.  Certain files do not get copied to their proper destination, so you have to do it manually.  To be clear, you need to place the files in the folder of your newest pack by release date.  The embedded video in the first post in this thread shows you how to do it:


You may also need to create an alias for one or more of these four packs if they don't already exist in your Applications folder, alongside the aliases for the base game and your other packs.


These steps will allow most people to play on newer macs, but some computers still won't run the game.  Especially with High Sierra, macbook airs in particular have been unable to launch TS3, even where they'd been running it for a while.  If you do everything listed and still can't even launch the game, you can post back here with your computer's specs and we'll try to help you.  But it's also possible that you simply won't be able to play on this computer.


I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 6 (190 Views)

Re: Patch Causes Error - No Troubleshooting Working!

★★★★ Novice

I've only been troubleshooting with the base game at this point, so the complications with expansion packs should be taken care of. 


I looked for the files mentioned (the files that could be lingering after an incomplete installation -- like the "transgaming" files). I couldn't find any via Finder. Perhaps it's possible that they're hiding somewhere. I'm not sure. I looked in the obvious places within finder and did a search. No dice. 


I tried reinstalling the game with Origin so that I could use their "repair" feature. For whatever reason, it's offered for my Sims 4, but not for Sims 3. I have the newest version of Origin and all that. No, again, no dice there. 


Graphics don't seem to be an issue. My computer isn't on the list of problematic computers, and I know that the game was able to start previously. Remember, the first issue was the "no disc" error once at the cusp of playing (at the pick-a-household stage). I've gotten that on other Macs and have fixed it. So, in other words, my computer went through all the initial scenes and the loading processes without a problem. The game worked perfectly fine up to this point. Graphics were great. Speed was normal. Everything was working fine. I wish I could get back to this original error, and I don't know why I can't. That seems strange to me, and it's something to ponder. I was getting that error, why can't I get that error again? What's different now? The "no disc" error prior to picking a household seems like a simpler error to deal with--I think I'd prefer it. 


I've tried the SuperPatch without the launcher update. The game launcher opens (when installed by disc, not by origin) prior to ANY update. Both the launcher update and the manual patch installation lead to the unknown error. Though, they both seem to complete their installation. 


Here are some of my computer specs... I checked for updates, but none are available. 


Screen Shot 2018-07-11 at 2.13.57 PM.png


I find it hard to believe that my computer would be incapable of playing the game. I've always had macbooks (different types, even), and it's always been fine. I get that it's maybe not ideal, but it's always worked. Plus, this computer was previously able to start the game up (and did so well). Clearly, there's some other issue if I can't even get back to that stage. Maybe the first question isn't even so much about what's preventing the game from playing, but about why the error has changed when, seemingly, the conditions are the same as they were when the first error occurred. Clearly, though, that's not the case. Something's gotta be different--unless, for whatever reason, expansion packs would actually aid in the initial loading of the game(?) That would explain why parts of the game can load--like an intro potentially provided by an expansion pack without the aid of the base. I don't know if that's the case, though.


I'd buy into the possibility of a corrupt file hiding somewhere. That's making the most sense to me. But in that case: where?! My finder seems to be hiding files from me. I tried to reveal all files with a code in Terminal. I still didn't find any missing Sims files. I just feel like there have been discrepancies between what I see in Finder and what I see when I use the search tool in Finder. That being said, I did use a full installer with CleanMyMac. But, perhaps it doesn't know what to look for with something like the Sims. I'm not sure. 

Message 3 of 6 (165 Views)

Re: Patch Causes Error - No Troubleshooting Working!

★★★★ Novice
Message 4 of 6 (164 Views)

Re: Patch Causes Error - No Troubleshooting Working!

@fluffyvmpr  A couple of small things to note:  First, macbook airs and macbook pros, if that's what you've had in the past, are very different.  Pros have better hardware and cooling and are spefically designed to run more resource intensive programs, while airs are supposed to be lightweight and portable.  You're right that your particular mac meets minimum requirements for the game, but it could still struggle to run the heaviest-hitting EPs.  (Still, if you're unable to launch even the base game, that can be put aside.)  Second, EA hasn't updated the game in years, so mac OS has become increasingly incompatible with TS3.  The disc authentication failure and unknown error messages didn't become common until the release of El Capitan.  I don't know when you last played, or what OS you were running, but it's not surprising that you'd have more trouble with TS3 now than before.


As for the files you need to delete after an uninstall, the Finder won't be able to locate them for you, as they're too far down into subfolders for the search to work.  That's why Bluebellflora's guide is so useful—just follow the instructions and trash every file on the list.


Once you've uninstalled, reinstalled the base game through Origin, and patched, it's probably a good idea to drag your TS3 game folder, if you still have one, out of Documents\Electronic Arts and onto your desktop.  You wouldn't be able to find this folder in a Finder search either, as the EA folder is hidden.  But it would have been generated when you first launched the game, and it conceivably could be causing issues now.  If there's no game folder in Documents\EA, the game will generate a new one with no content in it.  By the way, this is called the clean folder test, and it solves a lot of problems with games that are lagging or failing to load.


Anyway, at this point, it's probably best to just complete these four steps (uninstall using Bluebellflora's guide, reinstall through Origin, run the Super Patch, and remove your game folder, if you have one). and then see if you can launch and play for a bit.  Whether this works obviously dictates the next step(s), but either way, post back and we can go over what to do.


I don't work for EA. I'm just trying to help fellow players with their games.
Message 5 of 6 (151 Views)

Re: Patch Causes Error - No Troubleshooting Working!



@puzzlezaddict has covered all the issues with your game but If I could just reiterate:


  1. Your Mac is NOT supported as it has Intel HD 6000 graphics and a Broadwell CPU, the worst possible combination to try to get the game running (listed here). You are also running an unsupported version of macOS.
  2. 3rd party 'clean up' apps are appalling and should never be used. They quite often delete files they shouldn't and can cause instability of the OS by doing so. You should manually uninstall the game by following the instructions in my guide that Puzzlez linked to. It may be a faff for you but it is the only guaranteed way to get rid of ALL residual files left behind by the uninstaller. Just searching in Finder is not going to find them as they are in your hidden Library folder. Trust me, I have fully tested this myself many times over the last 8 years on every single version of macOS since the game was launched and I regularly update my pages if anything new is found.
  3. Forget Origin to try and get your game running. It is NOT needed to play the game or even install it, only to download the .dmg. There is also no repair function for Sims 3. You could even delete Origin from your Mac and Sims 3 would still run.
  4. MacBook Airs are great but they really aren't gaming machines. You have a dual core CPU and an integrated graphics chip. Sims 3 is not a natively written app for macOS, it is the Windows version 'wrapped' using Cider. Sims 4 is natively written for macOS so there is no comparison. Because of Cider your Mac is having to work extra hard just to get your game to load, let alone play. There is also the 2Gb RAM limit for the game.



Using CC/Mods is at your own risk, EA are not responsible for making the game compatible with 3rd party content, the creator is. 

The Sims 3 Mac Help Thread - | - The Sims 4 Mac Help Thread -
- The Sims 3 Mac super patch 1.67 - | - Origin Reset Tool for Mac -
- I am not affiliated with EA in anyway -
Apple Signature.png
Message 6 of 6 (145 Views)

Want more Sims?

Check out our Sims forums for tutorials and all things Sims.

View more


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help