Help us improve Answers HQ! Take Survey No, Thanks

Mods not playable

by chloerrox
Reply

Original Post

Mods not playable

[ Edited ]
★★★★★ Newbie

Please help! 

 

I like to think I'm not too new to mods but I'm at a loss. Im on a Mac. but cannot use any mods I have downloaded.

 

I save my mods as followsI  have made sure all mods are saved .package  -

Electronic Arts > The Sims 4 > Mods > (I save my chosen mods here)

 

I have removed all mods to see if it is a specific file that corrupted but all of my mods are still showing up when I go into settings in game and look at mods. Ive attached a picture. When I go into create a sim, i only have a handful of CC in each category but these are old ones and are still showing up despite me removing them from the folder on my Mac. 

I have checked to make sure none are zipped files, I was going to remove all categories and check one at a time to see which was corrupted but still not working. I just don't understand why the game is acknowledging they are there but then not showing them in create a sim. I have also tried to remove them from iCloud and store them on my laptop

When ever I try to open sims through Origin I get a notice come up to say 'cannot open application' but it opens and performs as normal anyway, not sure if this has anything to do with it. 

 

Thanks in advance

Message 1 of 3 (234 Views)

Re: Mods not playable

★ Novice

dont put them in too much folders and make sure to check if you already activated the mods option in the configuration menu!

Message 2 of 3 (126 Views)

Re: Mods not playable

@chloerrox

Is the issue game Mods which alter the game in anyway? Or CC objects/CAS items?

If the latter maybe the creator hasn't tagged them properly in which case they may not show in the correct categories.

The Sims 3 Mac Forum - | - The Sims 4 Mac Forum -
- Origin Reset Tool for Mac - | - Current broken Mods List -
AHQSigImage.png
Please do not PM me unless I ask you to, I won't reply
- I am not affiliated with EA in anyway -
Message 3 of 3 (116 Views)
Twitter Stream