Help us improve Answers HQ! Take Survey No, Thanks

[CURRENT ISSUE 64-bit] Terrain paints not applying

by Bluebellflora
Reply

Original Post

Re: [CURRENT ISSUE 64-bit] Terrain paints not applying

★★★★★ Apprentice
@Bluebellflora Yep me too. But the paint from my previous creations is still there. I just can't make any new ones.
Message 21 of 31 (693 Views)

Re: [CURRENT ISSUE 64-bit] Terrain paints not applying

★★★★★ Apprentice

I get the feeling that we are just going to have to live with bugs like this.  I imagine that EA is "done" with this game.  

Message 22 of 31 (692 Views)

Re: [CURRENT ISSUE 64-bit] Terrain paints not applying

★★★★★ Apprentice
@Dorabella123 You are correct -- it does not show up at first, but when you go to live mode, click on map view, then click it again (to get out of map view), it all shows up.
Message 23 of 31 (689 Views)

Re: [CURRENT ISSUE 64-bit] Terrain paints not applying

★ Apprentice

Its kinda sad that they did not fix this. I guess the one patch we got for the MacOS release was is. Back to Parallels then, I guess :/

Message 24 of 31 (616 Views)

Re: [CURRENT ISSUE 64-bit] Terrain paints not applying

★ Novice

Can you explain to me how to use Parallels? 

 

Message 25 of 31 (543 Views)

Re: [CURRENT ISSUE 64-bit] Terrain paints not applying

@romeiojohnson  Here's a good place to start:

 

https://www.parallels.com/welcome-new/

 

However, if you're going to install Windows, you'd get better performance running the game through Bootcamp instead.  The graphics drivers provided by Parallels are pretty bad, wherease the ones in Bootcamp are fine.  Additionally, your Mac would only need to run one OS at a time rather than splitting resources between both.

 

And of course it's cheaper to buy only the Windows 10 product key you'd need for Bootcamp than it is to buy the key and the Parallels subscription.

 

On the other hand, if you'd like to troubleshoot your current issue, maybe we can address it enough that you can keep playing in macOS, without the need for either of these approaches.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 26 of 31 (523 Views)

Re: [CURRENT ISSUE 64-bit] Terrain paints not applying

★★ Novice

Cant use the terrain paints either, exactly the same issue as described. Has anyone found any way around it? I really hope they fix it because although it may seem minor and it has been classed as a minor glitch as someone who mostly enjoys the building side of the sims, it's a bit of a dealbreaker which is a real shame because there's nothing that overly excites me about sims 4

Message 27 of 31 (421 Views)

Re: [CURRENT ISSUE 64-bit] Terrain paints not applying

★★ Novice

I really hope we get a fix for this soon. This problem seems widespread and persistent, and EA is well overdue in addressing the issue, even after multiple game updates.

Message 28 of 31 (227 Views)

Re: [CURRENT ISSUE 64-bit] Terrain paints not applying

★★ Novice

Same issue for me. Snow also won't stick to home lot, in conjunction with the static hair and block eyelashes. Seems to be an underlying graphics issue in 64bit that desperately needs a patch. It's now Feb '21 and the first reports were in October '20 so they really need to work on this. Do they read these forums? Can we...call them?

Message 29 of 31 (194 Views)

Re: [CURRENT ISSUE 64-bit] Terrain paints not applying

★★★★ Novice

I am also having this issue, I built a house in edit town for my family to move into and when I put the terrain paint down it didn’t appear except for in the one spot I painted it last. What I’ve noticed is that when I left build/buy back to edit town and then went back into the lot the terrain paint appeared. You just kind of have to guess where you want them and how they apply for you to have terrain paints. 
Hope this helps!

Message 30 of 31 (171 Views)
Twitter Stream