Help us improve Answers HQ! Take Survey No, Thanks

Re: Terrain paints not applying, TS3 64-bit

by Bluebellflora
Reply

Original Post

[CURRENT ISSUE 64-bit] Terrain paints not applying

[ Edited ]

The terrain paint tool does not seem to be useable. I can select the paint and click to apply but it does not stick:

 

 

Played around with graphics settings in-game but cannot currently find a workaround.


The Sims 3 Mac Forum - | - The Sims 4 Mac Forum -
- Origin Reset Tool for Mac - | - Current broken Mods List -
AHQSigImage.png
Please do not PM me unless I ask you to, I won't reply
- I am not affiliated with EA in anyway -
Message 4 of 32 (2,113 Views)

Re: Poor graphics/low-resolution/graphics glitches (TS3 64-bit)

★★★★★ Novice

Is anyone else having issues with terrain paint not working? I'll try to use it and it just doesn't appear unless I click undo and even then it doesn't cover everything and is pretty patchy or just doesn't show up at all. 

Message 1 of 32 (2,280 Views)

Re: Poor graphics/low-resolution/graphics glitches (TS3 64-bit)

@Padmefan2017

Which specific terrain paint and which lot are you on? I'd like to test in my game.

The Sims 3 Mac Forum - | - The Sims 4 Mac Forum -
- Origin Reset Tool for Mac - | - Current broken Mods List -
AHQSigImage.png
Please do not PM me unless I ask you to, I won't reply
- I am not affiliated with EA in anyway -
Message 2 of 32 (2,222 Views)

Re: Poor graphics/low-resolution/graphics glitches (TS3 64-bit)

★★★★★ Novice
@Bluebellflora For me, it's been every terrain paint on every lot. I've only played Sunset Valley both community and residential lots. Also if I use level terrain all-terrain paint disappears for me.
Message 3 of 32 (2,304 Views)

Re: Terrain paints not applying, TS3 64-bit

I saw this too.  If I click to apply terrain paint in one location, it does stick, even when I go back to live mode.  But if I click somewhere else, the previous spot disappears, like there can only be one spot on the lot with any terrain paint at all.  This happens whether I switch to live mode and back to build mode or just stay in build mode.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 5 of 32 (2,080 Views)

Re: Terrain paints not applying, TS3 64-bit

★★ Apprentice

I, too, am having the terrain paint issue.  It will not stay applied.  Reinstalling the game and/or repairing the game are not working as solutions for me.  I have also tried adjusting the graphical settings in various ways.  Please see device information below.

 

Name: Sims3
Version:
Build: Release
=== Rating info ===
GPU: 5 GPU Memory: 5 CPU: 4 RAM: 5 CPU Speed: 2300 Threading: 3
Adjusted CPU: 3910 RAM: 16384 Adjusted RAM: 15872 Cores: 8
Card Found in DB: 1
=== Machine info ===
OS version: Mac OS X Version 10.15.7 (Build 19H2)
OS prod type: 0
OS major ver: 10
OS minor ver: 15
OS SP major ver: 0
OS SP minor ver: 0
OS is 64Bit: 1
CPU: MacBookPro16,1
Brand: Intel(R) Core(TM) i9-9880H CPU @ 2.30GHz
Family: 8
Model: 7
Cores: 8
HT: 1
x64: 1
Memory: 16384MB
Free memory: 3809MB
=== Graphics device info ===
Number: 0
Name (driver): AMD Radeon Pro 5500M
Name (database): AMD Radeon Pro 5500M [Found: 1, Matched: 1]
Vendor: ATI
Chipset: Vendor: 1002, Device: 7340, Board: 0000020f, Chipset: 0040
Driver: macOS Metal driver, Version: 0.0.0.0
Driver version: 0
Monitor: 00000000
Texture memory: 4080MB
Vertex program: 3.0
Pixel program: 3.0
Hardware TnL: 0

 

Message 6 of 32 (2,070 Views)

Re: Terrain paints not applying, TS3 64-bit

@ew2013

Please can you attach the file, not just c/p part of it. You can open in TextEdit and take out your name, we don't need that Standard smile

The Sims 3 Mac Forum - | - The Sims 4 Mac Forum -
- Origin Reset Tool for Mac - | - Current broken Mods List -
AHQSigImage.png
Please do not PM me unless I ask you to, I won't reply
- I am not affiliated with EA in anyway -
Message 7 of 32 (2,066 Views)

Re: Terrain paints not applying, TS3 64-bit

★★ Apprentice

Absolutely!  Please see attached.

Attachment
Download this attachment
Message 8 of 32 (2,058 Views)

Re: Terrain paints not applying, TS3 64-bit

★ Guide

Hey! This has been glitchy for me as well. I've also messed around with some settings and restarted my game when it first happened. At least this isn't ultimately game breaking haha 😅

Message 9 of 32 (1,875 Views)

Re: Terrain paints not applying, TS3 64-bit

★★★★★ Apprentice

I also have this problem. Whenever I try to use terrain paint it doesn't apply the paint and for some reason it also deletes all other terrain paint that was on the lot originally 

Message 10 of 32 (1,832 Views)
Twitter Stream