Help us improve Answers HQ! Take Survey No, Thanks

[CURRENT ISSUE 64-bit] Keyboard commands don't release

by puzzlezaddict
Reply

Original Post

[CURRENT ISSUE 64-bit] Keyboard commands don't release

[ Edited ]

Update:  After today's (November 9) patch, cmd-Z and -Y should now work exactly once rather than undoing or redoing every change made in Build or Buy mode.  If you'd like to undo or redo multiple changes in a row, please use the UI buttons instead.

 


 

A number of players have reported that keyboard shortcuts seem sticky or are continuously applied.  I found two obvious examples.

 

In Build or Buy mode, cmd-z (undo) and cmd-Y (redo) are continuously applied after being used once.

 

I applied six floor tiles one at a time, then clicked Undo six times, and the tiles disappeared one at a time, as expected.  I then hit cmd-Y to redo, and one tile appeared, and a second later the others appeared in quick succession.  I clicked cmd-Z to undo, and they disappeared in the same pattern.  From there, I tried to place a tile, and it was instantly undone, over and over, with the money credited to the sims' household funds as when a purchase is undone.

 

  • I reproduced this multiple times, including in a new save in a clean user folder, in both Build and Buy modes.
  • Switching to another category of item, or even to Buy Mode, does not break the pattern.
  • Switching to another window (in this case a browser) and then back to the game sometimes breaks the pattern.
  • The Undo and Redo UI buttons are unaffected.
  • Occasionally, the keyboard commands work correctly a couple of times in a row before defaulting to this behavior.

The cmd-up arrow and cmd-down arrow keys move the camera to the maximum (top down) and minimum (parallel to the ground) viewing angles, respectively.

 

  • I see this in Live, Buy, and Build Modes.
  • Once one command has been used, the other usually doesn't work.
  • Once one command has been used, the UI buttons don't work.
  • Switching to another window and back restores the function of the commands and the UI buttons.
  • Clicking somewhere in-game, not on the UI, restores all functions.
——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 4 of 19 (814 Views)

Sticky keys in Build Mode (64-bit)

★★★ Apprentice

So, I got my code, the game works, jay! Up until the moment I am trying to build a house in Edit Town, then the game feels quite buggy. For example: using CMD-Z to undo and CMD-Y to redo are sticky. So: either everything I've built gets undone, or everything including faults gets redone. The same with tilting the camera using CMD-up/down-arrow: the camera fully tilts up and down. All graphic settings are at their lowest, on a 2017 MacBook Air 1.8GHZ, with intel HD graphics 6000. Would there be something I could change in settings? I have tried to repair the game, as well as uninstall and install the game again.

Message 1 of 19 (859 Views)

Re: Sticky keys in Build Mode (64-bit)

[ Edited ]

@PowerDijk  I can reproduce all this too.  I'm not sure whether there's anything to be done, but I'll let you know.  Please also test the undo and redo buttons, just to see how they work.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 19 (828 Views)

Re: Sticky keys in Build Mode (64-bit)

★★ Apprentice

I have the same problem with command + up/down or left/right arrows. A couple of times they would un-stick if I pressed command again but not always. Quite annoying actually as the game ignores my clicking on the control panel arrow buttons as the camera tilts all the way up or down.

Message 3 of 19 (817 Views)

Re: Keyboard commands don't release (Sims 3 64-bit)

@PowerDijk and @stickyhips  I've made a master thread for this issue.  Please click Me Too on the first post, and feel free to add any other observations.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 5 of 19 (801 Views)

Re: Keyboard commands don't release (Sims 3 64-bit)

★★★ Apprentice

For me, the camera buttons work, as well as the undo/redo buttons. It's just the keyboard shortcuts that work incorrectly.

Message 6 of 19 (750 Views)

Problems running cmd + z (TS3 64-bit Metal)

★ Apprentice

Greetings everyone.
Today, after installing the new TS3 (64bits Metal), I noticed that, when undoing an action (cmd + z), all previous actions done until then are undone. Another problem that I noticed refers to the terrain painting tool, it is failing.
Any solution?

 

🖖🏻

Message 7 of 19 (710 Views)

Re: Problems running cmd + z (TS3 64-bit Metal)

★★★ Apprentice
@MAUGUSTORJ Hello there. I think that currently, the only way to bypass the CMD + Z issue is to use the undo/redo buttons.

As far as the terrain painting tool, I got nothing.

Hopefully, these problems will all be fixed as soon as possible.
Message 8 of 19 (701 Views)

Re: Keyboard commands don't release (Sims 3 64-bit)

@MAUGUSTORJ  and @Arual7296  I've merged your posts with the master thread on this issue.  It would help if you clicked Me Too, and feel free to add any other details you find relevant.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 9 of 19 (690 Views)

PLEASE HELP ME!!

★★ Novice

So. Every time I try to change anything on a lot, all my changes get reverted back to how they were before I started editing the lot. It's like someone said "revert" (like when you edit a photo on and there is a "revert back to the original" and your edits go away). I am so irritated because I just wanna play my favorite game and build houses like I used to. 

ANYWAY... I can assure you that this is not a keyboard issue or has anything to do with the functionality of my computer as I am typing my frustration. 

I have also done the following:

  1. Uninstalled and reinstalled the game
  2. Deleted the Sims 3 folder
  3. Played with and without mods
  4. Uninstalled my CC and redownloaded and reinstalled ALL of it 
  5. I have tried to get in contact with EA and they just closed the issue. FYI EA: It is still happening! 
  6. I have turned my computer on and off
  7. I have repaired the game via origin.

I have not (yet) given up hope and downgraded my old computer to Mojave because 1) Sims 4 is nowhere near as good as the Sims 3; 2) I just want to play my game that I have invested not just my $$ but days of my life (the simhole).

For reference my computer specs are 

  • MacBook Pro 13" 2020
  • 2.3 GHz Quad-Core Intel Core i7

  • 16 GB 3733 MHz LPDDR4X

If you have any suggestions that have not been mentioned: PLEASE HELP ME!!! 

 

Message 10 of 19 (496 Views)
Twitter Stream