Help us improve Answers HQ! Take Survey No, Thanks

64 bit CC and Worlds

by CL199666
Reply

Original Post

64 bit CC and Worlds

★★★ Novice

Can someone please help? My custom worlds seem to be missing only my expansion pack worlds are there and all my CC is gone? Anyone else having this problem? Frown

Message 1 of 10 (206 Views)

Re: 64 bit CC and Worlds

@CL199666  When you reinstalled your content, did you ever see it in your game?  Does the launcher still think it's installed?

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 10 (182 Views)

Re: 64 bit CC and Worlds

★★★ Novice

Nope my .package files seem to be in the game but anything I’ve installed via the launcher isn’t showing up in game Frown 

Message 3 of 10 (165 Views)

Re: 64 bit CC and Worlds

@CL199666  Okay, but is it specifically in the launcher's Installed Content tab?  That can help distinguish between different causes.

 

Please also open Documents > Electronic Arts > The Sims 3 > InstalledWorlds, and let me know whether your custom worlds are listed there.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 4 of 10 (152 Views)

Re: 64 bit CC and Worlds

★★★ Novice

Sorry I’m not too sure what you mean by the first question sorry? Ye all my worlds are in the installedworlds folder Standard smile 

Message 5 of 10 (132 Views)

Re: 64 bit CC and Worlds

★★★ Novice

……same issue, and i checked my installed worlds folder and all files are there, but just didn't show up in my game....And all my S3P custom contents all gone, I have to turn them into package file, and although most custom contents can turn into package, but worlds, sims and lots cant.....

Message 6 of 10 (129 Views)

Re: 64 bit CC and Worlds

★★★ Novice

I’m so sorry Frown it’s so annoying I hope they fix it soon especially if it’s an issue a lot of people are having!

Message 7 of 10 (121 Views)

Re: 64 bit CC and Worlds

@CL199666  If you press Play in Origin, the launcher opens.  Click the Installed Content button on the left, and see whether your worlds are on the list.  This will show whether the launcher sees the worlds as installed or not.

 

@CL199666 and @ChihChihs  Given what you've described, you may need to rebuild your user folder.  Move the entire Sims 3 folder out of Documents > Electronic Arts and onto your desktop, open the launcher to spawn a clean folder, and download and install one item.  Check in-game to see whether it shows up.  If it does, you can start installing other content in small batches, maybe six items at a time; the launcher has traditionally not handled large amounts of data well.  Worlds are large files and should be handled separately, not in a batch with anything else.

 

Be sure to test often to make sure the content is still loading properly.  You can also periodically save the Sims 3 folder during this process, so if something goes wrong, you won't have to start from scratch (again) but instead can restore the next oldest copy.

 

Once you've reinstalled your content, you can move your saves or anything else you want to keep to the new Sims 3 folder from the old one.  Here's a list of everything in that folder, so you'll know what to transfer:

 

https://sims3.crinrict.com/en/2011/01/faq-user-files.html

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 8 of 10 (98 Views)

Re: 64 bit CC and Worlds

★★★ Novice

@puzzlezaddict  oh sorry! Ye they’re showing up in the Installer Content but not in game?

 

ah ok I’ll try rebuilding my user folder, thank you so much for all that info really really appreciate it! Standard smile 

do you think it’s got corrupted somehow?

Message 9 of 10 (71 Views)

Re: 64 bit CC and Worlds

@CL199666  Before you completely rebuild the folder, another player let me know that repairing fixed the issue for her.  Open your Origin game library, right-click on the Sims 3 icon, and select Repair.  If that alone doesn't work, try restarting your computer, running the Origin reset tool, and repairing again.

 

https://help.ea.com/en-us/help/origin/origin/how-to-reset-origin-on-mac/

 

But if these steps don't help, then yes, it's possible some file was corrupted and is blocking your content from loading properly.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 10 of 10 (67 Views)
Twitter Stream