Help us improve Answers HQ! Take Survey No, Thanks

❗️ [WORKAROUND] Problems playing Sims 4 on the 16" MacBook Pro

by Bluebellflora
Reply

Original Post

Re: Sims 4 no floor and can't build rooms since november 2020

★★★ Newbie

Its a Macbook Pro 2019, 16GB RAM. 2.6 GHz 6-Core Intel Core i7 AMD Radeon Pro 5300M 4 GB. The OS is Big Sur

 

Here's the graphic card details:

 

AMD Radeon Pro 5300M:

 

  Chipset Model: AMD Radeon Pro 5300M

  Type: GPU

  Bus: PCIe

  PCIe Lane Width: x8

  VRAM (Total): 4 GB

  Vendor: AMD (0x1002)

  Device ID: 0x7340

  Revision ID: 0x0043

  ROM Revision: 113-D3220E-190

  VBIOS Version: 113-D32207P1-020

  Option ROM Version: 113-D32207P1-020

  EFI Driver Version: 01.A1.190

  Automatic Graphics Switching: Supported

  gMux Version: 5.0.0

 

Message 401 of 498 (430 Views)

Re: Sims 4 no floor and can't build rooms since november 2020

@Nickypooface

Merged your post into this ongoing thread on 16" MacBook Pros and the issues they have with the game. Please read the opening post and try the workaround in the solution on page 1.

The Sims 3 Mac Forum - | - The Sims 4 Mac Forum -
- Origin Reset Tool for Mac - | - Current broken Mods List -
AHQSigImage.png
Please do not PM me unless I ask you to, I won't reply
- I am not affiliated with EA in anyway -
Message 402 of 498 (412 Views)

Re: Sims 4 no floor and can't build rooms since november 2020

★★★ Newbie

@Bluebellflora thank you

Message 403 of 498 (412 Views)

Re: Still game crash

Community Manager
@cebart73 Hello! There was an update that went out yesterday can you confirm if you are still having issues?
Illium.png

*Accept as Solution button- If a post answers your question please let us and other players know by hitting this button.
*Me Too button - 'Me Too' helps us track how many players are also experiencing that issue. Definitely make use of this button.
*XP button - Say Kudos and help players 'Level Up' by giving them XP for helpful posts.
Message 404 of 498 (417 Views)

Re: Still game crash

[ Edited ]
★★★★★ Novice

@EA_IlliumYes, it IS still happening! And it seems like the problem is now WORSE!!

If I do NOT enable the third party program GFXCardStatus2 and switch to the "Discrete only" option, the game will load, but it will get stuck on the beachball of death when trying to load a lot, etc.

And now, there's a NEW problem! Since some of the latest updates, I've just begun having the issue where the game would be in Fullscreen mode, but in settings it would say that I was in windowed mode, and WOULD NOT SWITCH to fullscreen mode no matter what I did. Even though visually it WOULD BE FULLSCREEN, the game still listed that it was in windowed, so edge scrolling (which I use A LOT) would not work!

It seemed like the GFXcardstatus 2 program was a fix for that, too. If I remembered to enable "discrete only" mode before starting the game, it would always open in fullscreen mode, the game would recognize that it was in fullscreen mode and I'd be good to go.

If I FORGOT to enable "discrete only," the game would freak out, most of the screen would be black, except the bottom left corner where the loading game would fill only 1/4th of the screen, and the settings would be back to windowed, even though, once loaded, it appeared that it was in fullscreen mode again.

The only way to fix it was to exit the game, shut down my computer, and reset the NVRAM by pressing Command + R with my left hand, and Option + P with my right hand immediately after restarting my computer (describing it in detail as a workaround for anyone else having this issue).

Prior to this latest update, I only had to reset the NVRAM if I forgot to open GFXCardStatus2 and enable the "discrete only" mode before starting the game.

Since this latest update, the game now ALWAYS switches back to windowed mode after I close out of a session! Even if I enable "discrete only" mode before loading the game, it always freaks out (as I described before) while loading and the settings have reverted back to windowed mode, even though visually it's still in fullscreen mode!

So NOW, I must reset the NVRAM EVERY TIME I want to play the game! I need to power down, reset theNVRAM, then turn on GFXCardStatus 2, switch to "discrete only," and only THEN can I load the game in fullscreen mode and play without it crashing!!!

THIS IS BEYOND RIDICULOUS AT THIS POINT!!!

How is it that this issue cannot be fixed?!?!? I've talked with customer service at Apple, and resetting the NVRAM so often is NOT good for my brand new computer!!! It is unacceptable that I need to take so many steps AND USE A THIRD PARTY PROGRAM to actually load this game and play it so that it won't crash and it'll recognize that it's in fullscreen mode!!!

IS ANYONE AT EA WORKING ON THIS ISSUE?!?!?!

 

ETA: Okay, it seems like I cannot even load a LOT to edit it without getting the beachball of death that freezes, then crashes the game! FYI, I have successfully played existing sims since the December 2020 patch, but I hadn't tried going into a lot directly to edit it (that crashed the game tonight), and I haven't tried opening CAS yet to check out the new sliders. I will now. And I'll also check to see if I can still play the existing sim without problems as I did yesterday...

 

UPDATE: SO, I was able to go into CAS and create a sim from scratch. And I was able to save her to the gallery (luckily!). Then I tried to load her into the lot that had crashed previously when trying to edit the lot (an EA made lot -- and no, I have no CC or Mods in the game...). As I suspected, the game crashed. I'm gonna try moving her into a different lot from the gallery...

 

UPDATE 2: I downloaded my new sim (using the new makeup/skin tone sliders) from the gallery and was able to successfully move her into both the lot in Willow Creek that kept crashing, and a new apartment lot in Evergreen Harbor (that I've never even loaded or modified at all). I was able put her onto the lots, but not open them up to play them. The second I tried to open either lot, it would start to load, I'd get the spinning beachball of death, and then the game would crash.

 

HOWEVER, I then switched to an already existing household that I had previously made from scratch (not an EA made sim or lot), and I was able to load it. Technically, I'm joining him mid-vacation in Mt. Komorebi. But I did play this household on Dec. 9, AFTER downloading the patch (but not using the sliders), and joined him on vacation in Selvadora, completed the vacation, took him home (the previously created-by-me home did load fine), and then sent him on the new vacation to Mt. Komorebi. So, it seems that sims, and lots already occupied by existing sims, load fine after this latest patch, but any newly created sim crashes, and opening an unoccupied lot crashes the game.

 

NOTE: When I played on Dec. 9, I WAS able to open build on lots he was visiting to edit them, so they weren't occupied lots, but my sim was visiting the lot, and they all loaded fine when he visited them, and I was able to modify them while he was visiting them. I have not tried modifying a community lot directly, without having a pre-existing sim visiting there.

 

I hope this helps towards finally finding a solution to these issues (crashing and the fullscreen issue!). It's ridiculous that this game plays better on my 2012 Macbook than it does on my 2019 Macbook!!! 

 

UPDATE 3: I spoke too soon... Even though I was able to successfully play for hours on December 9, after installing the December update, now my game is crashing even the sim I played on that day! I don't know if the crashing from trying to edit an empty lot has now corrupted the whole game or what, but it is SUPER annoying that I cannot play this game at all without it crashing!!!

 

FYI, I don't know if this information is important at all, but Origin is acting a bit strange. When I click on origin to load it (which is how I access Sims 4, because I ALWAYS check for updates AND repair every single time before playing -- I've been playing since Sims 1, I know it's better to be safe than sorry at this point...), its icon appears on my dock, then vanishes, then appears, then vanishes, then appears and finally loads Origin. THEN, after Sims 4 crashes, the Sims 4 icon disappears from my doc, but the origin logo stays there. But it appears stuck. You can click on the logo, but origin itself won't reappear (I don't know if Origin also crashes with Sims 4 crashes?), You CAN right click on the icon and it gives you a bunch of options of things to do (Funnily enough, Sims 4 is still listed at the top as if it's still open, and if you click on the Sims 4 title, it reloads the game, AND when it reloads the game, Origin will oddly pop up in the background, then disappear). HOWEVER, when the origin icon is stuck in the dock after the Sims 4 crashes, you can click on "open origin" but origin won't open. You need to click on quit (which works), then reopen origin to repair Sims 4 and try loading the game again. I'm only mentioning this on the off chance that its perhaps origin that is causing the game to crash. I doubt it, but I figured it's worth mentioning...

 

UPDATE 4: UGH! Okay, so when my game refused to recognize that it was in fullscreen mode again after I restarted the computer and loaded the game again (if I don't restart the computer, I can close and reload the game multiple times and it will always load in fullscreen mode AND recognize that it's in fullscreen mode. But if I shut down my computer, then try to play the game, the setting always switches back to windowed mode, even when it is clearly still in fullscreen mode! And resetting NVRAM is the only way to fix it!). ANYWAY, so, when I was trying to get the game settings to recognize it was in fullscreen mode, I tried turning on "laptop mode" again. (FYI, enabling laptop mode did NOT fix the fullscreen/windowed issue). I forgot to turn it off again! 

 

Now that I have turned off laptop mode, I was able to successfully load the lot that had been crashing before. I'm assuming I'll be able to move in and open the lot with my newly created sim, too. BUT, it does overtax my laptop to play it with the laptop setting off. Is there any reason why the "laptop mode" does not work with the Macbook Pro 2019, and do they have any plans to fix this issue?!?

Message 405 of 498 (383 Views)

Re: Still game crash

@cebart73

I believe you are already aware of the issues with the 16" MBPs - https://answers.ea.com/t5/Technical-Issues-Mac/WORKAROUND-Problems-playing-Sims-4-on-the-16-quot-Mac...

The Sims 3 Mac Forum - | - The Sims 4 Mac Forum -
- Origin Reset Tool for Mac - | - Current broken Mods List -
AHQSigImage.png
Please do not PM me unless I ask you to, I won't reply
- I am not affiliated with EA in anyway -
Message 406 of 498 (350 Views)

Re: [WORKAROUND] Problems playing Sims 4 on the 16" MacBook Pro

★★ Novice

I am playing on my 2019 16" MacBook Pro 

AMD Radeon Pro 5500M

 

My game worked perfectly and never had any issues with crashing, or endless loading screens until the December 2020 update. Since the update, my game is basically unplayable. It will crash without warning randomly, specifically when I place platforms on top of other platforms. It also freezes frequently and becomes unresponsive and I'll have to force quit. It has also caused my entire computer to crash, showing black patches across my entire screen and I'll have to restart my computer. I backed up my saves and un-installed the game then re-downloaded my game and all of my packs, but that didn't work and the issue still persists. I am extremely disappointed because I have spent a lot of money and time on this game and I've barely been able to play at all since the last update. 

 

Message 407 of 498 (267 Views)

Re: [WORKAROUND] Problems playing Sims 4 on the 16" MacBook Pro

@lo1890

It's so weird how this suddenly happens with a patch on an otherwise working game. Did you try the workaround in the solution on page 1 and disable automatic graphics switching?

The Sims 3 Mac Forum - | - The Sims 4 Mac Forum -
- Origin Reset Tool for Mac - | - Current broken Mods List -
AHQSigImage.png
Please do not PM me unless I ask you to, I won't reply
- I am not affiliated with EA in anyway -
Message 408 of 498 (263 Views)

Re: [WORKAROUND] Problems playing Sims 4 on the 16" MacBook Pro

★★ Novice

I just tried that and I think it worked! Thank you!!

Message 409 of 498 (240 Views)

Re: [WORKAROUND] Problems playing Sims 4 on the 16" MacBook Pro

★ Novice

I've had a problem of the floors and ceilings being invisible. Rugs are still there because in dorms I accidentally move them sometimes when I'm moving around the screen. All i see is a solid color for dorms and then the outside ground on homes. 

 

I've got the 16'' 2019 and MacOS BigSur

Processor: 2.3 GHz 8-Core Intel Core i9

Memory: 32 GB 2667 MHz DDR4

Graphics: AMD Radeon Pro 5500M 4 GB

Intel UHD Graphics 630 1536 MB

 

i'll attach some images of the floor, it makes it impossible to decorate the inside of builds and adding roofing. The game also crashes pretty regularly and it mentions core foundation and foundation a lot in the crash report.

Message 410 of 498 (214 Views)
Twitter Stream