Spore via EA Desktop will not launch

by Player_8t3mcjn2
Reply

Original Post

Spore via EA Desktop will not launch

★★★ Newbie

I have Spore installed on my son's PC.  We have an EA subscription via Game Pass.  Starting a few days ago, Spore refuses to launch.  The only option is to update.  When I click Update, it seems to download something briefly, then it goes back to prompting me to update.  

 

The same behavior occurs on my own PC.  Spore prompts for an update.  

 

I've tried the following:

 

* Cleared cache via Help | App Recovery | Clear cache

* Removed the Spore directory to force another download

* Uninstalled both the EA Desktop app and Spore and re-downloaded them 

* Verified we have plenty of free space and that the system date and time are correct

 

I chatted with EA Support.  After trying all of the above again, he suggested I post here for help.

 

Given that this is happening on two different machines, I wonder if something is wrong with either my account or with Spore in the EA Games service.  

 

 

Message 1 of 2 (268 Views)

Re: Spore via EA Desktop will not launch

★★★ Newbie

Forgot to mention that I tried launching Spore as an Adminstrator. 

Message 2 of 2 (255 Views)
Twitter Stream