Spore.com doesn't recognize that I own Galactic Adventures.

by BucklesFreeman

Original Post

Spore.com doesn't recognize that I own Galactic Adventures.

[ Edited ]
★★★ Novice

Galactic Adventures is on my Steam account.
Galactic Adventures is on my Origin account.
My EA and Steam accounts ARE linked.
My Spore.com account says I don't own Galactic Adventures.

My copy of GA was bought by me with my money in 2010.


I've tried contacting support 7 times now...
One said I should talk to Steam and I did. Steam told me they cant do anything.
Another said I should link EA and Steam and I did.
Another told me they have nothing to do with Spore.com.
Another seemed to understand my problem and asked for me to provide proof of purchase and I did. He asked me to verify my email account with a code. I emailed the code back and it ended there.


They act like they have NO clue what I'm talking about.


I know about the "can't log in through steam" problem but this problem is different. I can log in and play the game just fine. The game running and logging in have nothing to do with this problem.


Spore.com and sporepedia are acting like I don't have GA. That means no downloading captains or adventures. No sharing captains or adventures. No leaderbordes. No sporepoints. No Trophies. No credit for GA achievements. And whatever else comes along with owning GA.


There are 2 ways EA can fix this for me...
1. Go into my account and verify that my copy of Galactic Adventures is real.
2. Remove Galactic Adventures from my account. So I can buy a copy through Origin so you KNOW it's real.


-people with this same problem-

K, I'm gonna stop. There's clearly tons of people with this problem. Just search for it. One thing I can't find is a solution other than somebody telling me to talk to EA... Yeah tried that 7 times now.

However, look at this one. This guy seemed to have had it fixed for him.


Please Fix This For Me!

Message 1 of 12 (3,712 Views)

Re: Spore.com doesn't recognize that I own Galactic Adventures.

★★★ Novice

1 month later and still no help.


7 conversations with EA support and nobody is able to understand my problem.


I really hate to say this, but I have a feeling that if I could talk to somebody at support to whom English is their first language I'd be able to get this fixed. Every time I talk to EA support it's like talking to somebody who isn't listening to me, they just look for keywords in what I'm saying and consult a "common problems" list and take it from there. I'm pretty sure that all of them thought I was having a problem making an account or logging in. When those have nothing to do with my problem.


One support conversation went like this...


Support: "ok I need you to launch the game through steam."

Me: "ok I launched it. now what?"

Support: "so the game works and you can log in?"

Me: "yeah."

Support: "Okay is there anything else you need help with?"

Me: "yeah i need you to help me with my problem..."


As if launching the game was my problem...


They literally don't understand a word I'm saying.


Why is this a confusing sentence?...


Spore.com doesn't recognize that I own Galactic Adventures.


It's like i'm speaking Spanish when I say that or something because when i say that to your support staff they say...


"so you're having a problem linking spore and steam?'




"So you're having problems logging into spore?"



THAT'S NOT MY PROBLEM!!!!!!!!!!!!!!!!!!!














Here i'll translate this to every common language for you.


Spore.com doesn't recognize that I own Galactic Adventures.

Spore.com no reconoce que soy dueña de Galactic Adventures.

لا يتعرف موقع Spore.com على أنني أمتلك Galactic Adventures.

Spore.com 不承认我拥有银河历险记。

Spore.com은 내가 Galactic Adventures를 소유하고 있음을 인식하지 못합니다.

Spore.com ne reconnaît pas que je possède Galactic Adventures.

Spore.com erkennt nicht, dass ich Galactic Adventures besitze.


Spore.com non agnoscit me Galacticum Adventures habere.

Spore.com nie rozpoznaje, że jestem właścicielem Galactic Adventures.

Spore.com не признает, что я являюсь владельцем Galactic Adventures.

Spore.com не визнає, що я є власником Galactic Adventures.

Spore.com känner inte igen att jag äger Galactic Adventures.

Spore.com यह नहीं मानता कि मेरे पास गेलेक्टिक एडवेंचर्स है।


Can you understand now?


Here I'll even do binary...


01010011 01110000 01101111 01110010 01100101 00101110 01100011 01101111 01101101 00100000 01100100 01101111 01100101 01110011 01101110 00100111 01110100 00100000 01110010 01100101 01100011 01101111 01100111 01101110 01101001 01111010 01100101 00100000 01110100 01101000 01100001 01110100 00100000 01001001 00100000 01101111 01110111 01101110 00100000 01000111 01100001 01101100 01100001 01100011 01110100 01101001 01100011 00100000 01000001 01100100 01110110 01100101 01101110 01110100 01110101 01110010 01100101 01110011 00101110 00001010


Now fix it.

Message 2 of 12 (3,458 Views)

Re: Spore.com doesn't recognize that I own Galactic Adventures.

★ Apprentice

I feel the exact same way about the support. Some of them can barely speak English, let alone understand it. I've had the same problems with them you have. They try fixing every problem except the one I'm there for.

Message 3 of 12 (3,409 Views)

Re: Spore.com doesn't recognize that I own Galactic Adventures.

★★★ Novice

It's been like 2 months now of trying to get spore.com to acknowledge that I own galactic adventures and I still can't get any help with this. EA definitely has the worst support out of any support I have ever dealt with. 


This is literally just a checkbox on my spore.com account that they need to check and they just can't bring themselves to do it.


I would go through support again but I don't need to connect my steam profile to my EA account. And I don't need to connect my spore games to my origin account. Because you know... I already did. So the support staff really can't help me with anything.


The good news is trying to play spore was the only reason that I needed an EA account and since I can't play spore, I don't need the EA account so I can just easily delete it and not use anything from EA ever again and it doesn't make a difference. I feel bad for anybody who actually invested in their EA account.


Based on my interactions with your company it's clear that you only care about my money and once you have my money I don't matter anymore. What else am I supposed to believe????? You won't provide me with any support and you refuse to help me with my problem. You refuse to even acknowledge my problem as far as I can tell.

Message 4 of 12 (3,261 Views)

Re: Spore.com doesn't recognize that I own Galactic Adventures.

★★ Novice

Me too, I'm also having this problem, I can't really seem to share anything to the sporepedia because it doesn't acknowledge that I own GA and since I play through GA sharing any of my spore creatures rather they use the creation tools or not simply won't let me share because it needs to be able to show the games I used in order to share.

Message 5 of 12 (3,250 Views)

Re: Spore.com doesn't recognize that I own Galactic Adventures.

★ Guide
@BucklesFreeman I had a similar problem in the past but it was resolved after chatting with an advisor. But it sounds like the advisors are either not communicating or not trying to help you so you may be SOOL lol. My only advice would be to keep contacting them until you get someone who actually knows how to help you.
Message 6 of 12 (2,998 Views)

Re: Spore.com doesn't recognize that I own Galactic Adventures.

[ Edited ]
★★ Novice

@sfdiusmc Did you need to share a proof of purchase email notification? I talked with an advisor and they couldn't help me because I didn't have the purchase email from 6 years ago despite having website and app proof that I bought it. I'm wondering if I'm just sorta stuck here since I don't have a purchase email from six years ago.

Message 7 of 12 (2,557 Views)

Re: Spore.com doesn't recognize that I own Galactic Adventures.

★★★ Novice

They never asked for that. That's a ridiculous thing to ask for though because it was like 10 years ago and I don't even use that email anymore. But i have a thousand other was to show that I own the game.

Message 8 of 12 (2,456 Views)

Re: Spore.com doesn't recognize that I own Galactic Adventures.

★ Guide
@denbunny They are supposed to ask you for the CD key.
Message 9 of 12 (2,346 Views)

Re: Spore.com doesn't recognize that I own Galactic Adventures.

★ Guide
@BucklesFreeman My friend had the same GA problem and he gave the advisor the CD key and it was fixed immediately.
Message 10 of 12 (2,345 Views)