Help us improve Answers HQ! Take Survey No, Thanks

Unable to launch/start SimCity.

by APeX3181

Original Post

Unable to launch/start SimCity.

★★★★ Novice

It's been over 24 hours since I purchased and I still have been unable to even launch the game.  When I click "PLAY" in Origin, or click the shortcut icon on my desktop, SimCity fails to start.  There is a process in Task Manager labled SimCity.exe that is running, but the game never launches.


What I have don't so far:

1. Uninstalled / Reinstalled SimCity.

2. Uninstalled/ / Reinstalled Origin.

3. Disabled my firewall/antivirus.

4. Enabled NetBIOS over TCP/IP in my connection settings.

5. I can't clear my webstorage folder because one is never created.

6. I have disabled "Origin in Game" in application settings in Origin.


None of these fixes which have been mentioned by users on this forum have worked.  A lot of people are having this issue, and it has yet to be addressed.


Any other thoughts as to what might be causing this?

Message 1 of 16 (5,504 Views)

Re: Unable to launch/start SimCity.

★★★★ Novice


Message 2 of 16 (5,468 Views)

Re: Unable to launch/start SimCity.

★★★★ Newbie

there already is a topic but no solution yet. And you're not alone with your problem Confusedmileyvery-happy:

Message 3 of 16 (5,461 Views)

Re: Unable to launch/start SimCity.

★★★★ Novice

Other threads are being marked as solved because one or two suggestions worked for people.  However, the majority of us are having this issue and I'm inclined to believe the fix is NOT on our end.  I'll keep this marked as unsolved until EA addresses the issue.

Message 4 of 16 (5,455 Views)

Re: Unable to launch/start SimCity.

★★★★ Novice

Well...I saw there was a new update to the game.  I did a fresh install of Origin and SimCity, and STILL....cannot launch the game. WTF?

Message 5 of 16 (5,425 Views)

Re: Unable to launch/start SimCity.

[ Edited ]
★★★★ Novice

Similar problem, installed the game from the disc, installed the patches and updates. The launcher runs okay but when I press play in the launcher Windows gives me a mesage saying Simcity stopped working. No error codes just Windows mesage. I'm running Windows 8 pro 64bits and 2 AMD radeon 7950 in crossfire. Of the solutions people are commenting above here I only tried running as admin but got the same mesage.



Following these instructions my gme is fixed and launches normally


If you can't install launcher and/or launcher doesn't work normally install new launcher.
To obtain a new launcher:

  1. Desinstall SimCity trough Add/Remove Programs
  2. In the Origin client select" Aplication configuration..."and select “Erase all game installers”
  3. Next exit the origin client and restrat it.Download Simcity again and you will obtain a new launcher.

My game is fixed and now works. If you are experiencing similar issues i recomend you try this solution.

Message 6 of 16 (5,419 Views)

Re: Unable to launch/start SimCity.

★★★★ Novice

Wouldn't I have basically done the same thing by completely uninstalling SimCity and Origin and doing a fresh install?


Becasue I've done that several times.  Tried yesterday and still no luck.

Message 7 of 16 (5,368 Views)

Re: Unable to launch/start SimCity.

★★★★ Novice

Yes, it would be the same, the only change could be if you installed from disc or downloaded the game. When I installed from disc it never worked, but when i downloaded the game it did. Anyway after the last update patch it started doing the same thing again, "Simcity stopped working message", so i reinstalled again by the procedure I mentioned before and still got the message of not working. So I tried installing it on another rig and managed to load the game flawless. So I think the game isn't optimized for dual graphics cards or overclocked rigs, which is the a very common setup for todays gamers.

Message 8 of 16 (5,309 Views)

Re: Unable to launch/start SimCity.

★★★★ Newbie

I had a similar issue...

To resovle this for me...

I had to uninstall Origin and simcity...


then I ended up going out to adobe and installing the latest version fo "sun" java...

also ended up having to reinstall my video driver from nvidia...

THEN and only then was I able to launch origin...and get pas the EULA end user license which was blank...

THEN I was able to actually install sim city from disc...AND it was then able to launch...

then it began the update process and actually began to function..


I don't see a single thread in which anyone has mentioned the launch relies on a java based app to check your system video info...


So...lesson is...reinstall java...and then reboot...reinstall the drivers for your video card...

THEN and only then instal origin from


THEN install your application...

Message 9 of 16 (5,052 Views)

Re: Unable to launch/start SimCity.

★★★★ Novice

Hey there,


You may refer the following steps:


In the Origin client click on “Origin”
Select “Application Settings …”
A new window appears. Scroll down to the “Origin Beta Participation” section
Please ensure that all checkboxes have been activated except the option
“Automatically start Origin when I log on to Windows”
Confirm your changes by clicking the button “Done” and restart the
Origin client.


Mine issue is resolved by refer this link. So you may try these steps.



Message 10 of 16 (5,018 Views)


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help