Help us improve Answers HQ! Take Survey No, Thanks

Unable to Find Keybinding Options

by daerimclassic
Reply

Original Post

Unable to Find Keybinding Options

★★★★ Newbie

Specifically, I want to disable the screenshot function bound to the "C" key, as it is my standard push to talk button and Sim City pauses momentarily to take a screenshot every time I try to talk to my friends via Teamspeak.  This is kind of annoying.  As I have zero interest in taking screenshots of this game, the option to disable those would be just as useful to me.

 

As of yet, I've been unable to find a keybind or control option for the game.  Maybe I'm just being blind and someone can point out that it's been hiding in plain sight the whole time?

 

Any help will be greatly appreciated,

James

Message 1 of 5 (2,230 Views)

Re: Unable to Find Keybinding Options

★★★★ Apprentice

keyboard controls are listed here:

 

http://orcz.com/SimCity:_Keyboard_Controls

 

I dont think you can re-assign

Message 2 of 5 (2,201 Views)

Re: Unable to Find Keybinding Options

[ Edited ]
★★★★ Novice

I'm a player from Germany, but with games and movies, I prefere to not having the localized versions (IMHO, lots of humor can get lost during localization). 

So I'm playing SimCity in English. Unfortunately my Keyboard ist a German QWERTZ keyboard, and that means that I cannot use the ~ key to pause the game. I need to use a complicated keycombination with ALT GR to type the ~ which isn't recognized by SimCity. On the US ENglish QWERTY Keyboard, it is reight next to the 1 (which makes sense).

 

That's why I would like to change the keybindings, too, So I can assign another key to "Pause", for example ° (degree symbol - next to the 1 on a QWERTZ Keyboard) or P or SPACE.

Message 3 of 5 (2,197 Views)

Re: Unable to Find Keybinding Options

[ Edited ]
★★★★ Novice

I have this problem aswell... Using a swedish keyboard layout and I too have to use ALT GR to make ' ~ ' which SimCity does not support. Not to mention that I have to double tap on he key to make it AND the key is located on the other far side of the keyboard from 1, 2 & 3.

The fun part is that the key binding was ' § ' (next too 1, 2 & 3 for me) when I bought the game so this sudden change is really dumb beyond regognition... It really surprises me that the developers made such an amateur mistake. Give me the option to assign key bindings myself or patch it ASAP! This really annoys me seriously... :robotmad:

Message 4 of 5 (1,809 Views)

Re: Unable to Find Keybinding Options

Anonymous

Many months after the release and after numerous threads about this particular problem, it seems EA DOESN'T WANT to fix the problem. I think I had the same troubles with The Sims 3 and I guess I would have the same problems with The Sims 4. I hate you so much for this EA! You have no respect for diversity!

Message 5 of 5 (1,315 Views)

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help