Help us improve Answers HQ! Take Survey No, Thanks

Re: Pop up blocker on Pogo

by EA_Stephen

Original Post

Pop up blocker on Pogo

★★★ Newbie

How do I disable my pop up blocker for Pogo on my Mac Pro?

Message 1 of 6 (343 Views)

Re: Pop up blocker on Pogo

EA Staff



If you're using Safari, try the following:


  • Open the Safari Web browser and click the "Safari" menu.
  • Choose "Preferences."
  • Click "Security."
  • Check the box next to "Block Pop-Up Windows" to block pop-ups and remove the check from the box to allow pop-ups.

Hope this helps.

Thank you for being part of Answer HQ Community!
Make sure that you are automatically notified by email when your question gets a reply by clicking the 'Subscriptions' box on the right hand side of the 'New Question' page.
Did a solution help you? Let everybody know by clicking on the "Accept as Solution" button.
If you wish to provide further information or answer a question, click on the "Reply" button.
If you are especially happy with someone's response, reward them by clicking on "XP".
Message 2 of 6 (338 Views)

Re: Pop up blocker on Pogo

★★★ Newbie
Message 3 of 6 (330 Views)

Re: Pop up blocker on Pogo

★★★ Newbie

cant disable popup blockers on pogo games

Message 4 of 6 (320 Views)

Re: Pop up blocker on Pogo

★★★ Newbie
@Stargate19999 When i check high score i get a message that i have popup open
Message 5 of 6 (221 Views)

Re: Pop up blocker on Pogo

★★★ Newbie

Using Safari with macOS Version 10.14.5

Click on Safari in menu bar at top of screen

Scroll to Preferences

Choose Websites at top of preferences window

On left side scroll down to Pop-up Windows, click to open 

On right side is your list of Currently Open Websides and Configured Websites

For each website you can choose:


Block and Notify




Note: If you have Adope Flash Player installed it will show up usder Plug-ins on left.

If you find that your Mac slows way down and that darn beach ball spins forever...

make sure you choose Off or Ask. If you leave it On after you use it for Pogo, you will 

probably have this problem that turns your Mac into a snail.

Pogo will tell you that Flash Player is not installed but when that happens just go to 

your Preferences following the instructions above. Have fun playing Pogo games!

Message 6 of 6 (169 Views)
Twitter Stream