Re: E

by crinrict

Original Post

Error the vc++ runtime redistributable package was not installed successfully

[ Edited ]
★★★ Newbie

I am having major issues with the installation of my Sims 4 game. 


It has no problem downloading, but as soon as it's ready to install I get an error message saying "error the vc++ runtime redistributable package was not installed successfully 1612."

I have tried looking on forums already from various sights with no success. 

I have tried chatting with EA customer service agents, but none of them know what the hell they're doing.


I have tried reinstalling origin multiple different times, and also deleting all the files that comply with it.

Windows is up to date. My drivers are up to date. 

I have tried reinstalling the Microsoft Visual c++ files from the microsoft website and that didn't work. 

I tried going into the program files, origin games, sims 4, installer, vc, and repairing/reinstalling those. That didn't work either. 

I ran CCleaner.

I have tried everything that was suggested and nothing works!
I am extremely frustrated with this.


I have included my system information and DxDiag file. 

Message 1 of 2 (4,110 Views)

Re: E


Did you install the 64 bit version for the redistributable ?


Could you test if the 32 bit version works for testing purposes:

Good Luck


I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.

Important Threads

Message 2 of 2 (4,073 Views)