[CURRENT ISSUE] Error messages with MSVCP140.DLL/VCRUNTIME140.dll

by Dandelionx0
Reply

Original Post

Re: ts4_x64.exe sims 4

Hero
@SamToHam Here's the english version: https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

(the other is German though, not dutch)

Good Luck
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.



Important Threads


Message 21 of 178 (2,661 Views)

Re: Sims 4 won't launch after update

★★★ Newbie

I'm having a similar problem.  getting error  - MSVCP140.dll can't be found.  reinstalled several times and still doesn't work.

 

Message 22 of 178 (2,467 Views)

Sims refuses to run

★★ Novice
 

I am having a problem running The Sims 4, I keep getting both the ‘MSCVP140.dll not found’ error and the ‘VCRUNTIME140.dll not found’ error. I do not have any mods, and have the university pack, tiny living pack, and parenthood pack. I have tried restarting my computer, deleting  and reinstalling origin, and doing the same for the vcredist_x86.exe and vcredist_64.exe files specifically. Even with all of that, I’m still having the issue and have run out of ideas Frown 

Le me know if there is any more information you need.

Message 23 of 178 (2,411 Views)

Re: Sims refuses to run

[ Edited ]
★ Guide

You may need to install the missing Microsoft runtime libraries that are missing. Specifically the one associated with the missing files you mentioned. 

 

NOTE: Check this thread for more information.

 

 

https://answers.ea.com/t5/Technical-Issues-PC/CURRENT-ISSUE-Execution-cannot-proceed-because-MSVCP14...

 

You can find the downloads for the missing runtime library here:

 

https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

Message 24 of 178 (2,401 Views)

Re: Sims refuses to run

★★ Novice
@dimon6579 I have downloaded all of the latest Vc++ files, it still isn't working Frown thanks for the help anyways
Message 25 of 178 (2,387 Views)

Re: Sims refuses to run

★ Guide
@4yy5 Try running origin in Admin mode. Some people reported this allows them to play the game. It is the only other thing i can think of.
Message 26 of 178 (2,379 Views)

Re: Sims 4 won't launch after update

[ Edited ]
★★★★ Guide

Hello there @wynncg1 ,

 

Regarding your MSVCP140.dll, this Article shows how to fix that issue. 

 

I would also take a look at this Thread on AHQ as it shows different fixes users have for the MSVCO140.dll issue.

 

You can also try to download the latest version of VC++ as this might help.

You can download it here.

You need to install both of the following:

  • vcredist_x86_vs2015 (for 32bit Windows version)
  • vcredist_x64_vs2015 (for 64bit Windows version)

-Make sure to run the installer as an Admin. (Right Click, Run as Administrator)

-If it says that the file is installed, try repairing the file instead.

 

I hope this helps!

Happy Gaming and Stay Safe!

-xRarely

Message 27 of 178 (2,370 Views)

Re: Sims refuses to run

[ Edited ]
★★ Novice

@dimon6579tried that, unfortunately it still didn't run and is giving me the same error. Of course the usual fixes don't work for me lol rip

Message 28 of 178 (2,365 Views)

Re: Sims refuses to run

★★★ Novice
@4yy5 I'm in the same spot as you. I have updated everything under the sun and tried all the suggestions. I have uninstalled Origin and TS4. Reinstalling now. It's super frustrating because I am having zero issues on my MacBook Pro. It loads right up. I have no desire to play on a laptop so my fingers are crossed that it the game will start working again on my PC.
Message 29 of 178 (2,356 Views)

Re: ts4_x64.exe sims 4

★ Novice

Still not working for me. Extremely frustrating! now my computer (Which is a gaming computer) is running stupid slow. please fix ASAP!

Message 30 of 178 (2,489 Views)