The Sims Medieval problems on Windows 11

by LBonne24
Reply

Original Post

Accepted Solution

The Sims Medieval problems on Windows 11

[ Edited ]
★ Guide

Stress. I've owned my new gaming laptop for almost 2 days and all I have is stress. I finally upgraded laptops, my old one had lasted 6 years, and it was time to retire her while I could. And I bought one from that fancy smamcy company. And it came with windows 11.

 

I downloaded origin and the Sims games I felt like playing. Including medieval. And only medieval won't work. 2 days of support and now it's being escalated, and I was told to make a thread.

 

Here are the particulars:

  • I had an error message at first bc I  didn't have direct x. Once downloaded we realized I needed the 32bit version and got that too, no dice.
  • No more error message after getting this
  • Already got the .NET framework downloaded for Sims 3 
  • Compatability mode doesn't work
  • Microsoft checked all my drivers etc remotely and I'd had everything already 
  • Fixing the .vc folder doesn't work
  • It just opens origin if you click the shortcut. If you click from origin, you get an hourglass ⌛️ by the cursor and then it clears and that's it. 

Think that's everything. 

Message 1 of 45 (20,579 Views)

Accepted Solution

Re: The Sims Medieval problems on Windows 11

[ Edited ]
★★ Novice

Hey friend!,

 

Good news. I figured it out. And it was all thanks to you for raising your issue, thanks to dear @mate54 for linking the TS3 solution and thanks to person sharing the fix of course. I am sharing the solution right away with instructions.

 

So the code we will be using is:

echo "Launch The Sims Medieval..."

do{
$TSM = Get-Process TSM, SimsMedievalLauncher -ErrorAction SilentlyContinue
}until($TSM)

$Affinity=$TSM.ProcessorAffinity

$TSM.ProcessorAffinity=1

Start-Sleep -s 5

$TSM.ProcessorAffinity=$Affinity

Instructions:

 

0 - Open origin, get ready to click on "Play" button for your The Sims Medieval. Now minimize your Origin. We will use it later.

 

1 - Open your Windows' Notepad application. Regular notepad, nothing fancy. Copy and paste the code. In your notepad window, click on File from menu and select "Save As". When new window pops up for you to save the file, select "All Files" as Save As Type. Also give a name to your file (any name, just pick one). At the end of the name you have given to your file, add ".ps1"

(Adding the ".ps1" extension at the end of your file name, makes it a powershell file)

 

2 - Save your newly created powershell file to your game directory (wherever the TSM.exe is located). Mine was in C:\Program Files (x86)\Origin Games\The Sims Medieval\Game\Bin

 

3 - Make sure compatability setting and run as administrator is off for your original TSM.exe file (since you mentioned that you tried those)

 

4 - Right click on your .ps1 (powershell) file which is now located in your game folder. Select "Run with Powershell". Now a powershell window will pop up and nothing will happen

 

5 - Open your Origin app window and click on "Play" button for your The Sims Medieval. It's play time!

 

Whenever you want to open your The Sims Medieval again, you just need to do the steps 0, 4 and 5.

 

SOLUTION UPDATE : Omg. I didn't even realize that Origin is no longer with us. When did that happen? Anyways. So my powershell file also didn't work and game didn't open.

That's why I searched: can't run ps1 file with powershell.

 

Then I learned that windows changed a powershell security setting to block you from running your own scripts. Aha! I found the solution and voila! my beloved Sims Medieval is working again. Here is the solution: (Yes, not for Origin but for the "EA App")

 

Go to your start menu on Windows. Type "Powershell". When it appears, right click on it and say "Run as administrator"

After your powershell window opens, type:

set-executionpolicy remotesigned

after you do that, windows will ask you if you are ok or not since this is a security setting. You should type the letter Y at this point and hit your "Enter" button. Then the powershell will be working again. You can use my solution I provided in my original response and go into your game. (I did it)

Again, for my solution to work you need to be using gen12 intel CPU for some reason. Again, remember to keep your powershell window open in the background while you are clicking on "Play" button. As it seems, problem wasn't with the EA App but rather with Windows Powershell Security updates.

 

Defeat an evil wizard for me @LBonne24 !

View in thread

Message 10 of 45 (18,367 Views)

All Replies

Re: The Sims Medieval problems on Windows 11

@LBonne24  I've moved your post to the Other Sims Games forum.  Please run a dxdiag and attach it to a post.

 

https://help.ea.com/en/help/pc/how-to-gather-dxdiag-information/

 

I'm not an expert in troubleshooting Sims Medieval by any means, but someone here should be able to help.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 45 (20,561 Views)

Re: The Sims Medieval problems on Windows 11

Champion

@LBonne24 , I can help with Sims Medieval, but not Windows 11 as I'm on a Mac and don't own Windows 11. Do you own Sims 3 and does it play ok? Both games share a similar architecture and if your computer can run Sims 3, it should be able to run Medieval.

 

 

CCP Champion Banner - Blue.png

Message 3 of 45 (20,530 Views)

Re: The Sims Medieval problems on Windows 11

★ Guide

Here's the dxdiag.

 

I haven't tried to play the sims 3 yet but the launcher opens just fine. Even the Sims 2 ultimate works. Only the Sims Medieval is like this.

Message 4 of 45 (20,522 Views)

Re: The Sims Medieval problems on Windows 11

★ Guide

@LBonne24 wrote:

Here's the dxdiag.

 

I haven't tried to play the sims 3 yet but the launcher opens just fine. Even the Sims 2 ultimate works. Only the Sims Medieval is like this.


Actually I just tried the Sims 3 and I take it back only the launcher opens. I can download the things from the store that I own. But can't install and the game won't start and opened origin.

Message 5 of 45 (20,512 Views)

Re: The Sims Medieval problems on Windows 11

Hero

@LBonne24 According to your dxdiag, your laptop has a 12th generation Intel CPU. Unfortunately, The Sims 3 and The Sims Medieval won't run on it without some extra tweaks. This has been reported by every 12th gen CPU owner, and your best chance is to go through this Sims 3 forum post and see if there are any solutions for The Sims Medieval.

 

https://answers.ea.com/t5/Technical-Issues-PC/Sims-3-won-t-open-Alder-Lake-Intel-12th-gen-CPU/m-p/11...

 

I have seen some players post a Powershell script so, if that worked for TS3 players, it might work for The Sims Medieval if modified. Unfortunately, I don't have a 12th gen CPU to test it myself.

CCP Hero Banner - Blue.png


Message 6 of 45 (20,493 Views)

Re: The Sims Medieval problems on Windows 11

★ Guide

I'll go check it out and see how that goes. Thanks. 

Message 7 of 45 (20,473 Views)

Re: The Sims Medieval problems on Windows 11

★ Guide

I went but I don't really understand what I'm supposed to do. What is Power Shell, and how does one save something as a .psi file?

Message 8 of 45 (20,407 Views)

Re: The Sims Medieval problems on Windows 11

Champion

@LBonne24 , PowerShell is a newer version of the Windows Terminal app that was a part of the Windows code that that allows you to access the inner workings of the OS. It appears that this script allows you to run Sims 3 and probably Sims Medieval on newer computers. You can Google exactly what PowerShell is and ways to run the and install code to get games and programs to run on the computer. I would post links, but forum rules do not allow for linking to YouTube or other outside sites.

 

I'm afraid I cannot help you either as I run on a Mac and have older versions of Windows to run my games with Parallels.

CCP Champion Banner - Blue.png

Message 9 of 45 (20,396 Views)

Re: The Sims Medieval problems on Windows 11

[ Edited ]
★★ Novice

Hey friend!,

 

Good news. I figured it out. And it was all thanks to you for raising your issue, thanks to dear @mate54 for linking the TS3 solution and thanks to person sharing the fix of course. I am sharing the solution right away with instructions.

 

So the code we will be using is:

echo "Launch The Sims Medieval..."

do{
$TSM = Get-Process TSM, SimsMedievalLauncher -ErrorAction SilentlyContinue
}until($TSM)

$Affinity=$TSM.ProcessorAffinity

$TSM.ProcessorAffinity=1

Start-Sleep -s 5

$TSM.ProcessorAffinity=$Affinity

Instructions:

 

0 - Open origin, get ready to click on "Play" button for your The Sims Medieval. Now minimize your Origin. We will use it later.

 

1 - Open your Windows' Notepad application. Regular notepad, nothing fancy. Copy and paste the code. In your notepad window, click on File from menu and select "Save As". When new window pops up for you to save the file, select "All Files" as Save As Type. Also give a name to your file (any name, just pick one). At the end of the name you have given to your file, add ".ps1"

(Adding the ".ps1" extension at the end of your file name, makes it a powershell file)

 

2 - Save your newly created powershell file to your game directory (wherever the TSM.exe is located). Mine was in C:\Program Files (x86)\Origin Games\The Sims Medieval\Game\Bin

 

3 - Make sure compatability setting and run as administrator is off for your original TSM.exe file (since you mentioned that you tried those)

 

4 - Right click on your .ps1 (powershell) file which is now located in your game folder. Select "Run with Powershell". Now a powershell window will pop up and nothing will happen

 

5 - Open your Origin app window and click on "Play" button for your The Sims Medieval. It's play time!

 

Whenever you want to open your The Sims Medieval again, you just need to do the steps 0, 4 and 5.

 

SOLUTION UPDATE : Omg. I didn't even realize that Origin is no longer with us. When did that happen? Anyways. So my powershell file also didn't work and game didn't open.

That's why I searched: can't run ps1 file with powershell.

 

Then I learned that windows changed a powershell security setting to block you from running your own scripts. Aha! I found the solution and voila! my beloved Sims Medieval is working again. Here is the solution: (Yes, not for Origin but for the "EA App")

 

Go to your start menu on Windows. Type "Powershell". When it appears, right click on it and say "Run as administrator"

After your powershell window opens, type:

set-executionpolicy remotesigned

after you do that, windows will ask you if you are ok or not since this is a security setting. You should type the letter Y at this point and hit your "Enter" button. Then the powershell will be working again. You can use my solution I provided in my original response and go into your game. (I did it)

Again, for my solution to work you need to be using gen12 intel CPU for some reason. Again, remember to keep your powershell window open in the background while you are clicking on "Play" button. As it seems, problem wasn't with the EA App but rather with Windows Powershell Security updates.

 

Defeat an evil wizard for me @LBonne24 !

Message 10 of 45 (18,368 Views)