Help us improve Answers HQ! Take Survey No, Thanks

Sims 2 on Windows 8

by elmooer

Original Post

Sims 2 on Windows 8

★★★★ Novice

Hello. I try to run the Sims 2 in compatibility mode in Windows 8 but get an error message saying "Direct3D returned an error: E_INVALIDARG!". I'm running it on a laptop and my graphics card is all up to date.

Message 1 of 8 (11,306 Views)

e_invalidarg on Windows 8.1

[ Edited ]
★★★★ Novice

Recently I've got a The Sims 2 Ultimate Collection from Origin. It worked well on my PC, but since I have moved onto an acer laptop I keep getting E_INVALIDARG error when running the game via NVIDIA GPU. I have tried reinstalling drivers, updating windows, updating net framework, repairing Sims 2, chaning compatibility settings, I have also asked both ACER and NVIDIA for help but with no effect so far. Now I ask you if you know how to fix this issue. It happens only when using NVIDIA GPU, the game runs fine but very slow on INTEL graphics.


My laptop:

Acer Aspire v5-573G

Intel Core i5-4210U 1.7GHz with Turbo Boost up to 2.7GHz

NVIDIA GeForce GTX 850M with 4GB Dedicated VRAM


Message 2 of 8 (11,126 Views)

Re: e_invalidarg on Windows 8.1

Community Manager

Find and run the following file in your Sims 2 install folder: DXSETUP.exe


If that does not fix this then update or reinstall your nvidia video drivers and during the install process choose custom install and then tick the box for Clean Install.

If a post Answers your question please click on Accept as Solution.
Thank players and help them 'Level Up' by giving them XP.
Thank you for sharing your gaming expertise with your fellow players!
Message 3 of 8 (11,113 Views)

Re: e_invalidarg on Windows 8.1

★★★★ Novice

I don't have DXSETUP in _Installer folder, I also don't have installation files(origin deleted them after the game was installed). I have ugraded DirectX with with a web installer from Microsoft site. I have also reinstalled drivers using clean install but with no effect.

Message 4 of 8 (11,109 Views)

Re: e_invalidarg on Windows 8.1

★★★★ Novice

So, can anyone help me on that? I heard E_INVALIDARG is a .NET Framework related proble. I have NET Framework 3.5 installed by default(it contains older versions as well) but I have also installed newest frameworks as well. Still without success.

Message 5 of 8 (11,093 Views)

Re: e_invalidarg on Windows 8.1

★★★★ Newbie

If I am reading right, you have the same computer as me. It has an NVIDIA graphics card and Integrated graphics, right? For some dumb reason, the computer is designed to run the NVIDIA card THROUGH the Integrated Graphics, and you can't turn this off. I did find a solution, however:

For me, what fixed it was to go into the Nvidia Control Panel, click "Manage 3D settings", click the "Program Settings" tab, and then add Sims 2 (Default path if you have the ultimate edition is Program Files -> Origin Games -> Sims 2 (Ultimate Collection) -> Fun with Pets -> SP9 -> TSbin -> Sims2EP9. You then want to tell it to run off the INTEGRATED GRAPHICS instead of the Nvidia Card.

That being done, you should be able to run it in compatability mode (I used Windows 7) and also as an administrator. I have been troubleshooting this problem for the past three days, and as such have fiddled with a lot of things, but it wasn't until I did the above thingy that it would run for me. Good luck!

Message 6 of 8 (9,929 Views)

Re: e_invalidarg on Windows 8.1

★★★★★ Novice

EA_Barry, I am trying to do this with The Sims: Life Stories. It has a DIAG.EXE file on it. Is this what you mean?

Message 7 of 8 (5,290 Views)

Re: e_invalidarg on Windows 8.1

★★★★ Novice


Message 8 of 8 (1,412 Views)

Want more Sims?

Check out our Sims forums for tutorials and all things Sims.

View more


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help