Help us improve Answers HQ! Take Survey No, Thanks

Origin version Simcity 4 won't start (Win10)

by miax64
Reply

Original Post

Origin version Simcity 4 won't start (Win10)

★★★★ Newbie

I've just bought the SimCity 4 game in Origin. I'm running a VM with Windows 10 where Origin and the SimCity game are installed.

 

However, I can't get it to work. I've searched this forum, but a lot of question go about the old (not Origin) version of the game which is not suitable for me. Also I tried almost all start-up commando's (and al sorts of combinations of these) like:

 

-f or -w (fullscreen or windowed mode)

-d:Software (to render it on software)

-BackgroundLoader:off

-Cursors:fullcolor

-Intro:off

-CPUPriority:high

-CPUCount:1

 

But none of them seem to start the game. The best luck I had with this (combination) commando:

-f -d:Software -BackgroundLoader:off -Cursors:fullcolor -Intro:off -CPUPriority:high -CPUCount:1 

 

But this only could let me run the game for 5 seconds without crashing. 

 

I've also tried playing with the VM settings; like enabling / disabling 2D and 3D rendering of the graphic card. All don't matter.

 

Can anyone help me? I'm kind of lost as I did pay for a game which I can't play now.

Message 1 of 1 (335 Views)

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help