Unplayable: Game does not start after EAC splash screen

by neo_razgriz

Original Post

Accepted Solution

Unplayable: Game does not start after EAC splash screen

[ Edited ]
★★★★ Apprentice

Product: Star Wars: Squadrons
Please specify your platform model. PC
What is your gamertag/PSN ID/EA Account name? neo_razgriz
Are you playing in VR? Yes
Which VR Platform are you using? Steam VR
Which part of the game is the issue happening in? Other
Please explain 'Other' EasyAntiCheat Splash screen
What were you doing when the bug occurred? Step by Step detail is helpful. Launching the game
Where did this issue occur? Please include menu name or in game location. EasyAntiCheat Splash screen
When did this happen? (dd.mm.yy hh:mm) 02.10.20 11:36 UTC
How often does the bug occur? Every time (100%)
How severe is your issue? Can't play
What happens when the bug occurs? Game shows splash screen, then closes with no indication. I can see starwarssquadrons.exe.local file being created and then deleted.
What do you expect to see? Game should start
Which ship were you playing? If not applicable, just answer "no" or "none." none
What components were you using? none
Which customizations (if any) were you using? none


This also happens to another friend who just bought the game (different PC specs).

Tried solving by:

  • Updating nVidia drivers
  • Windows update
  • Run as administrator
  • DPI compatibility mode
  • Disable antivirus
  • Verify integrity of game files.
  • Launch in non-vr mode.

DxDiag info attached

Message 1 of 109 (32,735 Views)

Accepted Solution

Re: Unplayable: Game does not start after EAC splash screen

★★★★ Apprentice



make sure your antivirus is not loading any dll or hook for programs that are launched on your PC.


My antivirus loads a dll for every program that launches on my machine (to check if it is safe, quarantine it, etc...).
Easy anti-cheat does not like this, and quits the game.
There is no log entry anywhere for this behavior.


I had the same thing happen to me with Back4Blood beta, but this time, there was a log entry in Windows event viewer! (under "Application")

So, i completely shut down my antivirus and made sure the dll is not loaded.

And now, Squadrons works! as well as Back4Blood, but only if i completely exit my antivirus.
Exclusions don't work, shutting down specific features doesn't work, it has to be shut down completely.


If you have completely shut down your antivirus, and this is still occuring, try uninstalling it.
If uninstalling the AV solves it, contact your AV vendor's support for a solution.

If none of the above solve is for you, i'm very sorry but there is nothing more i can help with, please create a new thread, and feel free to post a link to it in the comments.

Hope this helps some of you.

View in thread

Message 102 of 109 (22,564 Views)

All Replies

Re: Crash at splash screen

★★★★ Apprentice
Update: Refunded on steam, bought on EPIC store, still same issue.
Message 2 of 109 (32,656 Views)

Re: Crash at splash screen

★★ Apprentice

I am having the same issue.  I played for 3 hours last night.  Now I can not get passed the splash screen.  Tried repair, unsintall ( twice) repair anti cheat , DDU drivers and do fresh set of drivers for Nvidia.  Anti Virus on and off.  Nothing works now.




32gb ram

SSD etc etc.



Message 3 of 109 (32,656 Views)

Re: Crash at splash screen

★★★ Novice

same issue here


Ryzen 3950


32gb ram


tried changing my origin drive from D to C to see if that made a difference and it doesnt.


Havent even been able to launch it once though!

Message 4 of 109 (32,636 Views)

Re: Crash at splash screen

★★★ Newbie
same problem, im on Epic and non VR, otherwise the same: get to splash screen for 2-3 seconds, get some low strange scrambled noises. then it crashes to desktop

I tried to use a dedicated usb card as well.
I'm running on a new legion laptop, everything is fresh.
newest nvidia driver,newest windows build,all systems drivers latest.
win 10 nvidia rtx 2060 mobile
deactivated overlays etc

bought via epic games, i get the same result starting with origin
Message 5 of 109 (32,622 Views)

Re: Crash at splash screen

★★ Novice

I am so glad I'm not the only person who was able to play for a bit with VR on launch night and can't get past the Easy Anti-cheat screen today.


I get error 15, 26, or 29 on both Epic/Origin and Steam.


At this point I reckon it's something to do with EAC today, since this wasn't an issue last night.



Message 6 of 109 (32,559 Views)

Re: Crash at splash screen

★★ Novice

I was able to get the game to run by launching it through GeForce Experience.


As of this morning's update, game still crashes during EAC loader through Steam but GeForce still loads it (so they didn't break that Party hat )


Still waiting on a tech support response from EAC.

Message 7 of 109 (32,528 Views)

Re: Crash at splash screen

[ Edited ]
★★★★ Apprentice

@astragoblinThanks for the suggestion, but it didn't work for me.

I should mention that i was never able to launch the game, and that i get no error from EAC or at all.


Also, after it crashes, it focuses the Origin window


- I have installed Origin on drive D:\ and the game is installed on drive G:\
- My EAC install/repair screen doesn't specifically list the game:


Message 8 of 109 (32,521 Views)

Re: Crash at splash screen

[ Edited ]
★★★★ Apprentice

Update: I have reached out to EA tech support, case ID: 65802577
They are now performing advanced steps to resolve the issue, I'll be checking in with them every day or so.


I have also opened a ticket with EAC, have not heard from them yet.


In the mean time, here are some more things i tried (that didn't work):
- Uninstall all RGB/Hardware control software
- Install the game on the same drive as the launchers (D:\)
- Cleared Origin cache (as described here)

- Performed "Clean Boot" (msconfig).

If anyone has the same problem, please click the "Me Too" button at the OP, and reply with your symptoms and troubleshooting steps.
We're in this together, let's hive-mind this thing to death (or until EA notices).

Since i made no significant progress, i'm just going to update this reply so as not to flood this thread with failed troubleshooting steps

According to EA support, the game should open in a separate window while the EAC splash screen is still open. This does not happen for me, the splash screen just closes, no other window is opened.

The above makes me feel like it might be a bug with EAC after all...

Message 9 of 109 (32,485 Views)

Re: Crash at splash screen

[ Edited ]
★★★★★ Novice

same here except non VR and different hardware.

3900x 1070Ti 64G

Mine's thru Epic


I was able to launch the game on launch day after they solved the epic store link issue. Today when I tried to play, it asked for update so I did and then what OP described happened.


This youtube vid seems to be showing exactly what's happening to us:


Message 10 of 109 (32,424 Views)