Help us improve Answers HQ! Take Survey No, Thanks

NFS Undercover (Origin Version) stuck on command line

by FirehawkV21
Reply

Original Post

Highlighted

NFS Undercover (Origin Version) stuck on command line

★★★★ Novice

I have purchased NFS Undercover on Steam recently. After finding the license key and activating it on Origin, I re-installed the game through Origin. When I try to run the game, it gets stuck to the command line (the window that shows up before the game starts). I tried various compatibility modes, I re-installed PunkBuster and nothing happened. The Steam version worked fine on my laptop, so what gives? Is there a way to fix this? I can't patch the Steam version to the latest one.

Message 1 of 1 (165 Views)

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help