Help us improve Answers HQ! Take Survey No, Thanks

Populous: The Beginning

by franktubbs
Reply

Original Post

Highlighted
Accepted Solution

Populous: The Beginning

[ Edited ]
★★★★ Novice

I have a problem with Populous Basketball: The Beginning.

The game installs fine, but when i try to start it, i get this error:

"Ordinal missing - Ordinal 3 can not be found in C;\Program Files (x86)\Electronic Arts\Bullfrog\Populous\WEANETR.DLL".

I have searched on the web for solutions, all i found is a post on GoG forums from 1 other person who has the exact same problem, but then with the game Dungeon Keeper 2.

As both games are published by EA, i find it very strange that EA only offers support/help for the first prequals of these 2 games (Populous 1 and Dungeon Keeper 1 are both listed in Origin, Populous 2, populous 3 and Dungeon Keeper 2 are nowhere to be found strangely).

 

I already contacted Microsoft about this problem, but they forwarded me to EA, since according to Microsoft, WEANETR.DLL is a file made by EA (or any sub-company of EA like Bullfrog).

I already contacted EA Holland by telephone, but they refuse to help with this because according to them "the game is too old".

When i asked why they do offer support for Populous 1 and Dungeon Keeper 1 (which are even older than Populous 3 and Dungeon Keeper 2) they said they couldnt answer that,,,

I find this very frustrating, that a company doesnt offer any help in any way because the game is too old.

Im not an experienced programmer, but from what i have heard, it would only take about 5 to 15 minutes to update the WEANETR.DLL's ordinal 3 for an average programmer who has experience with DLL files...

As i am part of Populous Reincarnated www.popre.net (the website which offers a multiplayer service with all kinds of extra's for Populous 3) you can understand that this is quite a problem for me.

I want to be able to play the game just like anyone else (i seem to be the only person with win8,1 who cant play right now), so if someone could help with this, i would appreciate it alot!

 

Hope to hear a solution here!

TheGabber.

Message 1 of 44 (9,032 Views)

Accepted Solution

Re: Populous the beginning wont start

Community Manager

That's great, thanks. Just to check it off, have you tried launching just the PopTB exe in Windows XP SP3 compatibility mode?

View in thread

Message 35 of 44 (6,576 Views)

All Replies

Re: WEANETR.DLL

[ Edited ]
Community Manager

@franktubbs Hi,

 

  1. Where did you buy the game?
  2. How did you install it? 
  3. Where did you install it to?
  4. Which operating system are you trying to run the game on?
  5. Have you tried using compatibility mode?
  6. Did you try installing it to another location?
  7. And last but not least, is the semi colon just a typo when you put the error in here or does it actually read exactly like that in the message? "Ordinal missing - Ordinal 3 can not be found in C;\Program Files (x86)\Electronic Arts\Bullfrog\Populous\WEANETR.DLL".

Also, is this your thread here? (Would let me skip some of the questions.) 

 

Cheers,

Nils

Message 2 of 44 (8,985 Views)

Re: WEANETR.DLL

[ Edited ]
★★★★ Novice

1. I first baught the game about 16 years ago, at the Vroom and Dreesman (in Holland) if i remember correctly. I also baught the ptatinum one 10 years ago.

The one from 16 years ago is the US version, the platinum one is EU. Tries installing both, both give same error.

2. I installed it with the setup file which autoruns when you put the cd in.

3. I installed to c:\program files (x86)\electronic arts\bullfrog\populous\, also tried to install to c:\electronic arts\bullfrog\populous\, without changes.

4. Im running windows 8,1

5. Tried all compatibitity modes on both software and hardware mode of the game (poptb.exe and d3dpoptb.exe),

6. See answer 3

7. Its in Dutch, i just used a rough translation of the error in English "D3DPOPTB.EXE - Ordinaal niet gevonden: Kan de ordinaal 3 niet vinden in DLL-bestand C:\Program Files (x86)\Electronic Arts\Bullfrog\Populous\weanetr.dll."

(Exact translation should be: "D3DPOPTB.EXE - Ordinal not found - cannot find/locate the ordinal 3 in DLL-file C:\Program Files (x86)\Electronic Arts\Bullfrog\Populous\weanetr.dll.")

The ; was a typo..

 

And yes the thread on popre.net forums is made by me, as you can see im getting really frustrated by this error, not only because i dont know how to fix it but also the fact that EA customer support in Holland is really bad...

Message 3 of 44 (8,977 Views)

Re: WEANETR.DLL

[ Edited ]
★★★★ Novice


Words of EA holland's telephone customer support: "sorry but we are not allowed to help with 15 year old games, if you would have had problems with Fifa we would have helped you"

 

So i ask "why do you still give support for populous 1 then, its even on origin", i get answer "we cannot answer this question, sorry".

Message 4 of 44 (8,975 Views)

Re: WEANETR.DLL

★★★★ Novice

In other words, they give support for a game made in 1989 (populous 1) but no support on a game from 1998 (populous 3).....

Reason enough for my frustration...

Message 5 of 44 (8,967 Views)

Re: WEANETR.DLL

Community Manager

@franktubbs Hi,

 

The reason we do offer support for the other Populous games is that they were recently added to the Origin store and hence are still actively being sold.

 

This isn't the case with Populous: The Beginning. In fact I can't get a copy even, making it very hard to reproduce this issue. 

 

While my personal guess would have been on the lacking backwards compatibility for Windows 8.1, the GoG page seems to suggest there might be an issue related to the GPU. Check the following requirements, is there any chance you do have one of those GPUs that aren't supported or a GPU driver that is newer than the 13.4 version?

 

Compatibility notice: Newer AMD cards (7XXX, 8XXX, and the Radeon R series) are not supported.

 

ATI/AMD compatibility notice: Populous: The Beginning requires graphic card drivers version 13.4 or older.

 

Minimum system requirements: Windows XP or Windows Vista, 1.8 GHz Processor, 512MB RAM (1 GB recommended), 3D graphics card compatible with DirectX 7 (compatible with DirectX 9 recommended), 2GB HDD, Mouse, Keyboard.

 

Cheers,
Nils

Message 6 of 44 (8,961 Views)

Re: WEANETR.DLL

★★★★ Novice

I have played this game for about 4 years on this same pc with windows xp, my graphics card cannot be the problem since the same problem occurs when i start the software mode exe of the game (as i said in previous post, both poptb.exe and d3dpoptb.exe give same error).

As you may have read on the forums of popre.net, you should have noticed someone else is also looking at this problem, he thinks it has to do with winsock.dll or wsock32.dll (as thats what ordinal 3 in weanetr.dll refers to or something according to him).

 

Message 7 of 44 (8,958 Views)

Re: WEANETR.DLL

[ Edited ]
★★★★ Novice

And this isnt a backwards incompatibility at all, otherwise the other people who use win8,1 should have the same problem, yet they can play the software mode without problems, as you said most GPU's of nowadays dont support populous hardware mode (d3dpoptb.exe) although there seem to be few people who are able to play in hardware mode.

I myself have a ATI Radeon 7570 HD with driver version 13,4 so i "should" also be able to play in hardware mode, afterall i was playing on xp with same GPU in hardware mode, the only thing changed in my pc is the OS, from XP to win8,1..

Anyways, populous is playable on both win8 and win8,1. i just dont understand why not for me...

Message 8 of 44 (8,957 Views)

Re: WEANETR.DLL

[ Edited ]
Community Manager

At least for the Gog version, it seems that your graphic card isn't supported.

If the game worked just fine on Windows XP however, I'd suggest to just set up dual boot.

Message 9 of 44 (8,951 Views)

Colors are distorted in older game

★★★★ Newbie

I just bought Populous: The Beginning, a game I already owned the disc for but have had trouble getting it to run on newer windows systems. When I start up the game everything is purple/yellow/red/blue pixels, not even close to what it should be. This is the exact problem I was having with my hard copy as well and I had hoped buying it on Origin would have provided a fix for this on newer systems. It is entirely unplayble this way, it's almost impossible to even navigate the menus let alone try and play a map. My system is running on Windows 7, on the basic color settings instead of Aero. 

Message 10 of 44 (8,926 Views)

fifa-19-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help