Freezing issue in The Exiled Prince

by Fred_vdp
Reply

Original Post

Accepted Solution

Freezing issue in The Exiled Prince

[ Edited ]
Hero

Note: This issue was posted before, but the OP selected a comment as solution while it did not in fact contain a solution. I hope the issue attracts more attention if I repost it.

 

The issue is that in the Exiled Prince DLC, starting with the mission Repentance in Act 2, some of the cutscenes are preceded by the game starting its fade-to-black transition, but freezing halfway through the transition and it shows the word 'loading' in an infinite loop. In the quest repentance (act 2) you can skip this by pressing escape. Not so in the quest faith (act 3).

 

 

I have the Dragon Age II Signature Edition (v 1.04). I attempted reinstalling the DLC. I didn't uninstall it first because I'm not sure which files need to be deleted.

 

Specs:

 

AMD Radeon HD 6870 (Catalyst 12.10)

AMD Phenom II x4 965 BE (3.4 Ghz quad-core)

4 GB Ram

Windows 7 Ultimate 64-bit

 

The problem occurs on both the DirectX 9 and 11 renderer. I have installed both DX9 and 11.

 

Update

 

In the quest Faith, the freeze occurs right after killing the apostates and before the cinematic starts where Leliana appears. If you do a hard save right after the fight (after the fight, hit escape really quickly), and load through the main menu (don't choose 'resume'), Hawke stands frozen but the dialog wheel does pop up. Click on one of the options, press escape, and the dialog with Leliana can initiate. However, a new freeze occurs later during the conversation and since you can't save during a dialog, the previous workaround will not help me here.

 

I will post more details if I find out more.

 

Update 2

 

Here's a video that shows what happens after using the aforementioned workaround, but as you can see, there's a second freeze that can't be skipped.

 

Video on YouTube (ACT 3 SPOILERS)

 

Update 3 - Solution

 

Patch 1.04 is the culprit. I reinstalled the game and patched it to version 1.03.



CCP Hero Banner - Red.png


Message 1 of 68 (46,964 Views)

Accepted Solution

Re: Freezing issue in The Exiled Prince

★ Apprentice

I know this is a major necro, but I've been struggling with this issue again.

 

I've found a workaround that actually works, without having to reinstall.

 

This error only happens with Legacy installed - I was experimenting, and discovered that if you update to 1.04 without Legacy, it's fine. Some more playing, and I have a workaround that works without killing saves:

 

 

1. go to your program files -> DA2 folder -> addins

2. In addins, find prc_drk_ something

3. inside that folder, open module

4. select teh 'patch' folder, and "cut" it to the desktop

 

Play Seb's quests - it should work perfectly normally

 

Replace the patch folder when you are done.

 

You could just delete the patch folder completely, but then you won't get the dialogue fixes it got in 1.04

 

 

View in thread

Message 24 of 68 (54,138 Views)

All Replies

Re: Freezing issue in The Exiled Prince

[ Edited ]
Hero

The problem is patch 1.04, so my advice to anyone is to just not download it. Instead, install patch 1.03. You can find it on FilePlanet.

 

If you already have v1.04 installed, I'm afraid you'll have to reinstall the game.



CCP Hero Banner - Red.png


Message 2 of 68 (46,833 Views)

Re: Freezing issue in The Exiled Prince

★★★★★ Novice

So basically you are telling us that we need to start from scratch?  All of my saves are with Patch 1.04.  I would have to lose every single save I have to even use this DLC I just purchased?   That is not acceptable. Why can this simply be fixed instead of asking us to lose all of our saves.  In addition we lose all of the other fixed in 1.04.  This is a simple bug to fix, isn't it?  It looks like it is trying to load something that is not there as far as I can tell. 

 

Honestly this is poor business practices to tell us because you have a patch that breaks something you are not willing to fix it. 

 

Terrible.

 

 

Message 3 of 68 (46,685 Views)

Re: Freezing issue in The Exiled Prince

Hero

Your saves should work with patch 1.03 as well. I reinstalled with 1.03 and was able to continue playing.



CCP Hero Banner - Red.png


Message 4 of 68 (46,647 Views)
0

Re: Freezing issue in The Exiled Prince

★★★★★ Novice

Fred, god Iwish you were right, however when I got an error that said "please install the correct Patch in order to continue".  I can try it again....and let you know.

Message 5 of 68 (46,645 Views)

Re: Freezing issue in The Exiled Prince

★★★★★ Novice

Reinstalled DA2, Applied Patch 1.03, getting a load Patch error on anything that had the DLC installed and saved it seems. I am losing a lot of my saves due to this.  Makes me feel like I am wasting my time.

Message 6 of 68 (46,637 Views)

Re: Freezing issue in The Exiled Prince

★ Guide

I am doing a reinstall right now, and hoping that will fix it but please FIX THIS BIOWARE!!!!!  We shouldn't have to roll back to a previous patch or even worse restart the entire game because of an issue like this.

Message 7 of 68 (46,610 Views)

Freezing issue in Exiled Price NOT SOLVED. Bioware needs to patch it to fix it!

★ Guide

Detials on the issue are here at http://answers.ea.com/t5/Dragon-Age-2/Freezing-issue-in-The-Exiled-Prince/m-p/219604#U219604

 

The "workardound" of installing a previous version patch of 1.03 (which you can't even get from Bioware's site, but most go through a third party site to obtain) is not acceptable as a "solution"

 

It's a workaround nothing else.

 

Bioware needs to fix this issue because there are many fixes in 1.04 of other bugs/issues.

Message 8 of 68 (46,421 Views)

Re: Freezing issue in The Exiled Prince

★★★ Newbie

I have the same issue. After contacting support they told me to revert (re-install the game) to patch 1.03. All my save games won't work! I have litle time to play. I pay for all EA games with all DLC and I want them to work like expected! This is indeed a stupid bug you should fix EA/Bioware. I spend 39 hours to get at this point and there is not even an option to return out of this quest because all doors are shut in this stage of the game when you are inside the building. I tried everythin, even on another computer. Please fix this.

This is why people like me will stop paying for DLC and even for games. Believe me, I have 100+ games which I payed for.

 

FIX IT

 

Thx

 

A father of 4 kids with little gaming time.

Message 9 of 68 (46,432 Views)

Re: Freezing issue for discussion in here, not for FIXES

[ Edited ]
★★★★★ Expert

@bartv2000 wrote:

This is indeed a stupid bug you should fix EA/Bioware.. Please fix this.



Bioware's people don't read anything in here.  This is a Gamer to Gamer discussion forum (same as it was on the Social Network, same as before that, on the old Legacy forums).  I can't fix your game, none of the people who might be able to repair the bug, if that's what it is, will ever learn about your unhappiness with them from this vector. 

 

Message 10 of 68 (46,430 Views)
0
Twitter Stream