EA App doesn't see my Battlefield 1942

by Pathfinder75thB

Original Post

EA App doesn't see my Battlefield 1942

★★★ Newbie

Through my EA Origin Account, I downloaded the Battlefield 1942 Game on my Windows 10 Machine.  Recently updated to Windows 11, made sure that my Origin Games Folder was set correctly, then it wanted me to use an EA App that would download the APP and uninstall my Origin Software.  My other 3 Games are seen through the EA App but it doesn't see my BF1942 that I downloaded.  I legally purchased BF1942 back in the day, I even still have the CD-KEY.  About a year or 2 ago, Origin allowed me to download BF1942 through the EA Origin Program.  It launched it worked.  Now the EA APP doesn't even seen my install folder to allow me to access my BF1942.  Is there any resolution of this.

Message 1 of 5 (702 Views)

Re: EA App doesn't see my Battlefield 1942

[ Edited ]
Community Manager

@Pathfinder75thB Hey, so this title is one of the games that have been sunset. You can check out the full list of games here. Unfortunately, if it is not listed in your library of games, there is no longer a way to get that added back.


I would also try the following and see if this helps. As long as the key was registered to the same account, once you played it, it should be there.

EA App's Cache (Top Left Menu > Help > App Recovery)


Delete Windows Temp Files

  • First, make sure you close as many programs as you can
  • Press the Windows key + R, go into the file explorer
  • Type in %temp%, and hit Enter
  • Delete everything it allows you to delete
  • Reboot the PC


Accept as Solution button- If a post answers your question please let us and other players know by hitting this button.
Me Too button - 'Me Too' helps us track how many players are also experiencing that issue. Definitely make use of this button.
XP button - Say Kudos and help players 'Level Up' by giving them XP for helpful posts.

Message 2 of 5 (669 Views)

Re: EA App doesn't see my Battlefield 1942

★★★ Newbie

I legally purchased BF1942 from EA games and I was forced to <upgrade> it using the painful Origin client. Now I want to play the game again and as soon as i launch the origin client it uninstalls itself and installs the EA client. In the EA client I see my other BF games but not bf1942 which is the one I want to play,

the fact that you won't let me reinstall a game i've paid for and want to play becuase you've "sunset it" leads me to one very very clear conclusion,


I will NEVER buy another EA game EVER AGAIN. <------------------------------------


this is NOT how to treat customers.


shame on you.

Message 3 of 5 (640 Views)

Re: EA App doesn't see my Battlefield 1942

★★★ Newbie

I still have the original cd's for this game as I bought it from a shop... and I want to play it. But my laptop doesn't have a cdrom drive, how am I supposed to install the game i want to play ?

Message 4 of 5 (637 Views)

Re: EA App doesn't see my Battlefield 1942

★★ Guide



Have you tried redeeming the key into the EA app? I did few years ago and worked fine (they release a digital copy of the game back in 2012). Even though the game is sunset you might be able to redeem it, no expasions packs though. 


Another thing is, if you had it in your Origin library, you should have it in the EA app (mine didnt dissapear). Worst case is to have to contact supoport, i reccomend chat but be sure to have proof of purchase and if that dont work ask them to try to redeem your key.

Hope this helps,m



Message 5 of 5 (504 Views)