Help us improve Answers HQ! Take Survey No, Thanks

Re: Origin preventing windows shutdown windows 10

by KMBak
Reply

Original Post

Highlighted

Re: Origin preventing windows shutdown windows 10

★★★ Newbie

I have same issue. Got a clean install of Windows 10 x64 and now Origin is preventing my PC from shut down. Every time I have to wait around 4s to shutdown PC (SSD).

Message 71 of 169 (1,258 Views)
Highlighted

Re: Origin preventing windows shutdown windows 10

[ Edited ]
★★★★ Novice

Me too. Fresh install of Origin (Version 10.3.2.64936 - 0), now it prevents Microsoft Windows 10 from shutting down each time unless I forcibly exit the Origin client. Probably just some buggy code in there making Windows 10 think the program is active. 

 

As a workaround for this Origin bug, you can do this:

 

* Click the Windows icon, type regedit then press enter to open Registry Editor

* Go to the following key: HKEY_CURRENT_USER\Control Panel\Desktop

* In the right-hand pane, right-click on an empty area to create a new String called AutoEndTasks and set its value to 1

* Close Registry Editor, Origin and restart your computer for the change to take effect.

 

This will automatically end tasks for you when you shutdown, pretty much like you'd expect the OS to function when you issue a shutdown command!

Message 72 of 169 (1,211 Views)
Highlighted

Re: Origin preventing windows shutdown windows 10

★★★★ Novice

I posted this solution few pages eralier.

Message 73 of 169 (1,198 Views)
Highlighted

Re: Origin preventing windows shutdown windows 10

★★ Novice

You posted a workaround for the problem that causes other issues, whether they affect you directly or not. Noone has posted a solution yet and as of the newest version of Origin, the problem still exists.

Message 74 of 169 (1,166 Views)
Highlighted

Re: Origin preventing windows shutdown windows 10

★ Novice

Im asking EA to fix it. Its very annoying error. Its proof that Origin is worse than Battlenet or Steam even Uplay.

Message 75 of 169 (1,123 Views)
Highlighted

Re: Origin preventing windows shutdown windows 10

★★★ Novice

I was able to pin-point the problem for me.

The error with Origin only occurs when I'm running an application called "HsMgr Application" in the Windows startup programs.

I have 2 "HsMgr Application"s in the startup programs that look the same from the Task Manager (Same name)... When I look to the files they're different though:


C:\Windows\SysWOW64\HsMgr.exe

C:\Windows\System\HsMgr64.exe

 

This file: C:\Windows\SysWOW64\HsMgr.exe is the one I disabled from startup. Now Origin doesn't crash when I shut down.

From the looks of it through some google searches, these files are related to my ASUS Xonar Soundcard... So I'm not a fan of disabling them. I could be hindering my sound-card for the sake of preventing an Origin error.

 

I doubt I can expect a solution from ASUS, my drivers are the latest and from October 2015. So, I would think the only chance for a real solution would be from EA/Origin since that is the only program I can get this error from.

Message 76 of 169 (1,249 Views)
Highlighted

Re: Origin preventing windows shutdown windows 10

★★★ Novice

If the asus sound cards really are the problem it is their problem to fix. I myself too have a asus sound card so it makes sense. And HsMgr is needed for some of the sound cards features like "GX". And I have got the same error on some other applications too.

Message 77 of 169 (1,232 Views)
Highlighted

Re: Origin preventing windows shutdown windows 10

★★★★ Novice
Xonar on board too. On both computers. But it surely not only issue. Becasue Skype on laptop behaviours the same...
Message 78 of 169 (1,224 Views)
Highlighted

Re: Origin preventing windows shutdown windows 10

[ Edited ]
★★★ Novice

It could be an issue of ASUS installing both 32-bit and 64-bit software and only needing the 64-bit version on my 64-bit OS, so there is a conflict from programs that use it... if so, its possible disabling the 32-bit HsMgr.exe only as I've done will have no effect on the sound quality or limit it in any way. Only stop the errors.

 

If that is the case, disabling the 32-bit version is really no different than a fix from ASUS.

 

Then again, maybe it installs both, for 32-bit and 64-bit programs... Idk. But in order to prevent the error I don't really have any other option. So here's hoping

Message 79 of 169 (1,204 Views)
Highlighted

Re: Origin preventing windows shutdown windows 10

★★★★ Novice
In any case origin should solve that not us ...
Message 80 of 169 (1,193 Views)
Twitter Stream