Help us improve Answers HQ! Take Survey No, Thanks

Origin launcher, "well that didn't go as planned" other fixes not working.

by beanyboy90792
Reply

Original Post

Highlighted
Accepted Solution

Origin launcher, "well that didn't go as planned" other fixes not working.

★★★ Newbie

I haven't been able to gain access to my origin account for a few months now I can bring up the launcher and type in my login details but when the launcher loads all i get is a screen saying "too many redirects" then it says "well, that didn't go as planned. origin encountered an issue loading this page. try reloading it if that doesn't work restart the client or try again later"

This has been the case for about 3 months now, If I launch it with admin privileges it brings up two instances, one shows everything above, and the other works fine but wont let me play any online games at all (they will load but will not connect to any servers)

 

I have been in the firewall settings and there isn't anything there to allow me to enable the launcher through the firewall so I added the setup launcher hoping that would work but it didn't.

 

I have uninstalled and reinstalled the client about 5 times now at different times in the last 3 months or so and the problem is the same i'm not sure if this would fix the cache issue I've read about by default if not then please let me know.

 

I can launch the client fine and play games on other computers, just not on my main desktop.

 

thanks for any help you can give me and have a great day!

Message 1 of 2 (115 Views)

Accepted Solution
Highlighted

Re: Origin launcher, "well that didn't go as planned" other fixes not

★★★ Newbie

I feel like an idiot. I didn't delete the cache files manually like I read about as I figured they would just be deleted by uninstalling the client so many times. I was wrong.

 

This fixed the issue for me!

 

 

View in thread

Message 2 of 2 (106 Views)

All Replies
Highlighted

Re: Origin launcher, "well that didn't go as planned" other fixes not

★★★ Newbie

I feel like an idiot. I didn't delete the cache files manually like I read about as I figured they would just be deleted by uninstalling the client so many times. I was wrong.

 

This fixed the issue for me!

 

 

Message 2 of 2 (107 Views)
Twitter Stream